Closed Thread
Results 1 to 6 of 6

Reload Thread: Mechman 270

  1. #1
    Rocky213's Avatar
    Rocky213 is offline Member



    Join Date
    Jul 2010
    Location
    Miami
    Posts
    130
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Mechman 270

    I just put the alternator in my car today and the battery light on the dash stays on..its a 2003 ford explorer..i called matt and he said to wire the yellow wire on the harness straight to the positive output on the alternator..i did that and the alternator didnt even turn on my batterys were at 12.5..so i put it back the other way ..im getting 14.3 should i not worry bout the batt light on the dash? or should i get another alternator?







  2. #2
    sexy's Avatar
    sexy is offline mind reader



    Join Date
    Jul 2009
    Location
    ohio
    Posts
    301
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman 270

    the battery light bulb gives a slight amount of resistence to the exciter wire that is what makes the alternator start producing voltage. that said let me ask you how many wires does this alt have? i am pretty sure that the yellow wire is your exciter wire and it should have been hooked up to the little wire that was hooked up on your original alt. if done right your light will only come on when the key is on and the engine not runing or when the alt has failed. if the rep at mechman told you to wire it that way then he is full of crap and thats the kind of stuff that i have heard from others about mechman. you pay good money for an alt and then the rep tells you to drive around with the battery light on.




  3. #3
    Rocky213's Avatar
    Rocky213 is offline Member

    Threadstarter


    Join Date
    Jul 2010
    Location
    Miami
    Posts
    130
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman 270

    the wire harness has three..yellow white green..my factory only had two




  4. #4
    Rocky213's Avatar
    Rocky213 is offline Member

    Threadstarter


    Join Date
    Jul 2010
    Location
    Miami
    Posts
    130
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman 270

    the rep told me the white is a dead wire.. i tried switching the green and yellow and i got 17 volts so i put it back..can i drive for a while with the batt light on or is it not safe




  5. #5
    sexy's Avatar
    sexy is offline mind reader



    Join Date
    Jul 2009
    Location
    ohio
    Posts
    301
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman 270

    it should be safe as long as you have 14.4 just a pain in the butt. your original harness would have had an exciter wire plus one that prolly went to the computer. dont know why you got a new alt but if the old one still works you may want to put it back in untill you get the right wiring figured out. to do that you will need to know what the wires on the new alt are for like yellow for field and green for exciter. then find out what the wires in the exploder harness were for so you can get them right.




  6. #6
    Rocky213's Avatar
    Rocky213 is offline Member

    Threadstarter


    Join Date
    Jul 2010
    Location
    Miami
    Posts
    130
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman 270

    im getting 14.4 but when i stop at a red light it drops to 13.2-13.5 even when im not playing any music..whats up with that




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum