Closed Thread
Results 1 to 9 of 9

Reload Thread: My JVC Stereo Won't Turn On!

  1. #1
    BarakObamaJr666's Avatar
    BarakObamaJr666 is offline Junior Member



    Join Date
    Aug 2010
    Location
    Aurora, CO
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)

    My JVC Stereo Won't Turn On!

    Ok so my JVC R618 won't turn on. If I press DISP it will show the time, and if I press Eject it will try to eject, buts thats it. It won't power on or anything. So first off, I began checking all my wiring and everything was fine. I tested my constant, and my ignition wires at every point leading up to the stereo and everything is reading fine. Next I connected the constant and ignition wires from the stereo harness to the constant from my car's harness. Still the same. What gives? Any ideas? My fuses are all fine, I checked, so i don't know if its the stereo itself or what but I'm pissed.







  2. #2
    BarakObamaJr666's Avatar
    BarakObamaJr666 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    Aurora, CO
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My JVC Stereo Won't Turn On!

    Also, btw, there is another harness in my car for the antenna. It has two wires coming from it, which i have connected to a antenna adapter i received from crutchfield. On the adaptor there is a pronged plug which I plugged into the receiver for the antenna, and there is also a blue wire that is labled POWER ANTENNA, does anyone know what this is for?




  3. #3
    BarakObamaJr666's Avatar
    BarakObamaJr666 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    Aurora, CO
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My JVC Stereo Won't Turn On!

    Ok so I took the HU completely out of the car. I wired the constant and ignition wire (yellow and red) together and taped it to the battery positive on my car. I then touched the negative to the battery and all the lights came on on the unit for about 3 seconds and then turned off. I tried again but then nothing happened. So i checked the fuse and it was still good. I tried this process again and the same thing happened. Can anyone give me any pointers? I have everything installed and this is the last piece before I can test everything else. Any advice would be highly appreciated. Thanks.




  4. #4
    Phoenix Risen's Avatar
    Phoenix Risen is online now OG.... Original Ginger



    Join Date
    Jun 2010
    Location
    Dayton/Springfield, Ohio
    Posts
    4,064
    Post Thanks / Like
    Mentioned
    27 Post(s)

    Re: My JVC Stereo Won't Turn On!

    trash the jvc and get a nice hu?



    R.I.P. 2008 Hyundai Tiburon GS
    2005 Subaru Baja turbo, build in planing stages.

  5. Thanks nateberrier thanked for this post
  6. #5
    loudassbug's Avatar
    loudassbug is offline Junior Member



    Join Date
    Oct 2010
    Location
    Easton,Maryland
    Posts
    27
    Post Thanks / Like
    Images
    9
    Mentioned
    0 Post(s)

    Re: My JVC Stereo Won't Turn On!

    If there is a small black plastic capsule in the switched wire (the red one),like on some Pioneer head units,there is a resistor in it,I have found sometimes they go bad and don't let enough power through so the headunit will light up but that is all.If there is one on your switched wire,try tapping into it after the plastic capsule and see if it powers up then.If it does just cut the wire off at the capsule and reinstall your head unit,it will work fine.Hope this helps,but I don't have much experience with JVC headunits.They aren't very popular in my area.



    If it don't have a system in it,I ain't drivin it.

  7. #6
    Louisiana_CRX's Avatar
    Louisiana_CRX is offline dem shoes......



    Join Date
    Aug 2006
    Location
    Piney Hills of Louisiana
    Posts
    34,152
    Post Thanks / Like
    Images
    9
    Mentioned
    31 Post(s)

    Re: My JVC Stereo Won't Turn On!

    Youd been better off buying a Sony Xplode deck




    Current 2010 Louisiana USACi State Records :

    Trunk 0-1000.................. 151.3
    StreetBeat 2................... 145.6
    Stock 1801-up.................153.8
    SuperStock 1801-up..........154.2
    Top three in 11 out of 26 power classes and Louisiana USACi Points Leader at 465

  8. #7
    ecko_0113's Avatar
    ecko_0113 is offline Member



    Join Date
    May 2010
    Location
    Fort Worth, TX
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My JVC Stereo Won't Turn On!

    Quote Originally Posted by Phoenix Risen View Post
    trash the jvc and get a nice hu?
    this




  9. #8
    slim2fattycake's Avatar
    slim2fattycake is offline rolling right along



    Join Date
    Jun 2008
    Location
    In the Stars
    Posts
    2,163
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: My JVC Stereo Won't Turn On!

    **** lol. This is happening the same way with my buddy's JVC. Brand new. I'm going to send it back for warranty. Someone told me that the internal faceplate ribbon could be the problem.



    SPL-Lab REP

    Want an SPL meter for a lot less than the cost of a Termlab, but just as accurate and has more features and support? PM me.

  10. #9
    FenixAudio's Avatar
    FenixAudio is offline Senior VIP Member



    Join Date
    Apr 2010
    Location
    Phoenix, AZ
    Posts
    427
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: My JVC Stereo Won't Turn On!

    take the face plate apart them. did you use the reset button? i should be behind the face plate. sounds dumb but im just being prudent.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum