Closed Thread
Results 1 to 2 of 2

Reload Thread: Amp keeps blowing fuses?

  1. #1
    drtjmpr909's Avatar
    drtjmpr909 is offline Nothing beats a tight box



    Join Date
    Aug 2008
    Location
    Pa
    Posts
    291
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Amp keeps blowing fuses?

    I am running a Kicker KX350.4. Each channel is running at 4ohm stereo, so it is well with-in its operating ranges. I am currently running 2 ga from the battery to a dist block. There is a 150a inline at the battery, and a 30a at the dist block. I took out the class d so all I have running is the Kicker. It keeps blowing both internal 20a fuses, but neither of the inline fuses are blowing. Is this an issue with the amp, or with the wiring?



    REFS~SOLD: Q-ball, Metsfan89, Jeremy M, Truckcap22, Makdaddy, Jh8909
    Bought: Powerstroker, EDZY, Trailz516, sq what 4




  2. #2
    93dakota's Avatar
    93dakota is offline CarAudio.com Elite



    Join Date
    Oct 2008
    Location
    Ohio U
    Posts
    660
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Amp keeps blowing fuses?

    it is most likly internal may want to open up your amp and take a look.



    Co-Founder OBS
    1993 Dodge Dakota LE 3.9L v6
    1 Fi BTL 18" in Custom wall enclosure
    Alpine CDA-9886
    Hifonics Goliath XXV
    Hifonics Zxi6410
    Mechman Street Beater 250amp Alt
    Powermaster D3100
    8 runs Knukoncepts 1/0 power/ground

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum