Closed Thread
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 16 to 30 of 47

Reload Thread: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

  1. #16
    I Like Waffle's Avatar
    I Like Waffle is offline Be Swangin'



    Join Date
    Sep 2008
    Location
    North Carolina
    Age
    26
    Posts
    4,207
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    159 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    maybe its because youre a nigger?




  2. Thanks hatedonmostly thanked for this post



  3. #17
    Haunz's Avatar
    Haunz is offline Packing 4/0



    Join Date
    May 2007
    Location
    inside a sine wave
    Posts
    1,866
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    fail setup, fail advice, fail thread.




  4. Thanks RAM_Designs, hatedonmostly thanked for this post
  5. #18
    340dustya's Avatar
    340dustya is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    columbus, ohio
    Age
    22
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    i took apart the amp and figured out that the power terminal was not soldered on to the circuit board. it was just bent so it would stay touching it with nothing to hold it down. what a fine BRAND NEW amp i had. im about to solder that back on and hopefully that will fix my problems




  6. #19
    AlterEgo99's Avatar
    AlterEgo99 is offline Streaming consciousness



    Join Date
    May 2009
    Location
    Domie Homie
    Posts
    12,533
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    433 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    Serial system amp killer in play here.




    Eddie Izzard: Squirrels always eat nuts with two hands, always two hands, "arararar", and occasionally, they stop and go...oh, uh, ah, as if they're going, "Did I leave the gas on? No! No, I'm a fucking squirrel!"

  7. #20
    Phoenix Risen's Avatar
    Phoenix Risen is offline OG.... Original Ginger



    Join Date
    Jun 2010
    Location
    Dayton/Springfield, Ohio
    Posts
    4,064
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    350 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    ppl like this are why bestbuy does installs, you always have to do your research before you start buying equipment and throwing it in. and if you have a problem dont just throw halfass solutions at it hoping it gets better



    R.I.P. 2008 Hyundai Tiburon GS
    2005 Subaru Baja turbo, build in planing stages.

  8. #21
    340dustya's Avatar
    340dustya is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    columbus, ohio
    Age
    22
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    why is everybody hating? i know what i am doing. i just ran it to some ****** equiptment. i solderded the terminal back on and it fixed all my problems.




  9. #22
    340dustya's Avatar
    340dustya is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    columbus, ohio
    Age
    22
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    i even asked best buy to hook my subs up for me when i first started with car audio and they said they wouldnt do it. they said my car was too old that they didint feel comfortable doing it. so i had to. ran into alot of problems trying to put this powerful of a system in a car thats electrical systm is from 1973. i have set up subs in about 15 newer cars (2000 and up) and it was no problem. but when you try doing it in a car like mine it is very difficult.




  10. #23
    ThatChevyGuy's Avatar
    ThatChevyGuy is online now NOLA Sludge



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,412
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    958 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    What brand amps are you using?

    Obviously they are ****.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  11. #24
    340dustya's Avatar
    340dustya is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    columbus, ohio
    Age
    22
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    old mono block was power acoustik. new one is logic soundlab. the power acoustik was awesome until it broke but my new one i would agree is ******. only reason i bought it was bc i was on a budgit




  12. #25
    ThatChevyGuy's Avatar
    ThatChevyGuy is online now NOLA Sludge



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,412
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    958 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    Don't buy logic soundlab. I've used them and they always blow



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  13. #26
    340dustya's Avatar
    340dustya is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    columbus, ohio
    Age
    22
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    agreed.




  14. #27
    ThatChevyGuy's Avatar
    ThatChevyGuy is online now NOLA Sludge



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,412
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    958 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    What amp are you using now? Are you sure you are running at 2 ohms and not .5?



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  15. #28
    ThatChevyGuy's Avatar
    ThatChevyGuy is online now NOLA Sludge



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,412
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    958 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    Good, thats what happened to my logic amps.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  16. #29
    on1wheel01's Avatar
    on1wheel01 is offline Bang A Lang



    Join Date
    Aug 2008
    Location
    Mooresville nc
    Posts
    2,738
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    Quote Originally Posted by 340dustya View Post
    i even asked best buy to hook my subs up for me when i first started with car audio and they said they wouldnt do it. they said my car was too old that they didint feel comfortable doing it. so i had to. ran into alot of problems trying to put this powerful of a system in a car thats electrical systm is from 1973. i have set up subs in about 15 newer cars (2000 and up) and it was no problem. but when you try doing it in a car like mine it is very difficult.

    There is your problem thinking your set up is powerful. You gear is garbage and you will continue to blow it until you get decent stuff. Audiopipe is a better cheap amp fyi. Your getting major voltage drop I imagine prob into or past 10 volts.



    REFS
    bought from nismos14,lask48180,wu501,teamsolo,thegreatestpenn, 1phatclipse,lorilee8284,Louisiana_CRX,woofercooker ,97maxima,Bad4Health
    sold to sotogrip,bobby32,rgplayer,mxer657,deathpenalty18,C ahm Rohn
    traded with grimreper912003,5cr4ppy
    1999 Durango 2 Memphis Mojo 15's Audiopipe ap3k
    4 Date Safe 75 ah batts Alpine hu. Lots of wangin

  17. #30
    340dustya's Avatar
    340dustya is offline Junior Member

    Threadstarter


    Join Date
    Aug 2010
    Location
    columbus, ohio
    Age
    22
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: System Keeps Killing Amps! HELP!!!!!!!!!!!!!!

    im using the logic now. they advertised it being 2 ohm stable bridged on the internet. but turns out it is stable at 4 ohm briged. i have 2 dvc 2 ohm subs so i couldnt wire it at 4 so i just hooked the + and - up on the right and left terminal which the amp can handle fine but it just isnt as loud




Closed Thread
Page 2 of 4 FirstFirst 1 2 3 4 LastLast

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum