Closed Thread
Results 1 to 10 of 10

Reload Thread: 2003 Ford Mustang. amps are gone now i have no audio!

  1. #1
    keith805's Avatar
    keith805 is offline Junior Member



    Join Date
    Jul 2010
    Location
    Ventura, ca
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon9 2003 Ford Mustang. amps are gone now i have no audio!

    Hey guys i just bought an 2003 ford mustang and the last owner removed the 2 amps that controlled the sub woofer and an amp that controlled speakers in the car. I have a Clarion VRX775VD. the problem im facing now is i dont have any amps to plug into but i want to get sound from my speakers! Please help!







  2. #2
    ozzy87's Avatar
    ozzy87 is offline CarAudio.com Elite



    Join Date
    Nov 2008
    Location
    mayfield, ky
    Posts
    582
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    make and model of said speakers and subwoofer?




  3. #3
    keith805's Avatar
    keith805 is offline Junior Member

    Threadstarter


    Join Date
    Jul 2010
    Location
    Ventura, ca
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    the subs are gone. the speakers in the car though i believe are stock mustang speakers. the guy too the amps from the car no i have no sound




  4. #4
    ozzy87's Avatar
    ozzy87 is offline CarAudio.com Elite



    Join Date
    Nov 2008
    Location
    mayfield, ky
    Posts
    582
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    so he took the stock amplifiers? It honestly sounds like a bad connection somewhere in the headunit




  5. #5
    keith805's Avatar
    keith805 is offline Junior Member

    Threadstarter


    Join Date
    Jul 2010
    Location
    Ventura, ca
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    no he has this thing all wired up to after market amps that are now gone..




  6. #6
    Popwarhomie's Avatar
    Popwarhomie is offline CarAudio.com Elite



    Join Date
    Jan 2010
    Location
    Jacksonville, FL
    Posts
    1,276
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    Okay he had an amp for the highs and amp for the sub and he took them out.. What you need to do is run the speaker wires to the headunit.



    1994 Ford Lightning
    Pioneer 80prs/AQ1200D/SA-8s/Kicker KS 6.5" comps/400.4/optima red top/200 amp alt/
    2010 Focus
    Pioneer 80PRS (3 way active)/(Walled) (2) DC lvl3 18's/AQ2200D/PPI800.4/(6)PPA mids/(4) PH25 tweets/AlphaDamped/KnuKonceptz wiring/102AH Batt

  7. #7
    KHARPS's Avatar
    KHARPS is offline CarAudio.com Veteran



    Join Date
    Jul 2008
    Location
    IL
    Age
    27
    Posts
    3,332
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    Or buy an amp to power the door speakers



    REFERENCES
    cam5860, Godsmack, dropkick13, ls2poweredgoat, bunkerking09, ProjectPechkin, GavinVoy, kmanian, magnum21, natetate, gqjeff, mustangowner, ssackett, hazardous0388, Rusty...WCA, ohsosmooth, grassroots, Leister, Scott S, Pyro_by_Nature, teamsolo, jblcamry, pickup1, got_focus?, fasfocus00, Zellner, Goindef154, Darknight, orangelss, Thorshammer1, BigSix

  8. #8
    Worlddre's Avatar
    Worlddre is offline Big Darkie



    Join Date
    Sep 2004
    Location
    Charlotte, NC
    Age
    30
    Posts
    17,901
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    Quote Originally Posted by ozzy87 View Post
    so he took the stock amplifiers? It honestly sounds like a bad connection somewhere in the headunit
    wow you are an idiot how does that even makes sense to what he is asking

    op hit up a junk yard and snag a factory amplifier out of an 03 mustang. They are attached to the under side of the rear deck on either side of the factory 6x9 enclosure. A pair of t20 torx screws hold the amps up to the rear deck






    "humility in the face of overwhelming genius will obviously amount to hypocrisy"

  9. #9
    x1le's Avatar
    x1le is offline I'm certified.



    Join Date
    Jul 2008
    Location
    Mass
    Age
    25
    Posts
    1,758
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    It's going to depend on where they caught their speaker outputs at. It would prolly be easier and quicker for you to take it to a shop.



    I INSTALL STUFF.
    mecp advanced.
    i do it all.

  10. #10
    Louisiana_CRX's Avatar
    Louisiana_CRX is offline dem shoes......



    Join Date
    Aug 2006
    Location
    Piney Hills of Louisiana
    Posts
    34,152
    Post Thanks / Like
    Images
    9
    Mentioned
    31 Post(s)

    Re: 2003 Ford Mustang. amps are gone now i have no audio!

    the factory amps are crap anyway...upgrade to a quality amp




    Current 2010 Louisiana USACi State Records :

    Trunk 0-1000.................. 151.3
    StreetBeat 2................... 145.6
    Stock 1801-up.................153.8
    SuperStock 1801-up..........154.2
    Top three in 11 out of 26 power classes and Louisiana USACi Points Leader at 465

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum