User Tag List

Closed Thread
Results 1 to 3 of 3

Reload Thread: I have Power to the amp but not to the subs

  1. #1
    Line's Avatar
    Line is offline Junior Member



    Join Date
    Dec 2003
    Location
    Anaheim, CA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Icon32 I have Power to the amp but not to the subs

    I have a ported sub box with 2 tens and the amps was working. then one day the subs started turning them selfs off. the amp has power and is working i think. what is wrong with this picture. Is it the sub or the amp?







  2. #2
    iceteebone's Avatar
    iceteebone is offline Banned



    Join Date
    Aug 2003
    Location
    Michigan
    Age
    29
    Posts
    37,876
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I have Power to the amp but not to the subs

    maybe your amp went into protection mode. if that happend the amp will still light up but you want getting any sound.




  3. #3
    nosaj070's Avatar
    nosaj070 is offline CarAudio.com Veteran



    Join Date
    Feb 2003
    Location
    Chicago, IL
    Age
    29
    Posts
    2,393
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: I have Power to the amp but not to the subs

    Well subs can't really turn themselves on but first what kind of amp and subs are you using. And do you have the gains set extremely high? Because chances are your amp is going into protection mode because you are driving it into clipping. Or you could have them wired wrong and the amp is seeing too low of an ohm load.
    -Jason



    Alpine CDA-7995, A/D/S 3 Series Comps, ED 8A, SoundStream Reference 604, 98 Civic Sedan
    AIM: nosaj070

Closed Thread

Similar Threads

  1. 2 12" power acoustik FUBR DVC subs what amp is good
    By forgotten_candy in forum Amplifiers
    Replies: 1
    Last Post: 02-05-2004, 11:09 PM
  2. Capacitor on a 300W amp?
    By Darwin in forum General Discussion
    Replies: 20
    Last Post: 12-29-2003, 04:24 PM
  3. plz help, i need a amp to power 3 subs.
    By Sone in forum Amplifiers
    Replies: 1
    Last Post: 12-15-2003, 01:25 PM
  4. Can 8 awg power a 750w amp?
    By danfortner in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 11-23-2003, 02:52 PM
  5. Good SQ amp to make subs POUND
    By Forty-Ouncer in forum Amplifiers
    Replies: 5
    Last Post: 10-01-2003, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum