Closed Thread
Results 1 to 3 of 3

Reload Thread: JL 10W6 Problems

  1. #1
    Shawnm's Avatar
    Shawnm is offline Junior Member



    Join Date
    Dec 2003
    Location
    Seattle
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    JL 10W6 Problems

    I have a set of 10W6's. There is somethign wrong with them - when I push them they don't have any movement. They won't move up and down like they are supposed to, like they are just stuck in one spot. I have a feeling that means they are toasted, though I was wondering if there is a way to fix them? Also, what could of caused that??

    Thanks!







  2. #2
    helotaxi's Avatar
    helotaxi is offline Kilroy was Here



    Join Date
    Dec 2003
    Location
    South Central (New Mexico that is...)
    Age
    39
    Posts
    8,933
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: JL 10W6 Problems

    Take them to a JL dealer to send them to be reconed. $90 per sub. Cooked coil usually caused by running a clipped signal through the sub.




  3. #3
    Shawnm's Avatar
    Shawnm is offline Junior Member

    Threadstarter


    Join Date
    Dec 2003
    Location
    Seattle
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: JL 10W6 Problems

    Thanks for the info -

    Do you know if there's a way to replace the coil yourself.... 90 bucks seems kinda steep, almost worth while buying new subs. A coil is pretty simple, just like the name sounds - a coil of copper wires. Any tuts on the net you've seen to do this?




Closed Thread

Similar Threads

  1. kenwood amp problems
    By REAA in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 11-28-2003, 12:57 PM
  2. Alpine 9815.. serious problems
    By Zylo in forum General Discussion
    Replies: 2
    Last Post: 11-20-2003, 09:43 PM
  3. Problems with Dims and Skips
    By Mash Jetta TDI in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 08-04-2003, 05:25 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum