Closed Thread
Results 1 to 3 of 3

Reload Thread: avalanche amp stuck in protection

  1. #1
    honda_dean's Avatar
    honda_dean is offline Junior Member



    Join Date
    Dec 2003
    Location
    australia
    Age
    29
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    avalanche amp stuck in protection

    does any body know how to reset a avalanche 4 channel amplifier code av 430. it went into protection mode today and i can't fix it, i have tried dissconnecting the power but that has not worked. i am running my speakers off it and can't hear anything, its driving me insane! any help would be greatly appreciated.







  2. #2
    rave man's Avatar
    rave man is offline Junior Member



    Join Date
    Oct 2005
    Location
    australia
    Age
    29
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: avalanche amp stuck in protection

    i'm having the exact same problem with my amp. it's bridged out to run my sub's on 2 channels and it worked for about half an hour then it stoped and the red protection light won't stop.




  3. #3
    Bake's Avatar
    Bake is offline CarAudio.com Elite



    Join Date
    Jul 2005
    Location
    Ga
    Posts
    1,072
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: avalanche amp stuck in protection

    Disconnect the speakers and rca's from the amp. Leave only the Batt. ground and remote connected. If it goes into protect when you power it up start looking for a repair shop.




Closed Thread

Similar Threads

  1. Whats wrong with my amp???
    By badazzDD in forum Amplifiers
    Replies: 6
    Last Post: 09-14-2004, 09:09 PM
  2. strangest wiring problem ever, PLEASE HELP!!! (thanks!)
    By dragonplayboy in forum Wiring, Electrical and Installation Help
    Replies: 18
    Last Post: 12-21-2003, 04:51 PM
  3. amp goes into protection when car starts
    By BulldogSr04 in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 12-08-2003, 08:13 PM
  4. sub amp going into protection when low notes hit
    By B|2imstone in forum Amplifiers
    Replies: 7
    Last Post: 12-08-2003, 03:12 AM
  5. help NO POWER PLEASE! URGENT
    By Alpine4life in forum General Discussion
    Replies: 7
    Last Post: 10-08-2003, 03:17 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum