Closed Thread
Results 1 to 4 of 4

Reload Thread: So i got a new Amp today.....

  1. #1
    Sscobb's Avatar
    Sscobb is offline Junior Member



    Join Date
    Aug 2003
    Location
    Kirkland WA
    Age
    30
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    So i got a new Amp today.....

    I picked up a JBL bp1200.1 today, plugged it all in and....... nothing! No idicator light, sound, anything. I triple checked all the connections, and i went through with a meter, to make sure everything had power, and that nothing was grounding out. The amp is in a 66 mustang coupe, with stock everyhing (200 ci if it matters). anyway, any ideas why the amp won't come on???







  2. #2
    jbl_marshall21's Avatar
    jbl_marshall21 is offline important person



    Join Date
    Oct 2002
    Location
    nebraska
    Posts
    2,494
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)
    well those amps have been known for problems. it should turn on though. the only reason i would think that the amp wouldn't turn on is because of a missing fuse maybe or a bad ground.




    Alpine CDA-9886
    RUX-C701
    PXA-H701
    JL xr-650csi
    JL vr-650cxi
    2 8" W7
    JL HD750/1
    JL HD600/4
    2007 Chevy Trailblazer

  3. #3
    Sscobb's Avatar
    Sscobb is offline Junior Member

    Threadstarter


    Join Date
    Aug 2003
    Location
    Kirkland WA
    Age
    30
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Ok, i checked the fuse by the battery again. it's giving me some weird readings.... i'm only getting .01v off the fuse, maybe i need a new fuse housing? if i really cram it in, then i can get about 4v.... kinda strange




  4. #4
    Sscobb's Avatar
    Sscobb is offline Junior Member

    Threadstarter


    Join Date
    Aug 2003
    Location
    Kirkland WA
    Age
    30
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    AHHHHH! i replaced the fuse housing, and now it works great!!!!
    Thanks for the help!!!!!




Closed Thread

Similar Threads

  1. Funny Stuff Today lol
    By Silica in forum Subwoofers
    Replies: 14
    Last Post: 02-11-2004, 11:35 PM
  2. how many db did I hit on a mic today with Dustin?
    By burtonsnow83 in forum General Discussion
    Replies: 88
    Last Post: 08-02-2003, 03:27 PM
  3. Heard D2's Today
    By BDIDDY in forum Subwoofers
    Replies: 5
    Last Post: 07-21-2003, 01:09 AM
  4. Got my Magnum today
    By Primetime in forum Subwoofers
    Replies: 10
    Last Post: 07-19-2003, 01:31 AM
  5. Got my roll of Second Skin today...woohoo!
    By Aurorav8 in forum General Discussion
    Replies: 3
    Last Post: 07-11-2003, 03:49 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum