Closed Thread
Page 3 of 3 FirstFirst 1 2 3
Results 31 to 39 of 39

Reload Thread: Mechman Alternator question

  1. #31
    MikeyB's Avatar
    MikeyB is offline CarAudio.com Addict



    Join Date
    Jul 2005
    Location
    H-Town, MI
    Posts
    7,727
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    Get the right belt on that bisch mang!



    Refs- hessdawg, Pepsifiend69, iltoivfe, ownage9, lifted95blaze, Buckshot, da box king, Po.Sic, baseballer1100, vetkilr, dkguitarist, Queball, qtipextra, LaserRed38, 350_regal, RidnClean, BushJ311 and a bunch more...




  2. #32
    Blazin_Jason's Avatar
    Blazin_Jason is offline CarAudio.com Elite



    Join Date
    Oct 2005
    Location
    Vancouver Isl, BC, Canada
    Age
    31
    Posts
    1,166
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    Go here and find your belt. Then go here and find the one that is just slightly smaller than your stock one if that's what you want.




  3. #33
    mazzasec's Avatar
    mazzasec is offline Banned

    Threadstarter


    Join Date
    Dec 2007
    Location
    ATL
    Posts
    6,875
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    My question is now though. How come when I took off the belt and then put it back on the noise was gone for a whole day of driving then came back?




  4. #34
    GreenBook's Avatar
    GreenBook is offline Senior VIP Member



    Join Date
    Nov 2008
    Location
    Michigan
    Age
    31
    Posts
    434
    Post Thanks / Like
    Images
    6
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    If it was a brand new belt it could have just been breaking in & stretched a little bit.



    DECKPioneer DEH-P6000UBAMPSKicker ZX1000.1; ZX350.4SUBS2 12" Type R'sHIGHSCadence CWM6'sPOWER160amp KnuKonceptz alt; 1/0 StreetWire

  5. #35
    mazzasec's Avatar
    mazzasec is offline Banned

    Threadstarter


    Join Date
    Dec 2007
    Location
    ATL
    Posts
    6,875
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    Quote Originally Posted by GreenBook View Post
    If it was a brand new belt it could have just been breaking in & stretched a little bit.
    Na it was the old one. I had the old one on, tried the new one and couldnt get the new one to fit on. Then when I put the old one back on it was fine and then started making the noise.




  6. #36
    mazzasec's Avatar
    mazzasec is offline Banned

    Threadstarter


    Join Date
    Dec 2007
    Location
    ATL
    Posts
    6,875
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    Bump put on another belt today. We will see how that goes.




  7. #37
    da box king's Avatar
    da box king is offline CarAudio.com Veteran



    Join Date
    Mar 2008
    Location
    Portland, MI
    Posts
    4,685
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    belt is just slipping..same happened to me, just put on a smaller belt and perfecto



    2003 Chevy Trailblazer LT
    (2) 15" AQ HDC3 7.25 cubes tuned to 35 hz
    Rear Fill: Pioneer Premier TS-D602P
    Front doors: ID ctx65
    Kick: ID ctx65cs
    Sub amp: Crossfire VR4000D
    Interior amps: SAX 100.4, PPI pc4400.2 (ACTIVE)

    PM ME: I BUILD BOXES FOR LOCALS OR ANYONE AROUND MICHIGAN

  8. #38
    mazzasec's Avatar
    mazzasec is offline Banned

    Threadstarter


    Join Date
    Dec 2007
    Location
    ATL
    Posts
    6,875
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    Ok fixed the belt slip noise for now. But now my alternator is making some funky noises Im starting to loose faith in my mechman alt




  9. #39
    audioarsonal's Avatar
    audioarsonal is offline JaMarcus



    Join Date
    May 2007
    Location
    close to home...
    Posts
    4,165
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)

    Re: Mechman Alternator question

    HO alt will have a slight whine from what I have noticed.Tighter tolerances on the stator and rotor are usually the cause of this.




    Bought from:whiteram,Pyro_by_nature,AudioXtremes,Slab,IA2
    Sold to:annarbor84,ssackett,tapout383
    built for:skeptikal,Raid3r89
    SHADY SELLER:memphisman00
    Subs:4 Incriminator Audio Death Row 15's
    amps: Memphis 4K
    154.8@34hz

Closed Thread
Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum