Closed Thread
Results 1 to 4 of 4

Reload Thread: power shut off in amp and head unit, won't turn back on.

  1. #1
    frontlinenut13's Avatar
    frontlinenut13 is offline Junior Member



    Join Date
    Aug 2008
    Location
    ma
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    power shut off in amp and head unit, won't turn back on.

    So, today I finally was able to wire everything, and for about an hour it worked.

    In celebration, decided to go to taco bell with a couple of buddies and later to the liquor store.
    I shut my car off and went into taco bell, when I came back out and started the car, I realized the sub wasn't working. I wasn't worried, figured that the amp overheated and it would eventually cool off. We went to the liquor store and I checked out the amp, it was perfectly cool. So I couldnt figure out what happened. I got back to my college and checked some of the stuff and it looked alright. I read that if your amp shuts off, than the ground and remote connections should be checked. So I checked them, While thinking that maybe the remote wire needed to be re-crimped, I inserted one wire, then went to insert the other and heard a pop. Now, my receiver doesnt work. I checked the receiver fuse, and the fuse under the hood of the xterra, it is all fine.

    So now I'm stuck, what happened? has this ever happened to anyone?







  2. #2
    edzy's Avatar
    edzy is offline SPL Ninja



    Join Date
    Feb 2007
    Location
    Where you live
    Posts
    2,188
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: power shut off in amp and head unit, won't turn back on.

    sounds like a short somewhere. Use a dmm to find out.



    Nothing to see here, Move along.

  3. #3
    05fronty's Avatar
    05fronty is offline SALT PETER



    Join Date
    Nov 2006
    Location
    conway,ar
    Age
    40
    Posts
    11,343
    Post Thanks / Like
    Mentioned
    53 Post(s)

    Re: power shut off in amp and head unit, won't turn back on.

    Quote Originally Posted by edzy View Post
    sounds like a short somewhere. Use a dmm to find out.
    yeah check voltages and i wish liquor stores are open on sunday here, i'm outa beer



    bought from ridinhi,vitveet,dbr,sicaudio and 99grandprixgt, and more ........... sold to player3,foomasta69, pitbull, brodiesel and dragnix 12887 traded with louisiana crx

    "noobs that come in the dome will get gang raped!"
    nothing but a stock fosgate system with gps and back up camera lol
    2012 nissan sentra spec v with some goodies cumming though

  4. #4
    frontlinenut13's Avatar
    frontlinenut13 is offline Junior Member

    Threadstarter


    Join Date
    Aug 2008
    Location
    ma
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: power shut off in amp and head unit, won't turn back on.

    This is what i got for readings..
    still cant figure it out. I'm getting power but its just not working.. I hate to say it, but i think its fried.. waste of a hundred dollars.

    but anyways.. i think it needs to be between 12 and 14.4 dv
    Attached Thumbnails Attached Thumbnails power shut off in amp and head unit, won't turn back on.-0928081549.jpg  




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum