Closed Thread
Results 1 to 4 of 4

Reload Thread: xtant saying over current?? HELP!?

  1. #1
    Join Date
    Dec 2007
    Location
    Evansville, IN
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)

    xtant saying over current?? HELP!?

    Ok, I have an xtant 604x and 603x.. just hooked them up to work with the imaging of the system i'm designing.. The 603x takes up to 100amp fuse, 604x takes up to 120amp.. I had them both on 150 amp fuses because its all I had at the moment, but the 603x said that it was over current, so I took them both and hooked them both up to one 150 amp fuse.. So they are capable of handling 220, but are only getting 150, yet the over current protection light on the 603x is still on?!? It makes a buzzing sound when its turned on?? the amp itself! i turned them off imediately and checked all the wiring but I really dont' know what the hell is up?!? Any one know how to fix this problem? If its over current that means it has to be coming from the power wire, right??







  2. #2
    lashlee's Avatar
    lashlee is offline Senior VIP Member



    Join Date
    Nov 2002
    Location
    over here
    Posts
    181
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: xtant saying over current?? HELP!?

    Was the car running? If the battery voltage was low, it could've caused some issue with the amp. I've only got 60 amp fuses going to my 603 and 604. The buzzing is one of the power transformers, you can send it back to them and they can re epoxy the board, or you can silicone around the base of it and get rid of some of the noise.




  3. #3
    2004alpinewhite's Avatar
    2004alpinewhite is offline Member

    Threadstarter


    Join Date
    Dec 2007
    Location
    Evansville, IN
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: xtant saying over current?? HELP!?

    Quote Originally Posted by lashlee View Post
    Was the car running? If the battery voltage was low, it could've caused some issue with the amp. I've only got 60 amp fuses going to my 603 and 604. The buzzing is one of the power transformers, you can send it back to them and they can re epoxy the board, or you can silicone around the base of it and get rid of some of the noise.
    Yeah the car was running.. This isn't just a vibration though.. It was a definite buzz..

    The car had just completely run out of battery power, and then I jumped it with my dad's car and all of a sudden this popped up.. It wasn't always like that..




  4. #4
    lashlee's Avatar
    lashlee is offline Senior VIP Member



    Join Date
    Nov 2002
    Location
    over here
    Posts
    181
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: xtant saying over current?? HELP!?

    Do you get any sound out of the 603? The over current light dosen't necessarily mean that you have too large of a fuse on it. I'd hook up just the 603 and see what it does. without any speakers hooked up to it. If it powers up normally, then add the speakers one at a time until you find the one that causes the problem.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum