Closed Thread
Results 1 to 4 of 4

Reload Thread: need help. bad ground?

  1. #1
    pellis's Avatar
    pellis is offline Member



    Join Date
    Mar 2005
    Location
    Raleigh, Nc
    Posts
    121
    Post Thanks / Like
    Mentioned
    0 Post(s)

    need help. bad ground?

    ok around 3 wks ago, i went out to my car. i adjusted some gains and played around with different settings. around a day later, while traveling down the road, a LOUD SCREECH/grinding noise comes through my speakers. turned the hu off and back on it was going, happens again. i thought something was killing my battery, turned the sub level down the neg 25 and i still get the screeching to make a long story short. read out from the HU is 13.9-14.1v. could it be a bad ground somewhere that is causing all of this trouble or could it be a sign of a bad battery/alt? i had both checked around a yr ago and they turned out fine, but that was a while back.

    any tips? i am planning to do the BIG 3 in a couple of wks try and eliminate the dimming of my lights.

    current setup:
    880prs, seas er18mids, seas tweeters, x200.4 and pioneer gm-5100t amps, 1 dayton ho 12.

    power wire from the batt to the pos distro is 4awg, from the pos distro to the amps are 8 awg.

    any help would be great appreciated.

    p.s. = amp doesn't go into protect as far as i can tell, voltage doesn't drop from the read out of the hu and happened with 2 different 880prs'



    Current Setup:
    Pioneer DEH-P880PRS
    Seas 27TBFC/G Tweeters. Seas ER18RNX Mids
    Phoenix Gold X200.4 / Pioneer GM-5100T Amp / DIYMA 12" Sub

    :Equipment used in the past:
    Pioneer DEH-P3600MP : DEH-P8600MP : Alpine CDA-9855 : LPG 25NFA : Seas 27TFFNC/G : B&G Neo3 : Seas CA18RLY : Peerless Exclusives : Seas P18RNX : Seas 27TDFC : Aura RPM 4200




  2. #2
    NissanKicker's Avatar
    NissanKicker is offline Honda-on-22-Nissan-on-20



    Join Date
    Oct 2007
    Location
    Ruston/Grambling, LA
    Age
    26
    Posts
    1,420
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need help. bad ground?

    Could be your RCAs.... Make sure they are push tightly, secure, in your amp... Also! Have you grounded your RCA Outputs behind the 880prs?




    Vehicle: 1999 Nissan Sentra GXE 4-Dr [ Lambo Doors ]
    Head Unit: Alpine CDA-124SXM
    Front Stage: Kicker DS6.5s w/ (4) Power Acoustik NB.4s - Rear Stage: (4) JVC 5-Way 6x9s
    Sub Stage: 18" FI Audio Q - Custom Ported Enclosure: 6.41 cuft Tuned @ 29Hz
    Sub Amp: (1) Kicker KX2500.1D - Highs Amp: AutoTek AT-1200.4
    Processors: Clarion EQ-746 & Clarion MCD-360
    Wiring: Install Bay 1/0 Gauge ( Including Big 3 Upgrade )
    Batteries: EverStart Maxx's ( 750 CCA ) In Front & Back
    DJ's Installation

  3. #3
    pellis's Avatar
    pellis is offline Member

    Threadstarter


    Join Date
    Mar 2005
    Location
    Raleigh, Nc
    Posts
    121
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need help. bad ground?

    Quote Originally Posted by NissanKicker View Post
    Could be your RCAs.... Make sure they are push tightly, secure, in your amp... Also! Have you grounded your RCA Outputs behind the 880prs?
    no, i didn't ground the rcas. i am on my second 880, while coming from an 880 that did have a blown pico fuse. this whine that i get now, happened with both HUs. i did have the rcas grounded with the last 880 that i had, though.

    this screech/whine now, is loud as hell compared the the whine that i got from a bad pico fuse. this screech could scare a passenger while driving.



    Current Setup:
    Pioneer DEH-P880PRS
    Seas 27TBFC/G Tweeters. Seas ER18RNX Mids
    Phoenix Gold X200.4 / Pioneer GM-5100T Amp / DIYMA 12" Sub

    :Equipment used in the past:
    Pioneer DEH-P3600MP : DEH-P8600MP : Alpine CDA-9855 : LPG 25NFA : Seas 27TFFNC/G : B&G Neo3 : Seas CA18RLY : Peerless Exclusives : Seas P18RNX : Seas 27TDFC : Aura RPM 4200

  4. #4
    NissanKicker's Avatar
    NissanKicker is offline Honda-on-22-Nissan-on-20



    Join Date
    Oct 2007
    Location
    Ruston/Grambling, LA
    Age
    26
    Posts
    1,420
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need help. bad ground?

    Try grounding them again... They take a long piece of speaker wire hook it up to to the ground in the amp ( unhook the current ground ) and touch the actual frame of the car... Or your engine block.
    .... If it stops, then it's your ground.

    Or just connect to the battery.
    .... And like I said " If it stops, the it's your ground "

    You'll need to find another place to ground it, or make sure that you scrapped ALL paint, and it's bare, shiny metal.




    Vehicle: 1999 Nissan Sentra GXE 4-Dr [ Lambo Doors ]
    Head Unit: Alpine CDA-124SXM
    Front Stage: Kicker DS6.5s w/ (4) Power Acoustik NB.4s - Rear Stage: (4) JVC 5-Way 6x9s
    Sub Stage: 18" FI Audio Q - Custom Ported Enclosure: 6.41 cuft Tuned @ 29Hz
    Sub Amp: (1) Kicker KX2500.1D - Highs Amp: AutoTek AT-1200.4
    Processors: Clarion EQ-746 & Clarion MCD-360
    Wiring: Install Bay 1/0 Gauge ( Including Big 3 Upgrade )
    Batteries: EverStart Maxx's ( 750 CCA ) In Front & Back
    DJ's Installation

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum