Closed Thread
Results 1 to 13 of 13

Reload Thread: Help

  1. #1
    Hawaiian's Avatar
    Hawaiian is offline Senior VIP Member



    Join Date
    Feb 2003
    Location
    CA
    Posts
    160
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Help

    Hey,

    I was all stoked on my new kicker 1200.1 which I will be having power my 15" Adire audio Brahma (Dual 2 ohm VC wired parallel to 1 ohm). Got it all wired up by a guy who worked for a car audio company who is a friend of mine, and turned it on, worked perfectly. Kept it low so i could break everything in and not push to hard at first. Turned it off for a bit, came back and turned it on and nothing. When I turn on the power I get a flash of the Red protect light, and then it dims out to no lights at all. The only troubleshooting things in my manual talk about red or green constant on, no single on the fading. I am wondering what this light means, I personally took everything apart to make sure that all the wires are run properly. Ground, Power and remote are all working, not totally sure how to check RCA's but they are brand new. Any idea what is going on?







  2. #2
    Hawaiian's Avatar
    Hawaiian is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    CA
    Posts
    160
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    As part of this same question, when wiring in parallel, does it matter which positive or negative the speaker wire from the amp is wired to? I drew a pic but its too big or something and i don't know how to link pics. Anyway i have the positive from the amp running to the positive on one voice coil then another to the other positive, then on the other voice coil i got the negative running from the amp and then a wire running to the other negative (the one next to the positive with the wire from the amp)




  3. #3
    ricerdude's Avatar
    ricerdude is offline TEAM THRESHOLD



    Join Date
    Dec 2002
    Location
    Idaho Falls, ID
    Age
    29
    Posts
    687
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    you might have blown your amp?? i dont know ..are you sure you checked your connections...double check them...un hook the sub and turn the amp on and if it does the same then take the fuse out of the amp power..and let it sit for a while..them try again...if either of those dont do anything you amp is shot..

    D



    1991 Mitsubishi Eclipse gsx
    far from stock

    Pioneer Premier deh-p630
    Pioneer 3 way 5.25
    Pioneer 6x9s--soon to change
    Rockford Fosgate Power bd1000.1
    1 Orion XTR 12 series 2 in 2.9 cuft. ported evclosure, tuned to 37hz..


    proud member of TEAM THRESHOLD

  4. #4
    Hawaiian's Avatar
    Hawaiian is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    CA
    Posts
    160
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    ************************************************** ************************************************** ****************MUTHER**************************** ************************************************** ************************************************** ************************************************** ************************************************** ****IN******************************************** ************************************************** ************************************************** ********************PIECEOFSHIT******************* ************************************************** *******

    thanks, i just got it so i guess i can send it back if i have to...




  5. #5
    ChefJoe's Avatar
    ChefJoe is offline Senior VIP Member



    Join Date
    Dec 2002
    Location
    Columbus, OH
    Age
    34
    Posts
    267
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    On a mono amp, it shouldn't matter. The dual sets of terminals are usually fused at the amp itself. I go with the "**** be broken" diagnosis if all the wires are correct.



    97 VW Jetta - building a system from parts in my old 85 Jetta
    HU: Pioneer P740MP with 12 disc changer
    Front: 3.5" JBL GTO302s in dash
    5.25" Cerwin Vega Vega Series 502s in door
    Amped: US Acoustics USX-2050 @ 2 ohm

    Rear: Stock components
    Sub: Single 12" Vega 124 in a cheap bandpass box
    Sub Amp:US Acoustics USX-2150 bridged

  6. #6
    ricerdude's Avatar
    ricerdude is offline TEAM THRESHOLD



    Join Date
    Dec 2002
    Location
    Idaho Falls, ID
    Age
    29
    Posts
    687
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Originally posted by ChefJoe
    On a mono amp, it shouldn't matter. The dual sets of terminals are usually fused at the amp itself. I go with the "**** be broken" diagnosis if all the wires are correct.
    i like that "**** be broken" thats a good one...lol...

    D



    1991 Mitsubishi Eclipse gsx
    far from stock

    Pioneer Premier deh-p630
    Pioneer 3 way 5.25
    Pioneer 6x9s--soon to change
    Rockford Fosgate Power bd1000.1
    1 Orion XTR 12 series 2 in 2.9 cuft. ported evclosure, tuned to 37hz..


    proud member of TEAM THRESHOLD

  7. #7
    Hawaiian's Avatar
    Hawaiian is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    CA
    Posts
    160
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    no, not right now it isnt. only if its some else's stuff




  8. #8
    ricerdude's Avatar
    ricerdude is offline TEAM THRESHOLD



    Join Date
    Dec 2002
    Location
    Idaho Falls, ID
    Age
    29
    Posts
    687
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Originally posted by Hawaiian
    no, not right now it isnt. only if its some else's stuff
    no i said i like the saying...but that fukin ***** dude...you said you drew a diagram...well go into paint..or what ever you have and redraw it and go to image on the pull down menu and go to attributes and tell me what he resolution and size of the pic is...

    D



    1991 Mitsubishi Eclipse gsx
    far from stock

    Pioneer Premier deh-p630
    Pioneer 3 way 5.25
    Pioneer 6x9s--soon to change
    Rockford Fosgate Power bd1000.1
    1 Orion XTR 12 series 2 in 2.9 cuft. ported evclosure, tuned to 37hz..


    proud member of TEAM THRESHOLD

  9. #9
    Hawaiian's Avatar
    Hawaiian is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    CA
    Posts
    160
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Doesn't really matter about my pic anymore i guess, just got back from rewiring my sub into series, and it still doesnt work, exact same reaction by the protection light. Evidently its not a problem with resistance.




  10. #10
    Join Date
    Apr 2002
    Location
    Idaho Falls
    Age
    37
    Posts
    1,134
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    See if you can try your amp in one of your buddies cars!! Then you can be sure that the amp is the problem and not something in your car



    '99 Ram Sport Quad cab
    Alpine 7897
    Rainbow 6.5 comp. set
    180 amp Iraqqi alt
    Optima yellow top

  11. #11
    Hawaiian's Avatar
    Hawaiian is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    CA
    Posts
    160
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    k, just figure i might wait till tomorrow. Don't really think they wanna try it at 1130. I would just be worried that something of their would break and they would blame it on me. I don't have any real good friends with sounds around here, just a couple guys i know.




  12. #12
    Join Date
    Apr 2002
    Location
    Idaho Falls
    Age
    37
    Posts
    1,134
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Take a road trip to Idaho We'll try it in my truck But I don't see how it could hurt anything in a differant car so I wouldn't be worried about that. Prolly the worst it could do is pop a fuse which is no biggie



    '99 Ram Sport Quad cab
    Alpine 7897
    Rainbow 6.5 comp. set
    180 amp Iraqqi alt
    Optima yellow top

  13. #13
    Matador's Avatar
    Matador is offline -= StillBumping =-



    Join Date
    Oct 2002
    Location
    Ca
    Posts
    2,093
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    stupid question, but did u check ur inline fuse? check ur ground n make sure it's fine. u just gotta check all the small details. u can just take ur amp n put into someone els'es car, n viceversa.




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum