Closed Thread
Results 1 to 5 of 5

Reload Thread: amplifier qusetion please help

  1. #1
    chris2's Avatar
    chris2 is offline Junior Member



    Join Date
    Mar 2003
    Location
    mobile
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    amplifier qusetion please help

    i previously had a 2000 ford mustang convertible with 4 5x7s and they were running off a 2 channel amp i have. well i traded the mustang in for a jeep cherokee, and i have two tweeters, two mb quart 6x9s, and a 6and a half component system running off the factory amp and cd player i bought. well why cant i use this 2 channel amp to deliver some extra power to my mids and highs? just wondering cause i was told u could run like 4-6 subs off a mono amp







  2. #2
    Gauntlet's Avatar
    Gauntlet is offline bulletproof



    Join Date
    Oct 2002
    Location
    Cleveland, Ohio
    Age
    36
    Posts
    8,477
    Post Thanks / Like
    Images
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Not sure exactly what youre asking....what exactly do you want to power with the 2 channel amp?



    "The world is full of people who want nothing short of perfect,
    but settle for less, blinded by their quest for purpose."
    - Slug



  3. #3
    Trixter's Avatar
    Trixter is offline Keepin it Simple



    Join Date
    Apr 2002
    Location
    Colorado Springs, CO
    Age
    39
    Posts
    2,609
    Post Thanks / Like
    Images
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)
    A little more info. on the amp and the speakers you want to wire up would be most helpful.



    2006 Jeep Liberty
    Adire Audio 15" Brahma running off Cadence A7hc, Clarion hu, MB Quart 6.5s and 5.25s running off old school Punch 800a4

    146+db @ 38hz with 1200w and a single 15"

    Lv = [(14630000 x R^2) / (Fb^2 x Vb)] - 1.463R
    *Vb = vol. in cu"
    **R = sq.rt. A / Pi (for square/slot port)

  4. #4
    Matador's Avatar
    Matador is offline -= StillBumping =-



    Join Date
    Oct 2002
    Location
    Ca
    Posts
    2,093
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

  5. #5
    i3abyjay25's Avatar
    i3abyjay25 is offline Get F'n Loud



    Join Date
    Aug 2002
    Location
    Dallas, Georgia
    Age
    37
    Posts
    2,128
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)
    i know in my sable,, when i installed an aftermarket HU, i had to bypass the factory amp.. and i did it by.. right behind the HU, their was 2 sets of wire harnesses.. 1 was ran w/ the factory amps, and the other set was ran w/o the amp.. just had to swap.



    Fs/t


    Orion 2500d
    Orion 4004
    250 amp alt w. external voltage reg. for a ford explorer

    Refs: Electrodynsmic, Millerboy, Ugaboiii, Ezekiel81923, Toaster, Team Psi, KickerCivic1, MatrxxDude, TommyK90, Xterra02_Pat

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum