Closed Thread
Results 1 to 4 of 4

Reload Thread: Help installing xover from Audiocontrol

  1. #1
    delrice's Avatar
    delrice is offline Junior Member



    Join Date
    Feb 2003
    Location
    Manzanillo, MEXICO
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Help installing xover from Audiocontrol

    Hi,
    I've just installed the 6XS xover to an Orion CS500.5 amp. The 6XS has 8 output channels and the amp has 6 inputs. The 6XS has four channels for the front, hi (from 250 hz and up) and low (90-250 hz). I have a JBL set in front (GTO605C). I've only connected the hi output front channels to my amp (250 hz and up), but i was wondering if i can use a rca Y-cable to connect both hi and lo channels from the xover to the front channels of my amp. What do you think? Could i have problems with the amp?

    Thanks







  2. #2
    ShaunMac's Avatar
    ShaunMac is offline Thank You Come Again!



    Join Date
    Feb 2003
    Location
    GEORGIA
    Posts
    585
    Post Thanks / Like
    Mentioned
    0 Post(s)
    shouldn't be a problem at all.

    My guess is that the high output was too high and you didn't have much
    bass in the front.

    If you want to run 90Hz and up to the JBL's in the front that would work.
    It would also allow you to fine tune the 90-250Hz independently from
    250Hz and up to get just the right amount of bass up front.

    Or you could replace the 250Hz module with a 90Hz module then hi would
    be from 90Hz and up.

    How many x-over points are there in your system?
    Are you just running a sub to 90hz and JBL's from 90hz up?




  3. #3
    delrice's Avatar
    delrice is offline Junior Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    Manzanillo, MEXICO
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Originally posted by ShaunMac
    shouldn't be a problem at all.

    My guess is that the high output was too high and you didn't have much
    bass in the front.

    If you want to run 90Hz and up to the JBL's in the front that would work.
    It would also allow you to fine tune the 90-250Hz independently from
    250Hz and up to get just the right amount of bass up front.

    Or you could replace the 250Hz module with a 90Hz module then hi would
    be from 90Hz and up.

    How many x-over points are there in your system?
    Are you just running a sub to 90hz and JBL's from 90hz up?
    -------------------------------------------------------------------------------------------------

    That's right. The range from 90 to 250 hz. is missing, and the system sounds incomplete. About the xover points, the settings in the HU are flat and in the amp too, i did this trying to keep it simple.
    The subs are in the 30 - 90 hz range, i have a pair of coaxials for the rear channel running from 250 and up and the fron channel 250hz and up too. Like i said, feels like something is missing.



    -----------------------------------------
    Alpine 7894 HU
    Alpine 6 disc MP3 changer
    Orion CS500.5 amp
    1 3 way set MB Quart PSD 316 Front
    JBL GTO635 Back (NOT ANYMORE!!! - Removed after reading excelent post)
    2 Orion CS10" subs sealed box
    Audiocontrol 6XS xover
    Audiocontrol EQS (At Last!!!)
    --------------------------------------

  4. #4
    delrice's Avatar
    delrice is offline Junior Member

    Threadstarter


    Join Date
    Feb 2003
    Location
    Manzanillo, MEXICO
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Well, thanks anyway.



    -----------------------------------------
    Alpine 7894 HU
    Alpine 6 disc MP3 changer
    Orion CS500.5 amp
    1 3 way set MB Quart PSD 316 Front
    JBL GTO635 Back (NOT ANYMORE!!! - Removed after reading excelent post)
    2 Orion CS10" subs sealed box
    Audiocontrol 6XS xover
    Audiocontrol EQS (At Last!!!)
    --------------------------------------

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum