Closed Thread
Results 1 to 7 of 7

Reload Thread: question on upgrading alt and fuse ?

  1. #1
    ryguy1607's Avatar
    ryguy1607 is offline Member



    Join Date
    Jan 2003
    Location
    Flint, Mi
    Age
    29
    Posts
    96
    Post Thanks / Like
    Mentioned
    0 Post(s)

    question on upgrading alt and fuse ?

    I have a JBL 1200.1 amp and the alt is 105amps, the lights dim pretty bad and i havent even turned the amp up at all yet. it pounds my 15" rockford good. I blew my 60A fuse so i put a 80A fuse in, will that hold good? My other queston is will upgrading my alt to 140 be enough amps or do i need to go higher? any feedback? thanks!







  2. #2
    Trixter's Avatar
    Trixter is offline Keepin it Simple



    Join Date
    Apr 2002
    Location
    Kenosha, WI
    Age
    36
    Posts
    2,608
    Post Thanks / Like
    Images
    29
    Mentioned
    0 Post(s)
    140-160 amp alt. should do. I am getting a 180 and my system is 1800w rms total (1400 for sub and 400 for highs.)



    2006 Jeep Liberty
    Adire Audio, Cadence, Clarion, MB Quart

    Lv = [(14630000 x R^2) / (Fb^2 x Vb)] - 1.463R
    *Vb = vol. in cu"
    **R = sq.rt. A / Pi (for square/slot port)

  3. #3
    Join Date
    Apr 2002
    Location
    Idaho Falls
    Age
    37
    Posts
    1,134
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: question on upgrading alt and fuse ?

    Originally posted by ryguy1607
    I have a JBL 1200.1 amp and the alt is 105amps, the lights dim pretty bad and i havent even turned the amp up at all yet. it pounds my 15" rockford good. I blew my 60A fuse so i put a 80A fuse in, will that hold good? My other queston is will upgrading my alt to 140 be enough amps or do i need to go higher? any feedback? thanks!
    What ohm load do you have your amp running at? The reason I ask is because I have the same amp running @ 1 ohm on a hcca 15 with only a 50 amp fuse and I've never had a problem with it




  4. #4
    ricerdude's Avatar
    ricerdude is offline TEAM THRESHOLD



    Join Date
    Dec 2002
    Location
    Idaho Falls, ID
    Age
    29
    Posts
    687
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: Re: question on upgrading alt and fuse ?

    Originally posted by RMKrider1
    What ohm load do you have your amp running at? The reason I ask is because I have the same amp running @ 1 ohm on a hcca 15 with only a 50 amp fuse and I've never had a problem with it
    and it is f-in loud...if you have a 105 amp alt and your lights are dimming then your amp is drawing some power....

    D




  5. #5
    ryguy1607's Avatar
    ryguy1607 is offline Member

    Threadstarter


    Join Date
    Jan 2003
    Location
    Flint, Mi
    Age
    29
    Posts
    96
    Post Thanks / Like
    Mentioned
    0 Post(s)
    im not sure what ohm load but i have the he2 and each voicecoil is running into a channel on the amp.




  6. #6
    Join Date
    Apr 2002
    Location
    Idaho Falls
    Age
    37
    Posts
    1,134
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)
    It's actually a mono amp. I know nothing about the he2's or rockford for that matter but my guess is that it's dual 4 ohm right? If so your amp is running at 2 ohms




  7. #7
    Trixter's Avatar
    Trixter is offline Keepin it Simple



    Join Date
    Apr 2002
    Location
    Kenosha, WI
    Age
    36
    Posts
    2,608
    Post Thanks / Like
    Images
    29
    Mentioned
    0 Post(s)
    Yes. The HE2 is a dual 4ohm coil sub. Your amp will be seeing a 2ohm load. What is the amp rated for at 2ohm? What size box?



    2006 Jeep Liberty
    Adire Audio, Cadence, Clarion, MB Quart

    Lv = [(14630000 x R^2) / (Fb^2 x Vb)] - 1.463R
    *Vb = vol. in cu"
    **R = sq.rt. A / Pi (for square/slot port)

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum