Closed Thread
Results 1 to 3 of 3

Reload Thread: Dead ignition wire

  1. #1
    Join Date
    Jun 2003
    Location
    MO
    Age
    31
    Posts
    94
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon8 Dead ignition wire

    I've had trouble with a CDE-7870 in my girlfriends car for a while. It shut off one day and refused to come back on. I tested the power and switched power wires and they were fine, so I just figured the head unit was dead since it was about 5 or 6 years old by this time, and left it in the dash.
    A couple of days ago I was messing around and hit the power button and it came on, but shut off the next day. I found out the connectors on the back of the HU were a little loose. When I pulled it out a wire sparked and blew the Instrument Illumination fuse. Now, the switched power wire is dead, and the only way to activate the head unit is to place the switched power wire on the power wire.
    Is there another wire I could place on the switched power wire that would work the same? Or is the switched power wire on a fuse? I checked the fuses that I thought would be related to it, but they all seem fine.



    2004 Ford Freestar
    Trying to figure out where to put a sub without compromising space in the back...




  2. #2
    Worlddre's Avatar
    Worlddre is offline Big Darkie



    Join Date
    Sep 2004
    Location
    Charlotte, NC
    Age
    30
    Posts
    17,901
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Dead ignition wire

    did you replace the fuse you blew?






    "humility in the face of overwhelming genius will obviously amount to hypocrisy"

  3. #3
    Another Device's Avatar
    Another Device is offline Member

    Threadstarter


    Join Date
    Jun 2003
    Location
    MO
    Age
    31
    Posts
    94
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Dead ignition wire

    Yes I did, and I also just realized I was looking at my fuse placement diagram backwards. I blew the radio fuse, along with a couple others. I replaced the radio fuse and now it works fine.



    2004 Ford Freestar
    Trying to figure out where to put a sub without compromising space in the back...

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum