Closed Thread
Results 1 to 7 of 7

Reload Thread: Stinger GM battery terminal question?

  1. #1
    gnet158's Avatar
    gnet158 is offline Senior VIP Member



    Join Date
    May 2005
    Location
    Orange County
    Posts
    155
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Stinger GM battery terminal question?

    What am I doing wrong? I have a 2002 GMC Sierra and purchased the following to connect my amp to my trucks battery.

    Stinger GM battery tap (for the single power cable)
    Stinger Pro ring terminal

    First I removed the Positive OEM battery tap and replaced it with the Stinger. I then ran the amps power cable into the ring terminal (with plenty of exposed wire), attached it to the battery tap and then tighten everything up. I put the keys in and turn the ignition to its first position, my system turns on and everything seems fine. But when I turn the keys to the next position (to start my truck) I hear a click and everything dies. I am unable to start my truck and nothing turns on.

    The only way to get the truck to turn on is to replace everything back to stock. Any ideas?



    H/U = Alpine 9830
    Alp-Sir1 Sirius tuner = Sirius Sat Radio
    Front Door Speakers = Alpine SPS-170A '6 1/2
    Rear Door Speakers = Pioneer TG-1040R '3
    Sub = Infinity Reference '10 1030
    Amp = Profile CA600

    Sound =
    Thump =




  2. #2
    Raffi's Avatar
    Raffi is offline Bring our TROOPS HOME!!!!



    Join Date
    May 2005
    Location
    Orlando, Florida
    Posts
    1,192
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: Stinger GM battery terminal question?

    Make sure the Pos Bat terminal is making good contact also make sure the bat pole is clean...



    I Love This country

  3. #3
    johnecon2001's Avatar
    johnecon2001 is offline SSA/ROE Super-Møderator



    Join Date
    Aug 2004
    Location
    Phoenix, AZ
    Age
    31
    Posts
    5,137
    Post Thanks / Like
    Images
    12
    Mentioned
    0 Post(s)

    Re: Stinger GM battery terminal question?

    did you put the power wire for the rest of the car back to the terminal?




    Don't PM me, I'm not here. Find me on SSA or ROE
    No, I won't re-upload the Big3 pictures. Don't ask.

  4. #4
    SUB_URBAN's Avatar
    SUB_URBAN is offline Almost ******



    Join Date
    Oct 2005
    Location
    J-ville Florida
    Age
    26
    Posts
    2,059
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Stinger GM battery terminal question?

    Make sure that ghey red thing that hooks the rest of your car is hooked up and actually touching, sometimes it will like float and not touch its weird. Sorry to tell you this but you could have gotten a longer bolt for your bat at home depot for 70 cents and it would work better than teh stinger.



    Quote Originally Posted by RumbleNTheTrunk
    damn. 8 10"s?........80" of cone area FTW!
    Current Setup
    -Hifonics BX1500d
    -12" Type R wired to 1 ohm (sometimes replaced by infinity Reference 12" i bought for $5. IT WANGS)
    in 2.6 ft box tuned to 34 hz.

    Needs to get metered.
    Coming soon 4 15" Orion Prototype Xtrs
    Powered by an Orion 2500d at .5ohms
    250 amp alt.

  5. #5
    gnet158's Avatar
    gnet158 is offline Senior VIP Member

    Threadstarter


    Join Date
    May 2005
    Location
    Orange County
    Posts
    155
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Stinger GM battery terminal question?

    “Make sure the Pos Bat terminal is making good contact also make sure the bat pole is clean.”

    Yes it’s touching and clean


    “did you put the power wire for the rest of the car back to the terminal?”

    Yes I did, it went in this order, OEM power cables touching the battery first, then I bolted in, I then removed the smaller bolt to connect the ring terminal.


    “Make sure that ghey red thing that hooks the rest of your car is hooked up and actually touching, sometimes it will like float and not touch its weird. Sorry to tell you this but you could have gotten a longer bolt for your bat at home depot for 70 cents and it would work better than the stinger.”

    I’ll check for that, would you happen to know the size of the bolt you’re taking about? I called Stinger again and went back and fourth with the tech, he sound like he kind of knew what he was talking about. I went thru my installation step by step a few times. After asking him the same questions over and over he may have picked up on something. When I ask him how much of the 8 guage power cable I needed to feed into the ring terminal connector he said “about a quarter inch”. I then asked “so the screw on the connector doesn’t need to touch bare wire?”. He said it did need to touch bare wire. I think I was only feeding enough bare wire to touch the actual ring connector and the screw was hitting the insulation. I don’t know, I’m going to give it another shot this weekend.

    Thanks for you help!



    H/U = Alpine 9830
    Alp-Sir1 Sirius tuner = Sirius Sat Radio
    Front Door Speakers = Alpine SPS-170A '6 1/2
    Rear Door Speakers = Pioneer TG-1040R '3
    Sub = Infinity Reference '10 1030
    Amp = Profile CA600

    Sound =
    Thump =

  6. #6
    SUB_URBAN's Avatar
    SUB_URBAN is offline Almost ******



    Join Date
    Oct 2005
    Location
    J-ville Florida
    Age
    26
    Posts
    2,059
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Stinger GM battery terminal question?

    good luck mine has done the same thing, all i would do is undo it and reconnect and it would work.



    Quote Originally Posted by RumbleNTheTrunk
    damn. 8 10"s?........80" of cone area FTW!
    Current Setup
    -Hifonics BX1500d
    -12" Type R wired to 1 ohm (sometimes replaced by infinity Reference 12" i bought for $5. IT WANGS)
    in 2.6 ft box tuned to 34 hz.

    Needs to get metered.
    Coming soon 4 15" Orion Prototype Xtrs
    Powered by an Orion 2500d at .5ohms
    250 amp alt.

  7. #7
    gnet158's Avatar
    gnet158 is offline Senior VIP Member

    Threadstarter


    Join Date
    May 2005
    Location
    Orange County
    Posts
    155
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Finally got everything to work

    Here's what fixed it.

    1. The POS battey cable has a RED rubber housing round it. I needed to pop this housing off to remove the stock battery bolt. When I put the Stinger bolt in and hooked everything up nothing, no power. I then left the housing off and connected the + & -, and everything powered up. So I put the rubber housing backon but made sure that the part that touchs the batter was out of the housing.

    2. Stripped back enough 8 guage power cable to make sure that the bolt in my Stinger Pro ring terminal was hitting the wire and not the cabling sheild. I didn't do that last time.

    Everything works, thanks for your suggestions!



    H/U = Alpine 9830
    Alp-Sir1 Sirius tuner = Sirius Sat Radio
    Front Door Speakers = Alpine SPS-170A '6 1/2
    Rear Door Speakers = Pioneer TG-1040R '3
    Sub = Infinity Reference '10 1030
    Amp = Profile CA600

    Sound =
    Thump =

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum