Closed Thread
Results 1 to 9 of 9

Reload Thread: need some install help

  1. #1
    springy101's Avatar
    springy101 is offline village idiot/racist



    Join Date
    Sep 2005
    Location
    Sacramento, CA
    Age
    25
    Posts
    8,152
    Post Thanks / Like
    Mentioned
    0 Post(s)

    need some install help

    ok so all today i have been working on my car, finally got my ground/power/remote ran to the trunk. to make a long story short i thought the battery was disconected but it wasnt, and i was put the ground in last after the power and remote wires and heard a loud pop. i checked my battery fuse and my distro fuse and they are fine, but i cant get the other dam fuses out of my amp. all my other electrical stuff still works in my car but my amp wont power on. what else may have happened besides popping a fuse. i already tried taking the amp apart to look at the board but best i could do is see the underside of it and nothing looked burnt or black. btw my amp is a kenwood kac-9152d



    I must follow in eugenics' footsteps, for he is great

    Ref's: Ebay


    VOA_NIGHTMARE, Blados, frankga2, allenzo, bamaboy x2, Crown_amps, violentrapture, adio x3, bumpin_blazer, fi car audio, haunther, sbcaprice305 x2




  2. #2
    springy101's Avatar
    springy101 is offline village idiot/racist

    Threadstarter


    Join Date
    Sep 2005
    Location
    Sacramento, CA
    Age
    25
    Posts
    8,152
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need some install help

    well finally got the fuses out of the amp and they are fine too



    I must follow in eugenics' footsteps, for he is great

    Ref's: Ebay


    VOA_NIGHTMARE, Blados, frankga2, allenzo, bamaboy x2, Crown_amps, violentrapture, adio x3, bumpin_blazer, fi car audio, haunther, sbcaprice305 x2

  3. #3
    sws10's Avatar
    sws10 is offline Banned



    Join Date
    Jul 2006
    Location
    Amarillo, Tx
    Posts
    351
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need some install help

    hmm very interesting




  4. #4
    skydeaner's Avatar
    skydeaner is offline suede humper



    Join Date
    Aug 2006
    Location
    Champaign, IL
    Age
    29
    Posts
    1,216
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: need some install help

    get a dmm and check for 12 volts at the turn on and at the power connection.




  5. #5
    springy101's Avatar
    springy101 is offline village idiot/racist

    Threadstarter


    Join Date
    Sep 2005
    Location
    Sacramento, CA
    Age
    25
    Posts
    8,152
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need some install help

    what settings on my dmm to i set to check for that, i had it on the AC 750volt and it kept giving me around 30 at my battery.



    I must follow in eugenics' footsteps, for he is great

    Ref's: Ebay


    VOA_NIGHTMARE, Blados, frankga2, allenzo, bamaboy x2, Crown_amps, violentrapture, adio x3, bumpin_blazer, fi car audio, haunther, sbcaprice305 x2

  6. #6
    springy101's Avatar
    springy101 is offline village idiot/racist

    Threadstarter


    Join Date
    Sep 2005
    Location
    Sacramento, CA
    Age
    25
    Posts
    8,152
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need some install help

    bump i need help



    I must follow in eugenics' footsteps, for he is great

    Ref's: Ebay


    VOA_NIGHTMARE, Blados, frankga2, allenzo, bamaboy x2, Crown_amps, violentrapture, adio x3, bumpin_blazer, fi car audio, haunther, sbcaprice305 x2

  7. #7
    iceteebone's Avatar
    iceteebone is offline Banned



    Join Date
    Aug 2003
    Location
    Michigan
    Age
    29
    Posts
    37,876
    Post Thanks / Like
    Images
    7
    Mentioned
    3 Post(s)

    Re: need some install help

    well for starters to measure current in the car you need the dmm set to dc. does the amp turn on? does it go into protect? maybe your speaker blew. if the amp turns on, disconnect the speaker and check your amp outputs like you are setting the gains. if that reads fine test the voice coils on the sub




  8. #8
    springy101's Avatar
    springy101 is offline village idiot/racist

    Threadstarter


    Join Date
    Sep 2005
    Location
    Sacramento, CA
    Age
    25
    Posts
    8,152
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need some install help

    Quote Originally Posted by iceteebone View Post
    well for starters to measure current in the car you need the dmm set to dc. does the amp turn on? does it go into protect? maybe your speaker blew. if the amp turns on, disconnect the speaker and check your amp outputs like you are setting the gains. if that reads fine test the voice coils on the sub
    amp doesnt not turn on, didnt even have a speaker attached wanted to do a test run to see if the amp worked before i put my box and crap in the trunk



    I must follow in eugenics' footsteps, for he is great

    Ref's: Ebay


    VOA_NIGHTMARE, Blados, frankga2, allenzo, bamaboy x2, Crown_amps, violentrapture, adio x3, bumpin_blazer, fi car audio, haunther, sbcaprice305 x2

  9. #9
    springy101's Avatar
    springy101 is offline village idiot/racist

    Threadstarter


    Join Date
    Sep 2005
    Location
    Sacramento, CA
    Age
    25
    Posts
    8,152
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: need some install help

    help bump



    I must follow in eugenics' footsteps, for he is great

    Ref's: Ebay


    VOA_NIGHTMARE, Blados, frankga2, allenzo, bamaboy x2, Crown_amps, violentrapture, adio x3, bumpin_blazer, fi car audio, haunther, sbcaprice305 x2

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum