Closed Thread
Results 1 to 2 of 2

Reload Thread: Electrical Problems...

  1. #1
    RumbleNTheTrunk's Avatar
    RumbleNTheTrunk is offline CarAudio.com Elite



    Join Date
    Jun 2005
    Location
    Liberty, TX
    Age
    25
    Posts
    1,922
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Electrical Problems...

    Alright so saturday I got my system put in and all...elevation audio x 12" sub pushed by elevation audio 1500.1 pushes it at around 1800-1900 watts.....I was getting some extensive drops on bass notes, I got a 200a excessive amperage alt and odyssey pc 1700 battery....sunday was voltmeter read 8 volt! the whole day i was driving on that it was worse at night because my headlights werent as bright. So I decided to take it out and charge it over night, I did so put it back in today and on the meter on the truck it stilll shows it being below normal...so what happened? im not running my system anymore shouldnt my alt have charged my battery? what does this sound like...faulty alt? or faulty battery...both were purchased around last year so they've been in awhile and never gave me this problem(but this is the biggest system ive ran) so what should i do? send it in and let them test it? I was thinking about just going ahead and getting it upgrade to a 300a alt. Or could it possibly be by battery?



    2009 Pontiac G8 GT
    SLP Loud Mouth Axleback -- Installed
    Vararam CAI w/ HSRK -- On the way
    ARH 1 7/8 Headers Catted -- Very soon



    Feedback here

    CLICK HERE




  2. #2
    80_Cutlass_mn's Avatar
    80_Cutlass_mn is offline What needs to be here?



    Join Date
    Nov 2002
    Location
    Anderson,Al
    Age
    28
    Posts
    1,809
    Post Thanks / Like
    Images
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Electrical Problems...

    Hmm...sounds to me like your alternator has taken a crap on ya. If you turn your system off and the voltage still doesnt come up to normal then its not charging. Normal charging voltage would be about 13-14.4 volts.



    Arctic White 1995 Camaro 3.4L

    Hifonics BX2005D- 12" IA Death Penalty
    Premier prs-x220 - MB Quart DSD213 components
    Pioneer DEH-P7600MP - Scosche 4 Ga. wiring kit

    Aol Instant Messanger: CamaroMN1995

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum