User Tag List

Closed Thread
Results 1 to 11 of 11

Reload Thread: battery/alternator help

  1. #1
    slim j's Avatar
    slim j is offline Senior VIP Member



    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    battery/alternator help

    I installed a new "HO" alternator yesterday and on the way home, my charge light came on. I use a DMM to check the voltage at the battery and it read 12.2, I am sure this is a problem. What can I do to check and see if I have a drain on the battery? Put the DMM on battery with the car off and see if it drops?



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.




  2. #2
    XtrmAudioCncpts's Avatar
    XtrmAudioCncpts is offline CarAudio.com Veteran



    Join Date
    Mar 2005
    Location
    Fairfax, Va
    Age
    28
    Posts
    4,294
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    make sure you hooked everything up to your alt right. the same thing happened to me and i found out that i had forgotten to hook up one wire and it screwed my battery up





    Quote Originally Posted by Devillain00
    XAC = pimpin since been pimpin

  3. #3
    slim j's Avatar
    slim j is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    I only have one wire that goes to the battery. Then I have this plug thing. It just plugs in. I may re-check to make sure the wire is very securly connected tothe battery.



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.

  4. #4
    slim j's Avatar
    slim j is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    I checked and rechecked all connections. For some reason my battery stays pegged at 12.33. Any new ideas?



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.

  5. #5
    knukonceptz's Avatar
    knukonceptz is offline CarAudio.com Elite



    Join Date
    May 2003
    Location
    Ohio
    Posts
    735
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    What is the voltage with the car off? May not be charging at all....Check voltage at the back of the ALT too




  6. #6
    slim j's Avatar
    slim j is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    It is 12.3 on at both @ the alt (using the battery for the black prong, if it matters) and 12.3 at the battery. Off, it drops to about 11.98-11.89



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.

  7. #7
    knukonceptz's Avatar
    knukonceptz is offline CarAudio.com Elite



    Join Date
    May 2003
    Location
    Ohio
    Posts
    735
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    Either the ALT or the install of the ALT went south. Did you ever check voltage after the install?




  8. #8
    slim j's Avatar
    slim j is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    No, I did not. I should have had it tested beforehand but I did not. What items could cause the alt to go bad during the install?



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.

  9. #9
    slim j's Avatar
    slim j is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    Since it isn't too hard to remove, I am going to take it to advance auto parts tomorrow to see if it is my install or the alternator itself.



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.

  10. #10
    knukonceptz's Avatar
    knukonceptz is offline CarAudio.com Elite



    Join Date
    May 2003
    Location
    Ohio
    Posts
    735
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    To many things to speculate on. Still have the old unit? Was that one working and you just wanted to go with a higher output?

    If the other one went bad, could be something causing them to go bad....just a thought.




  11. #11
    slim j's Avatar
    slim j is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2005
    Location
    ca.com
    Age
    34
    Posts
    466
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: battery/alternator help

    Other one worked well. It was starting to hurt due to age and excessive current draw, I didn't want to wait until it died and left me stranded



    Quote Originally Posted by woody89
    I hope your subs are better than your grammar.

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum