Closed Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 34

Reload Thread: fuses on amp fry everytime

  1. #1
    poopspoon's Avatar
    poopspoon is offline Member



    Join Date
    Oct 2005
    Location
    west alexandria,OH
    Age
    27
    Posts
    89
    Post Thanks / Like
    Mentioned
    0 Post(s)

    fuses on amp fry everytime

    ok guys i have a problem with a kenwood amp. every time i try to hook this thing up it will fry the fuses. what is my problem. i got every thing wired poperly and when ever i touch the positive on the battery it zaps the fuses. how could i get this thing going?







  2. #2
    n2audio's Avatar
    n2audio is offline OPTIDRIVEN



    Join Date
    Dec 2001
    Location
    Lawrence, KS
    Posts
    4,285
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    My old Lanzar 1200D did that - it was toast. Lanzar replaced it, no questions asked. Not sure how Kenwood will handle it.




  3. #3
    poopspoon's Avatar
    poopspoon is offline Member

    Threadstarter


    Join Date
    Oct 2005
    Location
    west alexandria,OH
    Age
    27
    Posts
    89
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    i bought this amp off of a freind about 5 days ago and i listened to it and everything but when i went to put it in another car it just started blowing fuses and everything.




  4. #4
    Moe Lester's Avatar
    Moe Lester is offline 1/3 of TEAM PWNAGE



    Join Date
    Dec 2003
    Location
    Houston, TX
    Age
    27
    Posts
    3,614
    Post Thanks / Like
    Images
    10
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    do you have the + and - power wires on the amp backwards on accident? I know a guy who did this with an amp and he couldnt figure out why his fuses kept popping lol.




  5. #5
    squeak12's Avatar
    squeak12 is offline CarAudio.com Veteran



    Join Date
    Apr 2005
    Location
    Thomaston, GA
    Posts
    3,671
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    Are you hooking the amp up with the negative bat. terminal on? Try undoing that and then hooking the amp up then put the neg. bat. back on.




  6. #6
    poopspoon's Avatar
    poopspoon is offline Member

    Threadstarter


    Join Date
    Oct 2005
    Location
    west alexandria,OH
    Age
    27
    Posts
    89
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    im not using the - on battery it is grounded to chassis

    il try to change them around but the amp says gnd and batt or something like that but i can try switching them




  7. #7
    Moe Lester's Avatar
    Moe Lester is offline 1/3 of TEAM PWNAGE



    Join Date
    Dec 2003
    Location
    Houston, TX
    Age
    27
    Posts
    3,614
    Post Thanks / Like
    Images
    10
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    Quote Originally Posted by poopspoon
    im not using the - on battery it is grounded to chassis

    il try to change them around but the amp says gnd and batt or something like that but i can try switching them
    dont try switching them if they are right, just make sure youve got them hooked up correctly




  8. #8
    squeak12's Avatar
    squeak12 is offline CarAudio.com Veteran



    Join Date
    Apr 2005
    Location
    Thomaston, GA
    Posts
    3,671
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    I meant complete the circuit at the battery not at the amp when your hooking it up. Hook the amp up with the neg. on the battery disconnected, then when your done, hook the battery back up and turn the car on to see if it worked.




  9. #9
    poopspoon's Avatar
    poopspoon is offline Member

    Threadstarter


    Join Date
    Oct 2005
    Location
    west alexandria,OH
    Age
    27
    Posts
    89
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    the car doesnt even have to be on for it to fry




  10. #10
    BassManB's Avatar
    BassManB is offline giggity giggity goo



    Join Date
    Jun 2005
    Location
    estill co. KY
    Age
    24
    Posts
    642
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    where do u have ur remote turn on wire hooked to? is it hooked up to a constant +12v wire?



    1989 Mustang LX 2.3L 4 cyl.

    JVC KD-S30 Head Unit
    Volfenhag 2 channel....

    (2) 10" Pioneer IMPP's

    Highs= JL Audio TR650 CX

    Schoche 8 gage wiring kit


    High Amp= Majestic Audio MA S 8600

  11. #11
    poopspoon's Avatar
    poopspoon is offline Member

    Threadstarter


    Join Date
    Oct 2005
    Location
    west alexandria,OH
    Age
    27
    Posts
    89
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    it fries with out even having the remote on with it on will it make a difference




  12. #12
    Blunt's Avatar
    Blunt is offline 2009 ProStock 0-600 Champ



    Join Date
    Aug 2005
    Location
    Somewhere
    Age
    32
    Posts
    2,102
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    Ok try this lol

    Step 1: Unhook negative battery cable
    Step 2: hook all wires to amp correctly
    Step 3: hook the negative battery cable back up

    Fuse still pop?



    Quote Originally Posted by DBfan187
    Ever laughed so hard that your spincter hurt? Think that's what it feels like when you stuck in a cage with an ape during mating season?
    87 S-10 Ext Cab 4x4
    3 Treo SSX 15's
    1 Treo CXT4.1i
    2 200 amp Ohio Gen Alts

    2009 USACi Pro Stock 0-600 World Champion
    TEAM DB DRIVEN
    TEAM TREO
    BROKEN SILENCE C.C.


    refs: HCCAfan,meka,slain93gsr,spitfirees20,iceteebone,sa kura,john payton,Mr. Loki, 96MaxGLE, speedfreak28

  13. #13
    poopspoon's Avatar
    poopspoon is offline Member

    Threadstarter


    Join Date
    Oct 2005
    Location
    west alexandria,OH
    Age
    27
    Posts
    89
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    yea it still does but would it matter if the remote was on and rca cables?




  14. #14
    Mr. Opportunist's Avatar
    Mr. Opportunist is offline CarAudio.com Veteran



    Join Date
    May 2005
    Location
    Chicago, IL
    Posts
    3,564
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    why is the remote on an rca cable?




    Quote Originally Posted by the12voltsux View Post
    You low voltage may be due to having three batteries. have you tried only using one battery?

  15. #15
    squeak12's Avatar
    squeak12 is offline CarAudio.com Veteran



    Join Date
    Apr 2005
    Location
    Thomaston, GA
    Posts
    3,671
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: fuses on amp fry everytime

    If he has KnuKoncepts Klarity RCAs, they have a built in remote. They arent in the RCA but are attached along with the RCAs.




Closed Thread
Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum