Closed Thread
Results 1 to 6 of 6

Reload Thread: Problem with HO alt. Help!

  1. #1
    wj94's Avatar
    wj94 is offline CarAudio.com Veteran



    Join Date
    Apr 2004
    Location
    virginia
    Posts
    2,127
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Problem with HO alt. Help!

    I bought a 240A alternator from Iraggi a few months ago and just got around to having it installed about 2 weeks ago. A Hawker Odyssey battery and the big 3 was done with 1/0 gauge as well. The amplifiers are a Tsunami db1800t and Cadence Z8000 (total RMS = roughly 2100w), although it shouldn't be drawing full wattage constantly for music.

    When I drive at night, my lights still dim a decent amount, even when the RPMs are 1800+. Honestly, I'm a little disappointed after having spent $500 to upgrade the electrical system. I know amps aren't 100% efficient and can draw a lot of amperage, but it doesn't seem like the HO alt. is making a big difference over the stock 130A alternator. Is there any way I can test the output of the alternator to ensure it's doing the job right?







  2. #2
    InhumanAcura's Avatar
    InhumanAcura is offline 1/3ofTEAM PwNAGE..*****es



    Join Date
    Feb 2004
    Location
    South Florida
    Posts
    8,639
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Problem with HO alt. Help!

    get the alt benched...

    i dont understand why people go out and spend an assload on a ho alt when they can spend a fraction of that on a secondary battery..which in your case, will solve your problem...




  3. #3
    wj94's Avatar
    wj94 is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Apr 2004
    Location
    virginia
    Posts
    2,127
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem with HO alt. Help!

    Where can I get it benched? Every place I see only tests voltage, not amperage. I'm not an electrical expert, I just heard "HO Alt this, HO Alt that" and wanted to get it done right the first time, rather than doing something else and having problems down the line and spending even more money.




  4. #4
    tommyk90's Avatar
    tommyk90 is offline THE WHOLE THING!!!



    Join Date
    Oct 2002
    Location
    Chicago Heights, IL
    Age
    29
    Posts
    16,638
    Post Thanks / Like
    Images
    20
    Mentioned
    29 Post(s)

    Re: Problem with HO alt. Help!

    Quote Originally Posted by InhumanAcura
    get the alt benched...

    i dont understand why people go out and spend an assload on a ho alt when they can spend a fraction of that on a secondary battery..which in your case, will solve your problem...
    Because people like me can only have one battery in their SPL class.

    Any i know that my HO alt solved my dimming problems while i was driving (parked is another story). I'd definitely see if you can get the output tested somewhere.




    Team Kicker (R.I.P.)
    Team Sundown
    Team Maxxsonics
    Team XS Power
    Team DD
    Team Audio Technix
    Team B2 Audio
    Team Mechman
    Team Tantric Sounds

    2008 Bassrace 130-139.9 Regional and National Champion
    2006, 2007, 2009, 2010 and 2012 MECA Champion (S1, SR1, DB1, S2, S3, S4)

    One DD 9510 powered by two Sundown SAZ-2500's
    Kicker KS tweeters, MB Quart 5.25's active on an MB Quart DSC480
    Kicker wiring throughout.



  5. #5
    InhumanAcura's Avatar
    InhumanAcura is offline 1/3ofTEAM PwNAGE..*****es



    Join Date
    Feb 2004
    Location
    South Florida
    Posts
    8,639
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Problem with HO alt. Help!

    we can only have a single battery as well...

    he has a ho alt, he's done the big 3, and has a good battery....seems the only thing he can do is throw a second battery in.

    if competing is a concern, just take the second battery out..only takes a minute.




  6. #6
    wj94's Avatar
    wj94 is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    Apr 2004
    Location
    virginia
    Posts
    2,127
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem with HO alt. Help!

    I don't compete. Perhaps I'll look into a yellow-top or equivelent for the trunk.




Closed Thread

Similar Threads

  1. Smaller Pulley for my 200amp alt from excesamp.com
    By bobo244 in forum General Discussion
    Replies: 13
    Last Post: 01-01-2006, 09:27 PM
  2. HO alt installed, voltage not high enough
    By Stillmatic22 in forum Wiring, Electrical and Installation Help
    Replies: 8
    Last Post: 07-25-2005, 04:35 PM
  3. where can i get my alt. beefed up?
    By aphinney in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 07-05-2004, 02:41 PM
  4. Problem with H/U turning itself on and off randomly
    By Forty-Ouncer in forum General Discussion
    Replies: 2
    Last Post: 06-26-2004, 01:55 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum