Closed Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 37

Reload Thread: WTT: Non working beastly us amps 4 ch.

  1. #1
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite



    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    WTT: Non working beastly us amps 4 ch.

    1. Product:

    ShipSound.com
    $719.95!

    2. Specs:

    75 x 4 @ 4 ohm
    90 x 4 @ 2 ohm
    180 x 2 @ 4 ohm bridged

    3. Description/Condition:

    7.5/10 cosmetically
    Mechanically: it powers on and just had it working a month ago
    It has output on 2 of the channels and now there is no output.
    It does not go into protect and also has never been ran under 12.8v
    NO BURNS at all that I can see on the board and my guess is that it wouldnt take much to fix but I have no use for it anymore.

    4. Price: :
    Motors, amps, hu, batts, etc
    Or
    $65 + shipping

    6. Pictures:














  2. #2
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Still here




  3. #3
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Anyone there?

    ---------- Post added at 08:33 PM ---------- Previous post was at 08:32 PM ----------

    It's also got a crack on one of the mounting feet




  4. #4
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Bump!!




  5. #5
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Bump still here




  6. #6
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    $50 shipped until Christmas




  7. #7
    Audiohazzard's Avatar
    Audiohazzard is offline Audiohazzard



    Join Date
    Dec 2010
    Location
    St. Johns, FL
    Posts
    223
    Post Thanks / Like
    Images
    3
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    I have a old school fosgate HX2 12" basket and motor I'll trade you for the amp, pm me if you would be interested




  8. #8
    ItsAJeepThing's Avatar
    ItsAJeepThing is offline CarAudio.com Elite



    Join Date
    Oct 2010
    Location
    Lincoln,NE
    Posts
    618
    Post Thanks / Like
    Feedback Score
    9 (100%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    36 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    15" Fi Q?



    Alpine 9885
    American Bass 150.1
    2 15" AQ HDC3

  9. #9
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Still here




  10. #10
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    bump




  11. #11
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Bump




  12. #12
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Still here?




  13. #13
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    anyone else?




  14. #14
    got160s?'s Avatar
    got160s? is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2011
    Location
    Michigan
    Posts
    894
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    66 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    Omg no one wants a beastly 4 channel?




  15. #15
    disturbed471985's Avatar
    disturbed471985 is offline CarAudio.com Veteran



    Join Date
    Jun 2009
    Location
    Greenwood, La
    Age
    30
    Posts
    7,534
    Post Thanks / Like
    Feedback Score
    22 (100%)
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1050 Post(s)

    Re: WTT: Non working beastly us amps 4 ch.

    I would be interested in it but no real way to know if its going to cost 50 to repair or 300..



    RIP Maynard "My heart"

    HU - Looking
    Front Stage - 6 Sundown Neo-Pro 6.5s. 2 - DD VO B2's
    Front Stage amp - Twisted 150.4
    Subwoofer -2 FI Sp4 15's "Full Load"
    Subwoofer Amp - 2 FSD 2600s...
    Box - Walled
    Wiring/Electrical -Looking for wire...4 Northstar G31's, Mechman 280

Closed Thread
Page 1 of 3 1 2 3 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum