Closed Thread
Results 1 to 11 of 11

Reload Thread: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

  1. #1
    dennit469's Avatar
    dennit469 is offline CarAudio.com Elite



    Join Date
    Jan 2008
    Location
    Clemson, SC
    Posts
    1,396
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)

    wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    let me knwo what you got



    Lexus IS300- Bumpin stock untill its not so hot outside.
    Damp Pro (not installed)
    Head: Kenwood eXcelon KDC-X993 (not installed)
    Current about to be front stage: PPI A1200 Powering a set of Image Dynamics XS-65's.
    sold to: bluevu77, nick06tc, massivespl, skylineTT, farmereshan, RidinHi, revrider1, Therum, budahbuddy803, blinkdogo2
    bought from: blinkdogo2, fasfocus00, budahbuddy803, (others i dont remember...)
    SCAMMED BY 1indatrunk




  2. #2
    dennit469's Avatar
    dennit469 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2008
    Location
    Clemson, SC
    Posts
    1,396
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    bump



    Lexus IS300- Bumpin stock untill its not so hot outside.
    Damp Pro (not installed)
    Head: Kenwood eXcelon KDC-X993 (not installed)
    Current about to be front stage: PPI A1200 Powering a set of Image Dynamics XS-65's.
    sold to: bluevu77, nick06tc, massivespl, skylineTT, farmereshan, RidinHi, revrider1, Therum, budahbuddy803, blinkdogo2
    bought from: blinkdogo2, fasfocus00, budahbuddy803, (others i dont remember...)
    SCAMMED BY 1indatrunk

  3. #3
    King_corral's Avatar
    King_corral is offline Id Hit IT!....With A BAT!



    Join Date
    May 2009
    Location
    Indiana
    Posts
    1,906
    Post Thanks / Like
    Feedback Score
    0
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    Sig




  4. #4
    vitveet's Avatar
    vitveet is offline CarAudio.com Veteran



    Join Date
    Oct 2004
    Location
    NC
    Posts
    3,630
    Post Thanks / Like
    Feedback Score
    14 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    Have a very nice MTX 502 2 channel amp that does 250 wts per channel. PERFECT mechanically AND cosmetically! Looks and performs brand new! I'll do $90 shipped on it!

    V.



    Lexus IS300
    Pioneer 4300dvd
    Vifa Tweets
    Knukonceptz wire
    2 many high end subs/amps to list!

    Vitveet = ENCLOSURES
    vitveet@hotmail.com for your custom enclosures!
    thousands of build pics, just ask to see them!
    PLEASE EMAIL ME SINCE PM'S ARE FULL!

  5. #5
    dennit469's Avatar
    dennit469 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2008
    Location
    Clemson, SC
    Posts
    1,396
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    i had this same one before and wasnt to impressed with the SQ, plus it got pretty hot



    Lexus IS300- Bumpin stock untill its not so hot outside.
    Damp Pro (not installed)
    Head: Kenwood eXcelon KDC-X993 (not installed)
    Current about to be front stage: PPI A1200 Powering a set of Image Dynamics XS-65's.
    sold to: bluevu77, nick06tc, massivespl, skylineTT, farmereshan, RidinHi, revrider1, Therum, budahbuddy803, blinkdogo2
    bought from: blinkdogo2, fasfocus00, budahbuddy803, (others i dont remember...)
    SCAMMED BY 1indatrunk

  6. #6
    ciaonzo's Avatar
    ciaonzo is offline TheContinental



    Join Date
    Feb 2009
    Location
    WI
    Age
    39
    Posts
    9,234
    Post Thanks / Like
    Feedback Score
    25 (100%)
    Mentioned
    33 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms




    Quote Originally Posted by audioholic View Post
    Saying "clipping doesn't kill speakers" is a half-truth at best. Technically no, clipping itself does not hurt the speaker. But in clipping your amp, you can easily create a situation that WILL kill the speaker. Was the squared waveform the DIRECT cause of the failure? No. In the end, the answer is, always has been, and can only be... heat kills speakers. BUT, clipping increases heat generation, sometimes by a drastic amount. So to start a thread simply to state that clipping does not hurt speakers is, again, a half-truth at best.

  7. #7
    nismos14's Avatar
    nismos14 is offline CarAudio.com Veteran



    Join Date
    Dec 2006
    Location
    Jersey
    Age
    33
    Posts
    14,518
    Post Thanks / Like
    Feedback Score
    7 (100%)
    Mentioned
    4 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms







    Car audio IS an addiction.
    C.A.A.A Member #1
    (Car Audio Addicts Anonymous)
    Refs http://www.caraudio.com/forums/buyer-seller-feedback/278560-nismos14-feedback-refs-thread.html


  8. #8
    dennit469's Avatar
    dennit469 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2008
    Location
    Clemson, SC
    Posts
    1,396
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    looking to spend around 125 dollars, max



    Lexus IS300- Bumpin stock untill its not so hot outside.
    Damp Pro (not installed)
    Head: Kenwood eXcelon KDC-X993 (not installed)
    Current about to be front stage: PPI A1200 Powering a set of Image Dynamics XS-65's.
    sold to: bluevu77, nick06tc, massivespl, skylineTT, farmereshan, RidinHi, revrider1, Therum, budahbuddy803, blinkdogo2
    bought from: blinkdogo2, fasfocus00, budahbuddy803, (others i dont remember...)
    SCAMMED BY 1indatrunk

  9. #9
    dennit469's Avatar
    dennit469 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jan 2008
    Location
    Clemson, SC
    Posts
    1,396
    Post Thanks / Like
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    bump



    Lexus IS300- Bumpin stock untill its not so hot outside.
    Damp Pro (not installed)
    Head: Kenwood eXcelon KDC-X993 (not installed)
    Current about to be front stage: PPI A1200 Powering a set of Image Dynamics XS-65's.
    sold to: bluevu77, nick06tc, massivespl, skylineTT, farmereshan, RidinHi, revrider1, Therum, budahbuddy803, blinkdogo2
    bought from: blinkdogo2, fasfocus00, budahbuddy803, (others i dont remember...)
    SCAMMED BY 1indatrunk

  10. #10
    andrewmoore13's Avatar
    andrewmoore13 is offline CarAudio.com Veteran



    Join Date
    Oct 2007
    Location
    Gloucester, MA
    Age
    27
    Posts
    2,188
    Post Thanks / Like
    Images
    5
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    if you can come up with some more cash

    http://www.caraudio.com/forum/showth...62#post6206262



    HU: Alpine iVA-w505
    Processor: Alpine PXA-H701
    Front Doors: Shok Comps
    AMP Speakers: Diamond Audio D7104
    AMP Subs: American Bass VFL 150.1 gold
    Subs: 2 Custom Sundown Z12s. Dual 2
    Kicker 1/0 wire (soon to be Shok 1/0)
    Stinger SPV44 and a XS Power 5100

    refs: http://www.caraudio.com/forum/showthread.php?p=5007514#post5007514

  11. #11
    profoundwill's Avatar
    profoundwill is offline CarAudio.com Elite



    Join Date
    Nov 2004
    Location
    Birmingham, AL
    Posts
    1,247
    Post Thanks / Like
    Feedback Score
    3 (100%)
    Mentioned
    0 Post(s)

    Re: wtb: 2 channel amp at a good rated 150rms each channel at 2 ohms

    Got a mint condition JBL GTS300, will let go for $100. Made in the US built like a tank!! Let me know.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum