Closed Thread
Results 1 to 4 of 4

Reload Thread: Question about PowerWedge JL 10's

  1. #1
    jmward27's Avatar
    jmward27 is offline Beer Processor



    Join Date
    Jul 2004
    Location
    Iowa
    Posts
    154
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Question about PowerWedge JL 10's

    All,

    First off, I'm a newbie here so I appreciate in advance any advice and opinion. I used to be pretty hardcore into stereos, but getting married and having a child put a damper on that for a while. Last week I came across a PowerWedge w/ Two 10W0-8's for only $75 on eBay and couldn't pass it up. For an amp I have a Profile Baja 600 watt 2 chan (I know I know) that I got for free from a friend. Finally, I have a Pioneer DEH-P9300 headunit.

    So, got all this hooked up and I was a little disappointed in how they sounded, keeping in mind what I have for an amp. I popped open the box to see what I was dealing with and encountered 2 things. First, they weren't wired in series. Second, they're packed with the fake insulation stuff. Now I know there are theories on insulation, but I've been out of the game so long I can't remember. I've since changed the wiring so they're in series.

    So my question is...keep or pull the insulation? The PowerWedge box has the partition in the middle.

    Also as a side note, my deck has the sub controls for the level, crossover and phase. At first, it didn't sound the greatest, so I put the phase on the deck to reverse and it sounds great.

    SO, I appreciate everyone's input and look forward to any suggestions. Thanks!!







  2. #2
    PhatalOne's Avatar
    PhatalOne is offline Senior VIP Member



    Join Date
    Dec 2003
    Location
    Dayton, OH
    Posts
    150
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Question about PowerWedge JL 10's

    Well I'd keep the insulation unless you would like the bass to be a bit tighter. Second it sounds to me like your subs were out of phase (either they were wired wrong or the amp had the phase setting moved) and so when you reversed it you fixed that problem.

    If you really want to make sure everything is right, you can rewire the box to make sure you are getting the optimum ohm load for your amp and make sure your subs are wired in phase. Then I'd make sure your amp has the phase control on it set to its default (which should be 0) and go from there.

    Overall it sounds like you've solved most of the problems yourself, these would just be additional things you can do to try and not solve it at the deck and possibly try to get a bit more power from your amp. However before I would rewire my subs for a different ohm load I'd make sure I knew what my amp can handle per channel and in bridged mode so you don't accidentally mess up your amp.



    Quote Originally Posted by DBfan187
    Below 30, your gene pool could use a little chlorine!
    Quote Originally Posted by ss3079
    You're definitely proof that evolution can go in reverse.

    You've come to be as welcome here as a hole in a lifeboat. Hope you realize that.

  3. #3
    jmward27's Avatar
    jmward27 is offline Beer Processor

    Threadstarter


    Join Date
    Jul 2004
    Location
    Iowa
    Posts
    154
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Question about PowerWedge JL 10's

    PhatalOne,

    Thanks for the info. I was pretty sure that was the case, but affirmation from others is always a good thing. Am I crazy to think I could get more of a happy medium of low and punchy if I take the insulation out of one of the sub chambers?

    Also, anyone know what a Profile Baja 600 watt 2 chan is worth? Was a factory refurb in the box until about 3 days ago, so obviously used lightly. Wasn't sure if it was appropriate to post that question in the classifieds or not, so what the hell.

    Thanks again.




  4. #4
    PhatalOne's Avatar
    PhatalOne is offline Senior VIP Member



    Join Date
    Dec 2003
    Location
    Dayton, OH
    Posts
    150
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Question about PowerWedge JL 10's

    Well I would try your subs with the insulation in and out. Because taking the insulation out is going to give you more accurate "punchy" bass but your bass will not be as deep. How much it is affected I do not know, so it would come down to your personal preference.

    As far as the amp, I haven't heard anything really bad about Profile amps. From what I hear they put out their rated power and are nice and cheap. I'd search the amp forums for similar Profile models and you'll probably get a good variety of opinions. As for the price on it, check out Crutchfield because they stock alot of Profile amps so you may find something similar. Although that is MSRP so you might want to discount that price a bit since its factory refurb AND the price is from Crutchfield.



    Quote Originally Posted by DBfan187
    Below 30, your gene pool could use a little chlorine!
    Quote Originally Posted by ss3079
    You're definitely proof that evolution can go in reverse.

    You've come to be as welcome here as a hole in a lifeboat. Hope you realize that.

Closed Thread

Similar Threads

  1. Mach 460 mercury question.
    By RoseMarysBaby in forum General Discussion
    Replies: 0
    Last Post: 04-24-2004, 09:39 PM
  2. Replies: 3
    Last Post: 04-22-2004, 04:46 PM
  3. subwoofer question???????
    By clark32980 in forum Subwoofers
    Replies: 4
    Last Post: 02-17-2004, 11:50 PM
  4. A few short, and one long question =) (n00b)
    By exile in forum Wiring, Electrical and Installation Help
    Replies: 17
    Last Post: 12-31-2003, 11:04 PM
  5. Amp wiring question
    By Dookie in forum Amplifiers
    Replies: 0
    Last Post: 11-13-2003, 10:36 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum