+ Reply to Thread
Results 1 to 2 of 2

Reload Thread: Subs not working

  1. #1
    Officialwhistle's Avatar
    Officialwhistle is offline Junior Member



    Join Date
    Jun 2018
    Location
    College Station, TX
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Subs not working

    Hey fellow audio heads I need some help, long story short I hit a curb and my subs went out. I took my head unit out to look at it and I noticed my control wire was out, I put it back in but smoke came out of my head unit wiring . Looks like the fuse on my unit is blown but I'm not sure because my capacitor still turns on just sporadic when it feels like it wants to cut on. Much help needed, it's a pioneer head unit BTW and Jl audio speakers but can't get sound out of them aka bass

    Sent from my SM-N900P using Tapatalk







  2. #2
    Boomin_tahoe's Avatar
    Boomin_tahoe is online now Hurtin' feelings errrday.



    Join Date
    Jul 2005
    Location
    WA
    Posts
    14,531
    Post Thanks / Like
    Images
    2
    Mentioned
    42 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    6180 Post(s)

    Re: Subs not working

    Your running a cap? How hard did you hit the curb?



    97 4 dr. Tahoe
    Interstate battery
    Alpine 9835
    Polk Audio MM6501 comps
    Soundstream Rubicon 1.2500D & 4.500 amps (New amps coming soon)
    2 Sundown Audio X 15's Tuned @ 30Hz.
    Knukonceptz/Royal Excelene wiring

+ Reply to Thread

Similar Threads

  1. Subs not working please HELP!
    By Willsphilly in forum General Discussion
    Replies: 9
    Last Post: 11-17-2011, 12:17 AM
  2. subs not working..
    By andycc529 in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 09-13-2009, 09:55 PM
  3. amp and subs not working right
    By gatorrick5178 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 06-17-2007, 08:59 PM
  4. Subs not working, help please.
    By lost1700 in forum General Discussion
    Replies: 32
    Last Post: 03-15-2007, 05:19 PM
  5. subs not working
    By kdubs56 in forum Wiring, Electrical and Installation Help
    Replies: 8
    Last Post: 06-27-2004, 01:20 AM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum