+ Reply to Thread
Results 1 to 12 of 12

Reload Thread: Is this normal for a brand new sub?

  1. #1
    Jason19's Avatar
    Jason19 is offline CarAudio.com Elite



    Join Date
    Jan 2004
    Location
    Kenosha Wisconson
    Age
    31
    Posts
    1,657
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Is this normal for a brand new sub?

    Delete
    Last edited by Jason19; 04-29-2014 at 11:46 AM.



    Head Unit - JVC Arsenal KD-ADV49

    Front Speakers - Precision Power PPI 356CS

    Subwoofers - Wanted Yo Buy

    Amplifier - 2 DD M3's 1 DD C4A

    Rear Speakers - ALPINE SPR-17C

    Memphis Line Driver




  2. #2
    hispls's Avatar
    hispls is offline CarAudio.com Veteran



    Join Date
    Sep 2009
    Location
    Cape Cod, Massachusetts
    Posts
    6,261
    Post Thanks / Like
    Images
    15
    Mentioned
    107 Post(s)

    Re: Is this normal for a brand new sub?

    LOL. Consider if you wanted to have 1000 comparable sized subs built in the USA with American made parts and American labor you'd pay more per piece than the MSRP of these things coming out of China. Yeah, there's a reason you get these so cheap. I'd also be interested to know what grade steel and ceramic is used.

    If it makes you feel better, I'm sure the 10 year old slave girl that made that one didn't get her pound of rice payment that day.




  3. #3
    michaellane's Avatar
    michaellane is offline CarAudio.com Veteran



    Join Date
    Oct 2005
    Location
    virginia beach
    Age
    28
    Posts
    9,749
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Is this normal for a brand new sub?

    Ok that made me laugh^^^^ but I do agree no matter where they are made they should arrive looking new. Then again if it was me id probably just use it. They are cheap already



    http://www.caraudio.com/forums/buyer-seller-feedback/414807-michaellane-feedback-if-i-bought-you-traded-i-sold-you-something.html

  4. #4
    BoomTaco64's Avatar
    BoomTaco64 is offline Senior VIP Member



    Join Date
    Jan 2014
    Location
    phoenix, az
    Posts
    428
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Is this normal for a brand new sub?

    crappy...thats horrible and i was going to buy them too. not anymore..




  5. #5
    michaellane's Avatar
    michaellane is offline CarAudio.com Veteran



    Join Date
    Oct 2005
    Location
    virginia beach
    Age
    28
    Posts
    9,749
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Is this normal for a brand new sub?

    Quote Originally Posted by BoomTaco64 View Post
    crappy...thats horrible and i was going to buy them too. not anymore..
    Its still a fine working nice driver for cheap.



    http://www.caraudio.com/forums/buyer-seller-feedback/414807-michaellane-feedback-if-i-bought-you-traded-i-sold-you-something.html

  6. #6
    BoomTaco64's Avatar
    BoomTaco64 is offline Senior VIP Member



    Join Date
    Jan 2014
    Location
    phoenix, az
    Posts
    428
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Is this normal for a brand new sub?

    that just shows not attention to detail. who in qc would let that go? horrible showing for any company. glue in excess and scratched but fixed with a sharpie..why not spray paint? its all in the details. i agree, a cheap driver. we will see..i will for sure keep this picture and ask about returns if i think about them again.




  7. #7
    Lowflyin's Avatar
    Lowflyin is offline Sit on my face, B*tch



    Join Date
    Dec 2010
    Location
    FU JOSE, PA
    Posts
    1,046
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Is this normal for a brand new sub?

    The glue is normal, the chipped magnet and sharpied basket I would be pissed about. I got a hdc3 from them (2-3 years ago) that had a lil extra glue but not bad.. The magnets aren't usually perfectly lined up either.



    Sold To: Epic0318, Alpine-Accord Bought From: JL Audio, SPLAudio, JS UltimateSounds, ShoelessJake


    This guys a winner...
    Quote Originally Posted by darron016 View Post
    I want to trade my amp but it is currently mounted to my trunk, how do I go about posting a picture with the date etc with it mounted? I can barely get to it

  8. #8
    BoomTaco64's Avatar
    BoomTaco64 is offline Senior VIP Member



    Join Date
    Jan 2014
    Location
    phoenix, az
    Posts
    428
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Is this normal for a brand new sub?

    a little extra glue is ok but a damaged(chipped edge) magnet, way too much extra glue, scratched basket. sorry, smells like a used/repaired motor to me.




  9. Thanks michaellane thanked for this post
  10. #9
    macsdad's Avatar
    macsdad is online now boom-boom



    Join Date
    Jun 2010
    Location
    birmingham, Al
    Posts
    1,360
    Post Thanks / Like
    Mentioned
    10 Post(s)

    Re: Is this normal for a brand new sub?

    So, a don't buy sq audio thread in the future, ala skar audio?




  11. #10
    jeffdachef's Avatar
    jeffdachef is offline I Bass Boost Rock/Metal!!



    Join Date
    Feb 2013
    Location
    Orange County, CA
    Posts
    2,620
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Is this normal for a brand new sub?

    @DJL ;

    wanna do some damage control here?



    Clip city b1tch, clip clip city b1tch. 10's, 12's, 15's, goin up in flames b1tch.
    2009 Sienna 3.5L Subs : C2 threatcon 15s. Sub amp: hifonics brx 2400.1D x 2
    Headunit: Pioneer 80PRS bought used from vertex audio Mids/Highs amp: PPI Phantom 900.4 - bought from dragnix
    Front stage: 3 way active front stage with Massive Audio CKX 6x9 component. ckx 6x9 midbass in doors + DB drive pro audio 6.5 in the kick. Rear stage: Jbl ms62C(Its a van I need rear fill). Still NOT ENOUGH! SEND HELP!! 4 Pro Audio 10s in the future
    320 amp Singer alt almost installed. Just a group 31 deka in the back atm with big 3 finished.

  12. #11
    DJL's Avatar
    DJL
    DJL is offline Owner, Audioque



    Join Date
    Dec 2004
    Location
    Stafford MO
    Posts
    438
    Post Thanks / Like
    Mentioned
    10 Post(s)

    Re: Is this normal for a brand new sub?

    Small chips on magnets can be found on any manufactures motors and are not considered defects nor do they degrade the performance of the subwoofer. The sub is designed with a magnet boot and comes with a boot. This subwoofer has a very heavy motor and we insist that the glue be applied generously to prevent magnet shifting. I do agree that the surplus glue could have been cleaned off the outside of the magnet surface even though it is covered by the magnet boot.

    My biggest concern is the scratch on the basket. I don't know who marked the scratch on the basket with the "sharpie". If the scratch was detected and marked while undergoing "QC" it should have been replaced. If the customer found the scratch and marked it with the "Sharpie" it simply means we missed it on our "QC" prior to shipping which can and does happen now and then when you ship 1000s of subs like we do. We do a power and rub test on each sub before shipping and look the sub over for cosmetic defects but sometimes a small scratch can get by.

    While the subwoofer in question is a perfectly functioning sub I am not in the business of shipping products with defects of ANY KIND. I have instructed our sales people to contact the customer and arrange for a replacement sub or a refund. I appreciate everyone's business and rest assured I will discuss this issue with the appropriate persons.




  13. Likes Booming liked this post
  14. #12
    jeffdachef's Avatar
    jeffdachef is offline I Bass Boost Rock/Metal!!



    Join Date
    Feb 2013
    Location
    Orange County, CA
    Posts
    2,620
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Is this normal for a brand new sub?

    Quote Originally Posted by BoomTaco64 View Post
    that just shows not attention to detail. who in qc would let that go? horrible showing for any company. glue in excess and scratched but fixed with a sharpie..why not spray paint? its all in the details. i agree, a cheap driver. we will see..i will for sure keep this picture and ask about returns if i think about them again.
    you speak as if every sub they put out has this problem lol.



    Clip city b1tch, clip clip city b1tch. 10's, 12's, 15's, goin up in flames b1tch.
    2009 Sienna 3.5L Subs : C2 threatcon 15s. Sub amp: hifonics brx 2400.1D x 2
    Headunit: Pioneer 80PRS bought used from vertex audio Mids/Highs amp: PPI Phantom 900.4 - bought from dragnix
    Front stage: 3 way active front stage with Massive Audio CKX 6x9 component. ckx 6x9 midbass in doors + DB drive pro audio 6.5 in the kick. Rear stage: Jbl ms62C(Its a van I need rear fill). Still NOT ENOUGH! SEND HELP!! 4 Pro Audio 10s in the future
    320 amp Singer alt almost installed. Just a group 31 deka in the back atm with big 3 finished.

+ Reply to Thread

Similar Threads

  1. Is this normal? breaking in a new sundown 18..
    By barber24alldaz in forum Subwoofers
    Replies: 16
    Last Post: 02-01-2010, 03:24 PM
  2. is this ok for a sub level control
    By fatboyracing in forum General Discussion
    Replies: 6
    Last Post: 05-16-2008, 08:21 PM
  3. Is this good for a final design for a sub box for my 05 XXX?
    By ls1pimp in forum Enclosure Design & Construction Help
    Replies: 4
    Last Post: 01-03-2007, 10:15 PM
  4. Is this normal for an Orion 2500d?
    By Rodeo91 in forum Amplifiers
    Replies: 21
    Last Post: 05-31-2006, 06:21 PM
  5. Replies: 15
    Last Post: 01-29-2006, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum