+ Reply to Thread
Page 6 of 7 FirstFirst 1 2 3 4 5 6 7 LastLast
Results 76 to 90 of 91

Reload Thread: Fi Audio 18BL warranty issue - failed after an hour of use

  1. #76
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!

    Threadstarter


    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,813
    Post Thanks / Like
    Images
    28
    Mentioned
    155 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    FYI - I sent a link to this post to my contact at Fi to allow them to justify their stance and to be fair. I disagree with talking about someone "behind their back". They have their reasons and are welcome to share.



    have you been helped by me? i'd love to know. shoot me a PM.

    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html]
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html




  2. #77
    skylineTT's Avatar
    skylineTT is offline bass=sekz



    Join Date
    Jun 2007
    Location
    Dallas/Raiderland
    Posts
    4,089
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    If they know how respected you are in the audio community, they may reconsider screwing you out of shipping costs. I would rebuild your sub as repayment for the wealth of knowledge you've given me. Lol



    Refs: Dipitydoo, appollyon, bad95gt, revrider1, jwh1598, ampjunkielikeme, deathpenalty18, ssackett, snoopysnooper, corey0928, SPLAudio, Clifff150, CL1CKCLACK, ShawnT, West + more

  3. Thanks supereikenator thanked for this post
  4. #78
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!

    Threadstarter


    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,813
    Post Thanks / Like
    Images
    28
    Mentioned
    155 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    UPDATE

    Finally received the replacement sub. I had communication with Fi several times. They still contend it is my fault and that I did something with wiring. They were very cooperative and ended up sending the repaired sub at no cost, even covered shipping and upgraded to a carbon fiber dust cap (may have been a stocking issue).

    Replacement is in, and again we adjusted gains. Now that the warranty is no longer valid (I was told this was a one-time thing) we have the sub hooked to both amps. And, of course, I took photos of my scope and DMM





    measurement of both amp outputs playing a 25Hz sine wave

    this demonstrates that both amps are in-phase electrically.

    setting gains with 0dB tone


    coil 1:


    coil 2:


    installed and operational:









    have you been helped by me? i'd love to know. shoot me a PM.

    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html]
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  5. #79
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!

    Threadstarter


    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,813
    Post Thanks / Like
    Images
    28
    Mentioned
    155 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    this sub was MUCH stiffer than the previous one. That was very evident. Also, four of the basket mounting holes had to be drilled out because the glue had hardened and was blocking the mounting holes.

    in the month since we pulled the sub, the Mayhem did just fine running off both amps. All we did was re-adjust gains for the different impedance load. We have no intention of the sub sustaining what both amps are capable of. But having headroom is always a good thing.



    have you been helped by me? i'd love to know. shoot me a PM.

    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html]
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  6. #80
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,259
    Post Thanks / Like
    Mentioned
    27 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Clean signals still blow subs, VC getting stinky was the warning sign. Hopefully this time the guy knows to back off when it starts to smell.

    You going to Cordova on Saturday for the dbdrag show, starts at 3:00?




  7. #81
    NIHL8ION's Avatar
    NIHL8ION is offline RUN ur car NOT ur mouth !



    Join Date
    Mar 2013
    Location
    IlliNOISE
    Posts
    1,354
    Post Thanks / Like
    Images
    22
    Mentioned
    5 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Looks good, now hopefully this one will actually stay together for awhile...




    - Cadence DCA2500.1 Running a Tantric HDD - 12" D2
    *Bought From: cx-7heaven, nutnbutcustm, naughtyca, agarabaghi, Skip01*Traded With: infamous_e46, basswiigee**Sold To: DeanG, R.S.D., livinloud!*
    Feedback Link: http://www.caraudio.com/forums/itrader.php?u=1028333

  8. #82
    slammedincouch's Avatar
    slammedincouch is offline CarAudio.com Elite



    Join Date
    Feb 2010
    Location
    Buffalo, NY
    Posts
    1,619
    Post Thanks / Like
    Mentioned
    8 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Quote Originally Posted by DDtC View Post
    Tensile leads use to catch the spiders on fire. User error as in way overpowering for most but come on.
    Quote Originally Posted by T.I.K. View Post
    Lol, yeah over-powering or not, I feel like those shouldn't catch fire.

    Back to this topic real fast...that's why they call it the BTL @T.I.K. - Broken Tinsel Leads



    Massive RK6's Front Stage (One set per door) > 07zx650.4
    Hertz HSK 165s in the trunk > Alpine 3542
    (6) 10" Sundown SA-10s > Kicker Warhorse
    Knu Krystal RCAs > lot's o' 0 gauge + Batts > Mechman 270a Alt

  9. Likes T.I.K. liked this post
  10. #83
    infamous_e46's Avatar
    infamous_e46 is offline hArRy_DaNgLeRs



    Join Date
    Jul 2008
    Location
    HaTeRs On My dlcK LiKe A JeAn ZiPpEr
    Posts
    25,916
    Post Thanks / Like
    Mentioned
    30 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    proved me wrong good to see it worked out



    Quote Originally Posted by RyanM923 View Post
    Damn, look at that midget ***...love me a midget ***. 3 foot 4 standing up, 3 foot 6 sitting down.
    Quote Originally Posted by michaellane View Post
    don dont come in here ruining my thread. i hate you and jose

    www.alphadamp.com
    Got Mad Feedback Son http://www.caraudio.com/forums/buyer-seller-feedback/364675-infamous_e46s-feedback-thread.html#post5697823

  11. #84
    SPLaudio's Avatar
    SPLaudio is offline CarAudio.com Veteran



    Join Date
    Feb 2009
    Location
    upstate ny
    Posts
    6,565
    Post Thanks / Like
    Mentioned
    284 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    glad to see everything worked out




  12. #85
    OldManBass's Avatar
    OldManBass is offline Senior VIP Member



    Join Date
    May 2013
    Location
    The Dirty South
    Posts
    227
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Quote Originally Posted by keep_hope_alive View Post
    this sub was MUCH stiffer than the previous one. That was very evident. Also, four of the basket mounting holes had to be drilled out because the glue had hardened and was blocking the mounting holes.

    in the month since we pulled the sub, the Mayhem did just fine running off both amps. All we did was re-adjust gains for the different impedance load. We have no intention of the sub sustaining what both amps are capable of. But having headroom is always a good thing.
    Awesome that it worked out, glad to hear Fi came through. My SSD's came with Carbon Fiber cones as well... I know they were out of copper coils for a while and they offered an upgrade to aluminum for free so they could get the subs to me faster but I wanted copper... guess they tossed the upgrade cones in to make up for the wait



    Clarion CZ702, PPI P900.4, PHD FB 6.1 Kit Pro, Digital Designs M2b, two Fi SSD 15"

    I can do all things through Christ who strengthens me. - Philippians 4:13

  13. #86
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!

    Threadstarter


    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,813
    Post Thanks / Like
    Images
    28
    Mentioned
    155 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Quote Originally Posted by mlstrass View Post
    Clean signals still blow subs, VC getting stinky was the warning sign. Hopefully this time the guy knows to back off when it starts to smell.

    You going to Cordova on Saturday for the dbdrag show, starts at 3:00?
    agreed.

    no, not going. i have other stuff going on.



    have you been helped by me? i'd love to know. shoot me a PM.

    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html]
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  14. #87
    bubbagumper6's Avatar
    bubbagumper6 is offline CarAudio.com Veteran



    Join Date
    Apr 2006
    Location
    The D
    Posts
    10,717
    Post Thanks / Like
    Mentioned
    10 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Quote Originally Posted by slammedincouch View Post
    Back to this topic real fast...that's why they call it the BTL @T.I.K. - Broken Tinsel Leads
    Bought my BTL used from a member on here years ago and it's outlived two amps and still wangs like it's brand new. It's an old school triple stack though so Idk if their issues were with specific generations or not.




  15. #88
    slammedincouch's Avatar
    slammedincouch is offline CarAudio.com Elite



    Join Date
    Feb 2010
    Location
    Buffalo, NY
    Posts
    1,619
    Post Thanks / Like
    Mentioned
    8 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Quote Originally Posted by bubbagumper6 View Post
    Bought my BTL used from a member on here years ago and it's outlived two amps and still wangs like it's brand new. It's an old school triple stack though so Idk if their issues were with specific generations or not.
    It's just a joke amongst the line. I believe it actually stands for built to last which is ironic for some people who had the lead problem. I've only owned a couple of the ufo series BTLs over the years



    Massive RK6's Front Stage (One set per door) > 07zx650.4
    Hertz HSK 165s in the trunk > Alpine 3542
    (6) 10" Sundown SA-10s > Kicker Warhorse
    Knu Krystal RCAs > lot's o' 0 gauge + Batts > Mechman 270a Alt

  16. #89
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!

    Threadstarter


    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,813
    Post Thanks / Like
    Images
    28
    Mentioned
    155 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    here is an interesting observation: playing the sub today the owner said he opened the doors and it was louder and seemed to play "easier". plenty of output but he is able to hit the "wall" in which you struggle to pressurize the cabin. not louder just because of reduced cancellation but louder because the sub doesn't have to work as hard - like a large sealed box vs. a large vented box.

    we are wondering if pressurizing the cabin is what resisted cone movement and caused over heating despite operating the sub in a fashion that would be fine without the additional cabin pressure. who else has noticed this?

    so for now, he is just going to take it easy and enjoy music through the Type-X comps and xtant amp.

    I still thing the sub lacks a sufficient heat sink and cooling for the price/market. the 12" Alphasonic Mayhem never had an issue in the same setup and had the same amount of output.



    have you been helped by me? i'd love to know. shoot me a PM.

    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html]
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  17. #90
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,259
    Post Thanks / Like
    Mentioned
    27 Post(s)

    Re: Fi Audio 18BL warranty issue - failed after an hour of use

    Normally you will be louder/have less backpressure on the sub with a window down or door open. Turns the box into a pseudo 6th order.

    If you're on the ragged edge then door open can lead to overexcursion/bottoming out. Lot of flat walls have that issue when playing low stuff...

    I would just tell him to be conscious of the music/freqs he's playing as higher stuff will heat the coil pretty quick if pushing a lot of power. And use the "smell-o-meter"

    Bummer you can't make it Saturday, got of us heading down for that one....




+ Reply to Thread
Page 6 of 7 FirstFirst 1 2 3 4 5 6 7 LastLast

Similar Threads

  1. Subwoofer sounds different after 10 hours of use problem?
    By eclipse3130 in forum General Discussion
    Replies: 40
    Last Post: 10-16-2012, 05:16 AM
  2. Replies: 1
    Last Post: 09-18-2010, 08:22 AM
  3. Speakers stopped working after 3 hours of use?
    By RoachForLife in forum General Discussion
    Replies: 3
    Last Post: 08-27-2008, 09:02 AM
  4. My 2 15" hdc3 alum are blown after 3 hours of use!
    By da box king in forum General Discussion
    Replies: 111
    Last Post: 08-14-2008, 11:53 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum