+ Reply to Thread
Results 1 to 12 of 12

Reload Thread: please help, sub not getting power

  1. #1
    ThunderOne's Avatar
    ThunderOne is offline Member



    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    please help, sub not getting power

    I just removed my entire interior and dynamatted the whole thing. I unplugged my amp and sub to remove the carpet. I left all the wires just hanging about and for a split second the 2 guage ground wire hit the power wire. It make an electrical spark so I checked the fuse and replaced it just in case. I plugged everything back in and now my sub is not getting any power. It has a slight amount of bass probably coming from the head units power. The amp is lit up but I'm not sure what's going on.

    Whats going on here? What did I do? I don't even know where to start. I guess I need to buy a multimeter now.







  2. #2
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    I checked the inline voltage via the connections at the amp. Good voltage going into it. But I'm not sure if the sub is getting fed power. Is it something with my amp?




  3. #3
    mylows10's Avatar
    mylows10 is online now Cali DC PHD & Tantric rep



    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    50
    Posts
    17,497
    Post Thanks / Like
    Images
    9
    Mentioned
    466 Post(s)

    Re: please help, sub not getting power

    Quote Originally Posted by ThunderOne View Post
    I checked the inline voltage via the connections at the amp. Good voltage going into it. But I'm not sure if the sub is getting fed power. Is it something with my amp?
    completely hook the amp back up except dont hook the sub wires to the amp ,turn on the deck and amp and put the dmm probes on the - and + speaker terminals on the amp .set the dmm on dc and see if you get readings




    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  4. #4
    mylows10's Avatar
    mylows10 is online now Cali DC PHD & Tantric rep



    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    50
    Posts
    17,497
    Post Thanks / Like
    Images
    9
    Mentioned
    466 Post(s)

    Re: please help, sub not getting power

    Quote Originally Posted by ThunderOne View Post
    I checked the inline voltage via the connections at the amp. Good voltage going into it. But I'm not sure if the sub is getting fed power. Is it something with my amp?
    completely hook the amp back up except dont hook the sub wires to the amp ,turn on the deck and amp and put the dmm probes on the - and + speaker terminals on the amp .set the dmm on dc and see if you get readings




    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  5. #5
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    Quote Originally Posted by mylows10 View Post
    completely hook the amp back up except dont hook the sub wires to the amp ,turn on the deck and amp and put the dmm probes on the - and + speaker terminals on the amp .set the dmm on dc and see if you get readings
    What readings should I be seeing? I checked the ohms earlier... all the speaker terminals read 2 ohms including at the amp, sub, box, and RCA cables. When I put it on voltage and touch the amp speaker terminals (on the dmm it is V~), it's just a tick above 0. If I put the dmm on V--- .. it just stays at 0. I'm not sure which of those is for DC... it's a simple dmm.. analog with a needle.




  6. #6
    tommydh's Avatar
    tommydh is offline Senior VIP Member



    Join Date
    Mar 2012
    Location
    Baltimore, MD
    Posts
    460
    Post Thanks / Like
    Images
    5
    Mentioned
    3 Post(s)

    Re: please help, sub not getting power

    the v ~ is ac the other is dc



    Pioneer DEH 80 PRS
    1 Sundown SD-2 10,
    Kicker SS56.2 components.(Soon to be changed out) Anyone with a set of these or maybe a single mid I'm looking
    Rockford Fosgate T-1000.1bd
    Pioneer GM6400f

    I am DH Audio.,
    This isn't baseball I'm the original DH Richard Ctranium

  7. #7
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    well then the DC setting isn't reading anything at all.




  8. #8
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    what does this mean?




  9. #9
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    Okay so after testing my amp and sub via headphone jack to RCA, seems to work fine. Replaced RCA cables with no success. I think the power wire touching said cable may have fried my HU subwoofer output terminals. So I guess I'll be getting a new HU. Live and learn!

    I will try to report back so the thread doesn't come to a dead end... hate that when I'm searching similar topics. More than likely the HU is the culprit.




  10. #10
    mylows10's Avatar
    mylows10 is online now Cali DC PHD & Tantric rep



    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    50
    Posts
    17,497
    Post Thanks / Like
    Images
    9
    Mentioned
    466 Post(s)

    Re: please help, sub not getting power

    does your hu have more rca outs




    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  11. #11
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    Yes, but not for a subwoofer. Only for speakers. Tried plugging them into other spots but it didn't work either.




  12. #12
    ThunderOne's Avatar
    ThunderOne is offline Member

    Threadstarter


    Join Date
    May 2012
    Location
    Tuscaloosa, Alabama
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: please help, sub not getting power

    The problem was the head unit. I think the positive wire touched the RCA wires and jacked up the terminals. Replaced the HU and all is well again.




+ Reply to Thread

Similar Threads

  1. Amp not getting power? Please help
    By MetalHead247365 in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 08-09-2011, 11:57 PM
  2. Please Help....sub not playing..help
    By bow125106 in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 05-16-2008, 06:31 PM
  3. PLEASE HELP, not getting power to HU!
    By ssj4nrs in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 11-01-2006, 05:04 PM
  4. PLEASE HELP! Not getting power to my HU
    By ssj4nrs in forum General Discussion
    Replies: 0
    Last Post: 11-01-2006, 04:46 PM
  5. help plz not getting enough power
    By rustycar in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 05-14-2004, 11:57 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum