Closed Thread
Results 1 to 5 of 5

Reload Thread: Why is my sub underperforming?

  1. #1
    Rooney's Avatar
    Rooney is offline Junior Member



    Join Date
    Apr 2013
    Location
    Utah
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Why is my sub underperforming?

    I have JVC receiver, a Sony Xplod 800 W amp (400 RMS, 800 peak), and a Rockford Fosgate punch 12" subwoofer (400 RMS, 800 Peak).

    The sub works fine...but the music from my speakers gets way too loud before the sub really starts hitting. All the settings on my amp and receiver are turned up all the way.

    Any ideas on how to fix it?? Do i need a more powerful amp? Better receiver?







  2. #2
    RicksI30's Avatar
    RicksI30 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Tucson, Az
    Age
    25
    Posts
    588
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub underperforming?

    What kind of enclosure?



    Head unit: Kenwood Excelon KDC-X996
    Front stage: Alpine Type X PRO mids Vifa Neo 1" silk tweeters
    Front stage amp: PPI Bk800.4
    Subs: SSA XCON 12's in 4.5 cubes tuned to 34hz
    Sub amp: PPI Bk1300.1
    Sound Deadening: Second Skin Damplifier Pro, Spectrum, and Sludge


    Team SSA

  3. #3
    chillin's Avatar
    chillin is offline CarAudio.com Elite



    Join Date
    Jan 2007
    Location
    Whistler, Canada
    Posts
    1,802
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Why is my sub underperforming?

    Uh. you need to learn how to set the amp. Everything all the way up is not the way it's done.



    Children are the future… today belongs to me!

  4. #4
    cfox10's Avatar
    cfox10 is offline Rock the house.



    Join Date
    Mar 2011
    Location
    Albany, Oregon
    Posts
    1,242
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Why is my sub underperforming?

    ^My first thoughts also... don't just turn everything up or you'll be buying a new system pretty soon.




  5. #5
    hispls's Avatar
    hispls is online now CarAudio.com Veteran



    Join Date
    Sep 2009
    Location
    Cape Cod, Massachusetts
    Posts
    6,118
    Post Thanks / Like
    Images
    15
    Mentioned
    105 Post(s)

    Re: Why is my sub underperforming?

    A sony xplode amp wouldn't make rated power if it were hit by lightning.




Closed Thread

Similar Threads

  1. Why is my sub humming loud with volume on 0 ?!?!?
    By noob with an RS in forum General Discussion
    Replies: 6
    Last Post: 07-06-2006, 03:11 PM
  2. Why is my sub cutting out at higher volume??
    By 97JeepTJ in forum Subwoofers
    Replies: 4
    Last Post: 06-20-2005, 05:36 AM
  3. why is my subs cut out
    By allsport513 in forum Amplifiers
    Replies: 16
    Last Post: 01-16-2005, 12:37 AM
  4. Replies: 0
    Last Post: 05-02-2004, 04:17 PM
  5. Why is my sub not hitting???????
    By coolman91985 in forum Subwoofers
    Replies: 10
    Last Post: 02-06-2004, 10:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum