Closed Thread
Results 1 to 5 of 5

Reload Thread: What Happened To My Subs???

  1. #1
    WeGoFootball20's Avatar
    WeGoFootball20 is offline Junior Member



    Join Date
    Dec 2001
    Location
    Illinois
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    What Happened To My Subs???

    Ok I have waited about three months to install everything i had. I first put in my head unit about four months ago. My whole car is Sony Prouducts. I have the CDM620 Sony head unit with a 760 watt Sony amp and two 12 inch Sony subs. I got them installed four stikin days ago, and now they dont work. Yesterday on Christmas Eve I helped jump start a guys car at work and then after that my subs dont work. My cd player works and it looks like my amp is getting power also but I dont really know much about this so if someone could help me out and tell me if this is minor or major. Thanks

    Brian <img src="confused.gif" border="0">







  2. #2
    ramos's Avatar
    ramos is offline Still learning



    Join Date
    Dec 2001
    Location
    Virginia
    Age
    49
    Posts
    10,329
    Post Thanks / Like
    Images
    8
    Mentioned
    6 Post(s)
    First thing check all the fuses and the wire connections. If everything is okay there, your amp should have three lights if I'm not mistaken. One is for power, the next one is over current, and the third one is thermal protection I think <img src="smile.gif" border="0"> The only one lit should be the power. Let me know after you check all of these things. And tel me what ou came up with <img src="smile.gif" border="0">



    5 % equipment
    90 % install
    5% beer

  3. #3
    <natem33>'s Avatar
    <natem33> Guest



    When you jump start a car you should hook up the jumper cables and let the car with the good battery run for about 10 minutes to charge the dead battery. Then disconnect the jumper cables and try to start the car with the bad battery. NEVER jump start a vehicle while directly connected to yours. It can send huge shocks through out your entire electrical system. Like Ramos said, check your fuses - in your amp, vehicle fuse box under the dash and under the hood, and also the main fuse on your amps power cable under the hood. If all checks out well there's a good chance that something got shocked in your car stereo. I learned about jump starting cars the hard way by blowing out my ICU computer module in my car- $850 - Ouch!




  4. #4
    BC_Andrew's Avatar
    BC_Andrew is offline Junior Member



    Join Date
    Dec 2001
    Location
    pitt meadows, bc, canada
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    k so what, never jump a car with your car, just disconnect it,?



    Pioneer deh-1000 deck<br />pioneer ts-a6975 6x9s<br />MTX road thunder subs,

  5. #5
    ramos's Avatar
    ramos is offline Still learning



    Join Date
    Dec 2001
    Location
    Virginia
    Age
    49
    Posts
    10,329
    Post Thanks / Like
    Images
    8
    Mentioned
    6 Post(s)
    As an added measure of safety take the main fuse out of your main power wire. If done properly it should be located right next to the battery anyway. This will keep any surges from harming your equipment <img src="smile.gif" border="0">



    5 % equipment
    90 % install
    5% beer

Closed Thread

Similar Threads

  1. What happened to the SKAR subs?
    By 45js45 in forum Subwoofers
    Replies: 79
    Last Post: 03-18-2011, 12:35 AM
  2. Headunit and subs fine, but what happened to my mids?
    By immasmokeu17 in forum General Discussion
    Replies: 18
    Last Post: 09-20-2008, 02:39 PM
  3. Ahh Subs Destroyed What Happened?
    By BlownEARdRUMS in forum Subwoofers
    Replies: 31
    Last Post: 09-14-2005, 02:09 PM
  4. What are the best subs the hradest hitting
    By <Burnsb7> in forum Subwoofers
    Replies: 17
    Last Post: 01-09-2002, 03:44 AM
  5. Replies: 5
    Last Post: 12-28-2001, 03:06 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum