Closed Thread
Results 1 to 11 of 11

Reload Thread: Why is my sub not hitting???????

  1. #1
    coolman91985's Avatar
    coolman91985 is offline CarAudio.com Elite



    Join Date
    Oct 2002
    Location
    Dallas
    Age
    28
    Posts
    551
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Why is my sub not hitting???????

    i have an elemental designs 15" k-series (older with e on cone). i turn my car on, the amp powers up, feeds the sub power, but it doesnt hit. when i push the cone surface in about 2 inches, it starts to hit somewhat. but when i let it go back to its natural position, it doesnt do anything. what is the problem? easy fix, or do i need another sub? any help is really appreciated...

    thanks







  2. #2
    thenewguy's Avatar
    thenewguy is offline Member



    Join Date
    Jan 2004
    Location
    AL
    Posts
    43
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    maybe the gain is not properly set...




  3. #3
    LBX2G's Avatar
    LBX2G is offline R.I.P Camofluage



    Join Date
    Jun 2002
    Location
    Warner Robins
    Age
    29
    Posts
    2,713
    Post Thanks / Like
    Images
    11
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    calll ed and ask them.



    FREE Terrelll"peanut" Grayer!!!!!!!!!!!!!!!!!!!!!!!!!!

    .

  4. #4
    Bill T.'s Avatar
    Bill T. is offline Senior VIP Member



    Join Date
    Jan 2004
    Location
    Wyoming
    Posts
    320
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    Sounds like wiring. If the VCs are wired out of phase, they cancel each other out.

    Bill T.




  5. #5
    coolman91985's Avatar
    coolman91985 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Oct 2002
    Location
    Dallas
    Age
    28
    Posts
    551
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    it worked for about 8-9 months and it just all of the sudden quit? so i dont think its the wiring...




  6. #6
    TheVanMan's Avatar
    TheVanMan is offline Why you looking here?



    Join Date
    Dec 2002
    Location
    Massachusetts
    Age
    31
    Posts
    888
    Post Thanks / Like
    Images
    10
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    Maybe one of the voice coils snapped? when you push the coil, you might have remade the connection but when it comes back out the connection breaks again. Take the sub out of the box and check it out.



    AOL s/n: Bramab
    Current Car: 2006 Jeep Grand Cherokee

    Current system (Always under construction):
    Head unit: Kenwood DNX5120
    Front Dash speakers: 3.5 midrange with DRT-25 Tweets
    Front Door speakers: (2) Dayton Reference RS225 8" woofers
    Rear Door speakers: Stock Boston Acoustic speakers (mostly faded out for slight rearfill)
    Sub amp: JL 1000/1
    Speaker amp: Eclipse EA4000
    Subwoofer: JL Audio 13W7
    Sub enclosure: 2.375 tuned to 30hz

  7. #7
    coolman91985's Avatar
    coolman91985 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Oct 2002
    Location
    Dallas
    Age
    28
    Posts
    551
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    i did take it out but i dont know what im looking for...any help?????




  8. #8
    joshpoints's Avatar
    joshpoints is offline CarAudio.com Veteran



    Join Date
    Jan 2003
    Location
    San Ma Tonga Central, CA
    Age
    30
    Posts
    3,165
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    Quote Originally Posted by coolman91985
    it worked for about 8-9 months and it just all of the sudden quit? so i dont think its the wiring...

    Speaker needs to be repaired. What's happening is the voice coil or tinsel leads have worn (probably from clipping) and when you push the speaker in is allowing the tinsel leads or voicecoil to make contact to the part of the circuti that has separated.




  9. #9
    helotaxi's Avatar
    helotaxi is offline Kilroy was Here



    Join Date
    Dec 2003
    Location
    South Central (New Mexico that is...)
    Age
    38
    Posts
    8,933
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    The "something" that you are hitting when you push on the cone is the backplate. You are bottoming the sub out. Sounds like you need to get the sub serviced. Most likely the leads have come apart. Take the sub out of the box, disconnect the wires and put an ohmmeter or continuity tester across each of the coils. Chances are you will find bad coils.



    Artificial Intelligence is no match for Natural Stupidity.

    Never underestimate the power of stupid people in large numbers.

    Life's tough...it's even tougher when you're stupid.

  10. #10
    coolman91985's Avatar
    coolman91985 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Oct 2002
    Location
    Dallas
    Age
    28
    Posts
    551
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    is there a way that i can fix it? i dont have any of those meters. will ed fix it for me?




  11. #11
    coolman91985's Avatar
    coolman91985 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Oct 2002
    Location
    Dallas
    Age
    28
    Posts
    551
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why is my sub not hitting???????

    is this covered in the warranty? will i just need to pay shipping? i bought it last march.




Closed Thread

Similar Threads

  1. Pioneer Sound shifts/cuts in & out when hitting bumps in the road
    By Karterius in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 12-22-2003, 03:06 AM
  2. Pioneer Sound shifts/cuts in & out when hitting bumps in the road
    By Karterius in forum Wiring, Electrical and Installation Help
    Replies: 0
    Last Post: 12-21-2003, 12:35 AM
  3. Wat Db wud I be hitting??
    By minx501 in forum Subwoofers
    Replies: 10
    Last Post: 10-24-2003, 12:59 PM
  4. i want some hard hitting 8's or 10's
    By phil7468 in forum Subwoofers
    Replies: 2
    Last Post: 09-08-2003, 11:05 PM
  5. Replies: 40
    Last Post: 09-06-2003, 12:46 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum