Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Reload Thread: my subwoofers arent hitting as hard as they should

  1. #1
    spenceyadigg's Avatar
    spenceyadigg is offline Junior Member



    Join Date
    Nov 2010
    Location
    los angeles
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    my subwoofers arent hitting as hard as they should

    i have 2 12" rockford fosgate punch2 in a box with a 3000w amp. i also have a jensen vm9312 headunit. i took them to a local car audio shop to get them installed but after the guy finished he said he hooked up my subs to the rear speaker outputs because my headunit only had a single subwoofer output. my subs dont seem to hit as hard as they could and i was wondering if this is because they are hooked up to the rear speakers. how can i get my subs to hit harder? thanks for the responses







  2. #2
    CHEMMINS's Avatar
    CHEMMINS is offline CarAudio.com Veteran



    Join Date
    Aug 2010
    Location
    Nevernever Land
    Posts
    4,081
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Ummmm.....why didn't he use the subwoofer output?



    References:
    kmarei, ge_off_me, AudioPipe, slim2fattycake, Louisiana_CRX, ARMed&Bangin, EXTREMECHEVYMAN, Dpc69ss, Psychoacoustics, Shinju, jonny101abc, snoopdan

    BUYING SILVER TOP TRF MOTORS



  3. #3
    CHEMMINS's Avatar
    CHEMMINS is offline CarAudio.com Veteran



    Join Date
    Aug 2010
    Location
    Nevernever Land
    Posts
    4,081
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Did he not hook up the amp?



    References:
    kmarei, ge_off_me, AudioPipe, slim2fattycake, Louisiana_CRX, ARMed&Bangin, EXTREMECHEVYMAN, Dpc69ss, Psychoacoustics, Shinju, jonny101abc, snoopdan

    BUYING SILVER TOP TRF MOTORS



  4. #4
    AllenH427's Avatar
    AllenH427 is offline CarAudio.com Elite



    Join Date
    May 2009
    Location
    Cincy Ohio
    Posts
    738
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Quote Originally Posted by spenceyadigg View Post
    i have 2 12" rockford fosgate punch2 in a box with a 3000w amp. i also have a jensen vm9312 headunit. i took them to a local car audio shop to get them installed but after the guy finished he said he hooked up my subs to the rear speaker outputs because my headunit only had a single subwoofer output. my subs dont seem to hit as hard as they could and i was wondering if this is because they are hooked up to the rear speakers. how can i get my subs to hit harder? thanks for the responses
    He used a LOC, I had that problem with my friends stock stereo, so we bought him an aftermarket stereo and now it sounds great.
    The great question remains... why didn't he use the subwoofer output? I'd ask for a refund, dude is clearly an idiot.



    TEAM XS POWER - MECHMAN - FI - AUDIOQUE
    152.1 OUTLAW AND CLIMBING, 4KW AT 40HZ

  5. #5
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    20
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Quote Originally Posted by CHEMMINS View Post
    Did he not hook up the amp?
    this



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  6. #6
    iLL Ridge's Avatar
    iLL Ridge is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    NC
    Age
    41
    Posts
    400
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    A lot of shops ****. I want to open up a good one.



    Piped-out 07 Altima on 22's
    2 optidrive 12's in 4.25cubes @30hz
    Kerf Port
    JL amps
    Pioneer components

  7. #7
    GotSPL?'s Avatar
    GotSPL? is offline Banned



    Join Date
    Nov 2010
    Location
    Miami
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    WHat amp do you have?




  8. #8
    spenceyadigg's Avatar
    spenceyadigg is offline Junior Member

    Threadstarter


    Join Date
    Nov 2010
    Location
    los angeles
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    my head unit has 5-channel preamp outputs (2 front, 2 rear, 1 sub). the rca cables dont fit into the 1 sub output so he connected the subs to the rear. would connecting them to the rear lower the bass though?




  9. #9
    iLL Ridge's Avatar
    iLL Ridge is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    NC
    Age
    41
    Posts
    400
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    ???? How do the rcas not fit?



    Piped-out 07 Altima on 22's
    2 optidrive 12's in 4.25cubes @30hz
    Kerf Port
    JL amps
    Pioneer components

  10. #10
    iLL Ridge's Avatar
    iLL Ridge is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    NC
    Age
    41
    Posts
    400
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Use this...



    Piped-out 07 Altima on 22's
    2 optidrive 12's in 4.25cubes @30hz
    Kerf Port
    JL amps
    Pioneer components

  11. #11
    n2caraudio's Avatar
    n2caraudio is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    California
    Posts
    459
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Is low pass filter set on the amp?




  12. #12
    n2caraudio's Avatar
    n2caraudio is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    California
    Posts
    459
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Also make sure that the head unit doesnt have a high pass filter turned on. Or just use a rca y connector and plug it into the sub out




  13. #13
    n2caraudio's Avatar
    n2caraudio is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    California
    Posts
    459
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Quote Originally Posted by iLL Ridge View Post
    Use this...
    Yes, that.




  14. #14
    GotSPL?'s Avatar
    GotSPL? is offline Banned



    Join Date
    Nov 2010
    Location
    Miami
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    Quote Originally Posted by iLL Ridge View Post
    Use this...
    Use it!




  15. #15
    spenceyadigg's Avatar
    spenceyadigg is offline Junior Member

    Threadstarter


    Join Date
    Nov 2010
    Location
    los angeles
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: my subwoofers arent hitting as hard as they should

    thanks i gonna buy one




Closed Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum