Closed Thread
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 54

Reload Thread: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

  1. #1
    Akrobatiks's Avatar
    Akrobatiks is offline Junior Member



    Join Date
    Sep 2010
    Location
    Chicago Il
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Ok so I have an 01 jeep grand cherokee limited and had my system installed at a very reputable place here in Chicago about 2 months ago. Here are the specs
    All Alpine:

    INA-w900 navigation unit
    2 9-inch headrest LCD's
    PDX-F4
    Type R Comps
    PDX-M12
    Type X 10 in a small custom built box

    Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!-myjeep.jpg
    Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!-jeeplcds.jpg
    Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!-myamps.jpg
    Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!-mysub.jpg
    Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!-myheadunit.jpg

    The problem I am having is that I keep blowing up subs! I have gone through 3 already and its only been 2 months!! Each time I bring it in they make adjustment and it sounds fine for a bit... one lasted like 3 weeks one lasted a month... I went back again today and they gave me another one, I watched them adjust and it sounded amazing for about 3 hours' and then out of nowhere it started buzzing again... It sounds like a fog horn every time it hits... Does anyone have any Idea on what could be causing these woofers to blow... I checked the gains and they are set to about 50%, which should be about 700 watts since the amp birth certificated rated it @ 1400, Crossover is set to just under 120hz, and my subwoofer level on my INA-w900 set at 10(scale from 0-15). Could this box be too small for that bad boy and causing the sub to fry soo easily? Im really frustrated having to keep taking my car back to the shop... Even though they keep giving me new subs for free, its getting redundant. Thanks in advance for any help you may be able to offer!!!
    Last edited by Akrobatiks; 09-04-2010 at 01:31 PM.







  2. #2
    audioholic's Avatar
    audioholic is offline Moderator



    Join Date
    Aug 2003
    Location
    Parts Unknown
    Posts
    23,586
    Post Thanks / Like
    Mentioned
    37 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Quote Originally Posted by Akrobatiks View Post
    I checked the gains and they are set to about 50%, which should be about 700 watts since the amp birth certificated rated it @ 1400
    Gains dont work that way. A gain setting of "50%" could make your amplifier clip quite easily, depending on the signal strength from your h/u.

    Hopefully the shop understands how to set gains better. Otherwise, that's is most likely your problem.



    No speaker, in the history of speakers, has ever been blown by too little power. Ever. I don't care what your friend told you, he's a dirty liar.


  3. Thanks nateberrier, benzmansl65amg thanked for this post
  4. #3
    RAM_Designs's Avatar
    RAM_Designs is offline SketchUp Master



    Join Date
    Feb 2006
    Location
    Rockwall, TX
    Age
    29
    Posts
    21,044
    Post Thanks / Like
    Images
    1
    Mentioned
    97 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    ^^^yep



    1,400+ designs since March 2011...
    I have my PM's turned off, please email at [email protected]

  5. #4
    snoopdan's Avatar
    snoopdan is offline Banned



    Join Date
    Dec 2005
    Location
    Louisville, KY
    Posts
    20,158
    Post Thanks / Like
    Images
    19
    Mentioned
    49 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    box looks a little small for me. But that wouldn't kill the sub anyways.




  6. #5
    kraudio12's Avatar
    kraudio12 is offline CarAudio.com Elite



    Join Date
    Sep 2009
    Location
    CP, Indiana
    Posts
    1,291
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Quote Originally Posted by audioholic View Post
    Gains dont work that way. A gain setting of "50%" could make your amplifier clip quite easily, depending on the signal strength from your h/u.

    Hopefully the shop understands how to set gains better. Otherwise, that's is most likely your problem.
    yah i was thinking this was the problem clipping the amp



    Refs
    Sold-Worstenemy453

    Bought-wccoug21,undadog,absoluteaudio,slim2fatty,finkster ,thelow,basscourt,truckcap22

    traded-Njstang,justadork2u,its450racer,basscourt,oxsign,t ruckcap22,

    BillJOnes42=Scammer
    http://www.caraudio.com/forum/showthread.php/460333-kraudio12-seller-buyer-thread?p=6920116

  7. #6
    Akrobatiks's Avatar
    Akrobatiks is offline Junior Member

    Threadstarter


    Join Date
    Sep 2010
    Location
    Chicago Il
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Honestly Im not pretending to be an expert.. That's why I spent a ton of money to have a professional install done but obviously there seems to be a problem here since they keep blowing. Im heading into the shop this morning to seriously sit down with them. I mean isnt this kinda ridiculous that this keeps happening over and over at high end shop? I dont touch any of the settings once they set it. I listen to my music and use the volume and thats it and they keep blowing...




  8. #7
    snoopdan's Avatar
    snoopdan is offline Banned



    Join Date
    Dec 2005
    Location
    Louisville, KY
    Posts
    20,158
    Post Thanks / Like
    Images
    19
    Mentioned
    49 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    If it was a high end shop, they'd of sold you a better sub




  9. Thanks nateberrier thanked for this post
  10. #8
    Akrobatiks's Avatar
    Akrobatiks is offline Junior Member

    Threadstarter


    Join Date
    Sep 2010
    Location
    Chicago Il
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Ok so what sub should I be using then...?




  11. #9
    snoopdan's Avatar
    snoopdan is offline Banned



    Join Date
    Dec 2005
    Location
    Louisville, KY
    Posts
    20,158
    Post Thanks / Like
    Images
    19
    Mentioned
    49 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    um, there are a ton of killer subs out there.

    I'll run some down for ya here


    FI Car Audio SSD or BL - https://ssl.perfora.net/www.ficaraud...iew.shopscript

    Audioque SDC - Audioque: Street Duty: SDC2.5


    Mach 5 Audio IXL - IXL-10 v2 SL [IXL-10 v2 SL] - $149.00 : Mach 5 Audio

    that will give you some reading material.




  12. #10
    thehardknoxlife's Avatar
    thehardknoxlife is offline CarAudio.com Veteran



    Join Date
    Sep 2005
    Location
    Knoxville, TN
    Posts
    2,789
    Post Thanks / Like
    Images
    1
    Mentioned
    1 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Quote Originally Posted by snoopdan View Post
    um, there are a ton of killer subs out there.

    I'll run some down for ya here


    FI Car Audio SSD or BL - https://ssl.perfora.net/www.ficaraud...iew.shopscript

    Audioque SDC - Audioque: Street Duty: SDC2.5


    Mach 5 Audio IXL - IXL-10 v2 SL [IXL-10 v2 SL] - $149.00 : Mach 5 Audio

    that will give you some reading material.
    I'd take the type X over the SSD, BL, or the SDC. Never heard the IXL. You acting like the Type X is a crap woofer, which it is not. I understand people around here like the so called underground brands, and for good reason, but that doesn't mean that all mainstream is crap when compared to them. The Type X is a really good woofer.

    Why not just stick to the topic instead of telling him to upgrade, which really wouldn't be an upgrade.




  13. Thanks jstbass, benzmansl65amg, TMali thanked for this post
  14. #11
    jco1385's Avatar
    jco1385 is offline expert jcologist



    Join Date
    Sep 2007
    Location
    Mobile, AL
    Posts
    18,120
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!



    i love my type x btw



    1994 Thunderbird
    JVC KD-AV7010
    Alpine 6x9 3-ways
    Pioneer 6x8 3-ways (rear)
    JVC CH-X1500 12-disc MP3 Changer
    Alpine Type X 12" 2 cubes @ 30hz
    MTX 404 runs the inside
    MTX 1501d runs the X
    Optima G75/25 RT up front
    2x Optima G31 YT in the trunk
    200a EA HO Alt (1/0 Big 3)
    ALL MY WIRE IS WELDING CABLE
    Quote Originally Posted by Johnny Drama View Post
    I always knew I was a feggot.
    Quote Originally Posted by Rashaddd View Post
    We're all feggots on the inside
    Quote Originally Posted by ToledoTom View Post
    I am sure the administration will be having a few words with you when they catch wind of your language.
    DO NOT SEND ME ANYTHING USING UPS. I WILL NOT DEAL WITH THEM EVER AGAIN
    OFFICIAL FEEDBACK THREAD

  15. #12
    audioholic's Avatar
    audioholic is offline Moderator



    Join Date
    Aug 2003
    Location
    Parts Unknown
    Posts
    23,586
    Post Thanks / Like
    Mentioned
    37 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Quote Originally Posted by Akrobatiks View Post
    Honestly Im not pretending to be an expert.
    I wasn't implying I thought you were acting like an expert. I was just trying to shed some light on the most likely cause of your problems.



    No speaker, in the history of speakers, has ever been blown by too little power. Ever. I don't care what your friend told you, he's a dirty liar.


  16. #13
    snoopdan's Avatar
    snoopdan is offline Banned



    Join Date
    Dec 2005
    Location
    Louisville, KY
    Posts
    20,158
    Post Thanks / Like
    Images
    19
    Mentioned
    49 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Quote Originally Posted by thehardknoxlife View Post
    I'd take the type X over the SSD, BL, or the SDC. Never heard the IXL. You acting like the Type X is a crap woofer, which it is not. I understand people around here like the so called underground brands, and for good reason, but that doesn't mean that all mainstream is crap when compared to them. The Type X is a really good woofer.

    Why not just stick to the topic instead of telling him to upgrade, which really wouldn't be an upgrade.
    where did you say I said the X was crap? Don't twist my words brochacho. I personally don't think they're all that great due to it's price and performance.

    As for sticking to the topic, I was trying to avoid saying that this is another case of a shop taking a customer for an expensive ride. Welp, too late now.




  17. #14
    benzmansl65amg's Avatar
    benzmansl65amg is offline CarAudio.com Elite



    Join Date
    May 2007
    Location
    Mobile AL
    Age
    25
    Posts
    1,905
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    It is probably a gain problem and 1400 watts seems like a little much for a single 10" type x that sub cant be more than 1kw rms



    Head Unit: Kenwood KDC-X996
    Components: Image Dynamics CXS62 V.2
    Amplifier: Rockford Fosgate T600-4
    Subwoofers: Image Dynamics IDQ10v3
    Electrical Upgrades: HO Alt and Big 3
    refs: trunks9_us, calikid, bassjunky, pickup1, bumpin buick, wgsj_fortvalley, holla105, Louisianacrx, pioneerspl1990, N2caraudio.com, terra, canyouhearmatt and many others

  18. #15
    TMali's Avatar
    TMali is offline I Can Dance If I Want To



    Join Date
    Oct 2009
    Location
    New Hope/Big Lake MN
    Posts
    2,864
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alpine Type x 10 keeps blowing.... Need Help Please!! PICS INCLUDED...!!!

    Quote Originally Posted by snoopdan View Post
    where did you say I said the X was crap? Don't twist my words brochacho. I personally don't think they're all that great due to it's price and performance.

    As for sticking to the topic, I was trying to avoid saying that this is another case of a shop taking a customer for an expensive ride. Welp, too late now.
    But see the thing has nothing to do with money here, he already has purchased the sub and im sure the shop has been replacing it for free. And the type X isnt all that badly priced



    http://www.youtube.com/watch?v=oHg5SJYRHA0

    Quote Originally Posted by dirtysouth31 View Post
    TMali new king of lulz
    Quote Originally Posted by N1ggaWeed View Post
    tmali can s#ck my girlfriends t1tties

Closed Thread
Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum