Closed Thread
Results 1 to 9 of 9

Reload Thread: HELP!! nasty probs with JL [Zane]

  1. #1
    tgkx's Avatar
    tgkx is offline Member



    Join Date
    Apr 2002
    Location
    Houston
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)

    HELP!! nasty probs with JL [Zane]

    I recently had two 12w6's put in my truck. They are mounted in a long box thats sealed and are running off a phoneix gold ti400.2. The problem I am having is that with some music (EX: Korn - Freak on a leash) the subs distort like dirty bastards. They cant hit the sound right for some reason and get a very nasty vibrating noise. This happens with a lot of songs from the Korn Follow the Leader cd. This type of music is just not playing right.

    I've spoken to the installers and they said I should get a new Head Unit with a crossover and eq built in. Currently I have a 10disk kenwood changer with RF mod. and factory radio and factory eq. I do not know if this is them trying to get more money out of me or honest advice of what I need. I've also heard that I should get an external 3 way crossover rather than a built in one into the radio from a friend.

    Please give me some solid advice on how to balance out this problem and best tune my system. Zane, I know JL Audio subs seem to be one of your favorites so I thought perhaps you could offer me the best insight here. Could this perhaps just be a kind of music that does not play well on any system? If you listen to the song I listened to above you'll know EXACTLY what kind of audio is causing me problems.

    Please help!!!

    -TGK







  2. #2
    adamawayfrommpa's Avatar
    adamawayfrommpa is offline Senior VIP Member



    Join Date
    Jan 2002
    Location
    North Carolina
    Age
    29
    Posts
    430
    Post Thanks / Like
    Mentioned
    0 Post(s)
    I'm not zane but I have a idea.....Since you only have a built in cross-over the subs may still be getting sound frequency that they can not handle....resulting in distrotion...hopfully for you zane will come and help..
    Adam



    http://images.andale.com/f2/107/107/3245322/1013574468219_744337.gif

  3. #3
    tgkx's Avatar
    tgkx is offline Member

    Threadstarter


    Join Date
    Apr 2002
    Location
    Houston
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)
    That sounds approximately what the installers said to me. I've been looking at crossovers and am considering getting a AudioControl EQX to do it all.

    Also I by no means meant that only zane could answer this question, please all input is welcome and thanks for commenting

    Any more opinions?




  4. #4
    adamawayfrommpa's Avatar
    adamawayfrommpa is offline Senior VIP Member



    Join Date
    Jan 2002
    Location
    North Carolina
    Age
    29
    Posts
    430
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Well I do have one more opinion....before buying that cross-over....check with zane....just to make sure that I'm not worng....good luck with it
    Adam



    http://images.andale.com/f2/107/107/3245322/1013574468219_744337.gif

  5. #5
    zane's Avatar
    zane is offline Bored.....



    Join Date
    Dec 2001
    Location
    Cedar Rapids, IA USA
    Posts
    1,887
    Post Thanks / Like
    Images
    9
    Mentioned
    0 Post(s)
    The Head Unit and Crossover are likely contributing to this matter, however, IMO the recording process on Korns Discs is appaling.....

    I have never had much luck in reproducing what you would call "quality" bass from a Korn Disc.

    What size and type of enclosure are you using?
    How is the bass on other selections of music?

    lets start with that and see whats going on.

    take it easy,

    -zane





    Webslave - www.SoundwavesCS.net


    "The man who goes alone can start today; but he who travels with another must wait till that other is ready."

    - Henry David Thoreau


  6. #6
    tgkx's Avatar
    tgkx is offline Member

    Threadstarter


    Join Date
    Apr 2002
    Location
    Houston
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)
    The enclosure I'm using is a long truck box with 2 chambers, seperated in the middle and both are sealed (would hollowing out the seperator make any difference to audio performance and quality?). Guestimating I'd say each chamber is about 1.5cu air space, I can measure tomorrow and get the exact # for you.

    Other selections of music sound pretty good but there are definately some others that have problems . I'll listen tomorrow and let you know some more specific bands/songs that are causing me problems.

    As far as Head unit and Crossover selection, do you think the AudioControl EQX would be a good product to finetune the audio? It seems like a very versatile product.

    I'm also trying to find a Head unit, right now i have a 10disk kenwood changer and if im correct dont I have to have a Kenwood head unit to continue controlling it? I'd like to get one with mp3 support and something that will allow me to continue using my changer. Metalic blue is my prefered color

    Thanks for taking the time at looking at this and if anyone has suggestions on headunits please hit me with them.

    -TGK




  7. #7
    jellydime's Avatar
    jellydime is offline Senior VIP Member



    Join Date
    Feb 2002
    Location
    Forest City, IA
    Posts
    216
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Two things that I would look at would be where your crossover is set now, if it is set too high with your gain up too much that could be causing problems, try lowering your xover frequency and lowering your gain a bit (I have found the way to figure this stuff out is to just play around with it till it sounds right)

    It could also be your box size...JL subs normally work better in smaller boxes and although I'm not certain, 1.5 cubic feet may be a little large for those subs.

    But whatever you do, do NOT take the center divider out!!!!! This would severely lower the quality of sound that you will get from your subs.

    The problem with this type of situation is that chances are it isn't one thing that is causing the trouble, but rather a few small things (some of which I may have mentioned) and it could be something to do with your factory radio...
    Hope this Helps!
    JELLYDIME




  8. #8
    dr. no's Avatar
    dr. no is offline Senior VIP Member



    Join Date
    Mar 2002
    Location
    Highlands
    Posts
    253
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Well man, I've got a kenwood excelon KDC-X917 and It's pretty **** fresh. Since you've got a kenwood changer you should take a look at some excelon. My model has crossovers for front, rear, and sub built in, makes life a lot easier. whatever you do replace your stock junk soon.




  9. #9
    tgkx's Avatar
    tgkx is offline Member

    Threadstarter


    Join Date
    Apr 2002
    Location
    Houston
    Posts
    39
    Post Thanks / Like
    Mentioned
    0 Post(s)

    New Update

    Took my truck to a respected car audio place (one that wont try and sell me things i dont need to fix my problem ) and I spoke to one of their techs. Turns out I have plenty of air space 1.25CU per chamber including the sub in there.

    Problem we came up with is when the subs hit really low its tearing apart the box. When we leaned up against the box HARD it would help cut down on the distortion I was getting. So monday I'm taking it in to have him nailgun and silicone the box to reinforce it. Its 5/8 or 3/4 MDF I believe and just needs some better anchoring.

    Chances are the box just was not nailed enough to hold the wood together when taking the deep constant sound. With the extra nails in it it should stop the wood from vibrating and hopefully solve all my problems .

    Thanks for the help and will let you know my results monday!

    -TGK
    Last edited by tgkx; 04-16-2002 at 07:25 PM.




Closed Thread

Similar Threads

  1. Help needed!!!! problem with Pioneer DEH-P725R
    By _J_D_Hogg in forum General Discussion
    Replies: 0
    Last Post: 05-31-2002, 02:38 PM
  2. Help me Please with Speakers
    By tuca33 in forum General Discussion
    Replies: 1
    Last Post: 05-16-2002, 07:53 PM
  3. help my out with these kenwoods
    By dbolm666 in forum Subwoofers
    Replies: 12
    Last Post: 03-26-2002, 01:04 PM
  4. Probs with Aiwa cd player/kenwood amp
    By IowaBoomer in forum Wiring, Electrical and Installation Help
    Replies: 0
    Last Post: 02-25-2002, 01:02 PM
  5. Will lead help or hurt with resonance?
    By Unregistered in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 01-23-2002, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum