Closed Thread
Results 1 to 2 of 2

Reload Thread: It's ben a long time but I'm back!! (with a ?)

  1. #1
    adamawayfrommpa's Avatar
    adamawayfrommpa is offline Senior VIP Member



    Join Date
    Jan 2002
    Location
    North Carolina
    Age
    29
    Posts
    430
    Post Thanks / Like
    Mentioned
    0 Post(s)

    It's ben a long time but I'm back!! (with a ?)

    Hi everyone. I haven't been here in like 2 months but anyway I've got questions for ya...
    As some of you know I have two 600w (peak) kenwood subs which are 160w RMS..
    My question is: Will a Legacy 1600w amp be enough to power my subs...I know that Legacy over-rates their amps so I want to know how much the amp will really give me, and will the power it gives me be enough for my subs?
    Thank you everyone
    Adam Chandler

    My Email:
    [email protected]



    http://images.andale.com/f2/107/107/3245322/1013574468219_744337.gif




  2. #2
    budgetSQ's Avatar
    budgetSQ is offline Basshead



    Join Date
    Mar 2002
    Location
    CT
    Age
    30
    Posts
    336
    Post Thanks / Like
    Mentioned
    0 Post(s)
    they're rated at 2x800.... so that's prob at 2 ohms and MAX
    so figure.... 2x200 rms? sounds about right
    aka they're crap



    -(1) Clarion 725
    -(2) Diamond M371i
    -(1) Diamond MacDaddy 12" UNIQUE (long throw) in a ported box
    -(1) 400w 4ch Crunch Drive Bridged
    -(1) 600w 2ch Crunch Drive Bridged

Closed Thread

Similar Threads

  1. A long time ago, pretty funny but wierd
    By sothrowd in forum Wiring, Electrical and Installation Help
    Replies: 0
    Last Post: 11-03-2007, 10:42 PM
  2. Replies: 18
    Last Post: 02-08-2003, 03:27 PM
  3. Long time no See!
    By Lord_Vegeta in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 02-05-2003, 07:58 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum