Closed Thread
Results 1 to 1 of 1

Reload Thread: Old rockford fosgate enclosure driver replacement

  1. #1
    Heide264's Avatar
    Heide264 is offline Member



    Join Date
    May 2009
    Location
    Pittsburgh, PA
    Age
    25
    Posts
    67
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Old rockford fosgate enclosure driver replacement

    So before I loaded the old enclosure in (ballpark 20 years old)... it had foam. Three hits later... it was rattling. All the foam had dryrotted to the point it fell off in three hits =P...

    ...So that leads to the next question - replacement drivers. I have an equally old USAmps150 powering them. It is a bandpass enclosure, and had two drivers in it (completely separate compartments to my knowledge facing away from each other). I always thought it had 2x8"s in it, but actually they feel kinda small now that the foam isn't there - gotta check to make sure they aren't six's or something strange. I am scared about replacing the drivers mainly for the reason it is a bandpass type box and not sure it will sound right at all. Might end up just building a whole new box at this point.

    Any suggestions on replacements? I found a pretty good deal on a set of JL 8" W1 series and was wondering if I should go for it.

    EDIT: Alright, I checked it out. The woofers actually do feel like 6" but I still haven't unbolted them and checked. Going to give refoaming them a shot - never know if that'll work out or not though. Box is pretty strange - It is a bandpass of some sort but the woofers are mounted in odd directions (Facing towards the front or back with the port hole facing upwards).
    Last edited by Heide264; 06-05-2009 at 02:09 PM.







Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum