Closed Thread
Results 1 to 5 of 5

Reload Thread: 130 amps, enough?

  1. #1
    smokeoff's Avatar
    smokeoff is offline here's my 3 cents



    Join Date
    Apr 2002
    Location
    Cambria,WI
    Age
    29
    Posts
    1,115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Icon32 130 amps, enough?

    I plan on running 4 subs, 2 off of 1 profile california mono amp and 2 off of another, I also have an aftermarket HU and A few Neons+ an underbody kit. I expect to be running around 800 watts and I don't want to ruin my car.







  2. #2
    bass_mekanik's Avatar
    bass_mekanik is offline i got 0.5 2 go til 145dbs



    Join Date
    May 2002
    Location
    Launceston Tasmania
    Age
    28
    Posts
    1,028
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    800 rms is not a significant ammount of power for an electrical systme to keep up to i have 970 rms and a completly stock electrical system and it goes fine



    Alpine 7892 Deck will get converted to am mp3 deck one day

    Apline DLC-176A splits

    Alpine MRD-M1000 sub amp i want 3 more

    Alpine MRV-T320 Split amp

    Alpine SWS-1241 woofers X2 they are mums i have better subs in store

    144.5 Db's worth on a linear X with mummys subs sealed wait till i port them and unleash the fury

    7 Months and 2 jobs later i am back louder smarter and alot poorer so watch yo asses cause i am back

    The aussie rice boi Slammed pulsar on 18's and tyres that are as thick as a condom :P

  3. #3
    BonusBobo's Avatar
    BonusBobo is offline Lightweight Sesh



    Join Date
    Oct 2002
    Location
    San Luis Obispo, CA
    Age
    28
    Posts
    1,650
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Originally posted by bass_mekanik
    800 rms is not a significant ammount of power for an electrical systme to keep up to i have 970 rms and a completly stock electrical system and it goes fine
    I agree with this. I have around 1000W coming out of my stock alt in my 93 explorer and the lights never dim. Then again I have a 1 farad cap that might be doing the trick.



    -AJ

    AIM: AJR775
    My CarDomain
    [email protected]

  4. #4
    bass_mekanik's Avatar
    bass_mekanik is offline i got 0.5 2 go til 145dbs



    Join Date
    May 2002
    Location
    Launceston Tasmania
    Age
    28
    Posts
    1,028
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    i have no cap but the lights dim a little when i get tones cranking but the voltage goes down to like 9 volts then



    Alpine 7892 Deck will get converted to am mp3 deck one day

    Apline DLC-176A splits

    Alpine MRD-M1000 sub amp i want 3 more

    Alpine MRV-T320 Split amp

    Alpine SWS-1241 woofers X2 they are mums i have better subs in store

    144.5 Db's worth on a linear X with mummys subs sealed wait till i port them and unleash the fury

    7 Months and 2 jobs later i am back louder smarter and alot poorer so watch yo asses cause i am back

    The aussie rice boi Slammed pulsar on 18's and tyres that are as thick as a condom :P

  5. #5
    smokeoff's Avatar
    smokeoff is offline here's my 3 cents

    Threadstarter


    Join Date
    Apr 2002
    Location
    Cambria,WI
    Age
    29
    Posts
    1,115
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    I like to be on the safe side but the way it sounds 130 amps will be more then enough.




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum