Closed Thread
Page 3 of 3 FirstFirst 1 2 3
Results 31 to 42 of 42

Reload Thread: JL W0 weak *** speaker

  1. #31
    ancorp's Avatar
    ancorp is offline Member



    Join Date
    May 2011
    Location
    Toronto
    Posts
    148
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL W0 weak *** speaker

    Big difference between JL 10W0 and 10W0V2 or V3.

    The original W0 is rated at 125w RMS. They should have no problem taking more (200-250) in a proper box so long as you don't let them bottom out.







  2. #32
    Worlddre's Avatar
    Worlddre is offline Big Darkie



    Join Date
    Sep 2004
    Location
    Charlotte, NC
    Age
    30
    Posts
    17,901
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL W0 weak *** speaker

    one of our shop demo cars is a 93 Accord with a pair of 12W0s in a 4th order bandpass porting through where the rear speakers would be. Subs are splitting 300w and it hammers






    "humility in the face of overwhelming genius will obviously amount to hypocrisy"

  3. #33
    vangore's Avatar
    vangore is offline Banned



    Join Date
    Jun 2012
    Location
    United States
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL W0 weak *** speaker

    11Same problem. I have Edmonton Escort Reference Version Edmonton Escorts 14 and an Asus G73Jh quad Edmonton Asian Escort core w lots of memory. Very fast on encoding to FLAC. All 8 cores used. Desperately slow going Edmonton Asian Escorts from FLAC to audio (not data) CD. Nero does it in 2 minutes or less.




  4. #34
    dragnix's Avatar
    dragnix is offline LXIX



    Join Date
    Dec 2006
    Location
    Socal cuz i'm So cool
    Posts
    19,628
    Post Thanks / Like
    Mentioned
    21 Post(s)

    Re: JL W0 weak *** speaker

    Quote Originally Posted by vangore View Post
    11Same problem. I have Edmonton Escort Reference Version Edmonton Escorts 14 and an Asus G73Jh quad Edmonton Asian Escort core w lots of memory. Very fast on encoding to FLAC. All 8 cores used. Desperately slow going Edmonton Asian Escorts from FLAC to audio (not data) CD. Nero does it in 2 minutes or less.
    Spamming old threads much?




  5. #35
    Bettr n' Revrse's Avatar
    Bettr n' Revrse is offline I do what I want



    Join Date
    Dec 2010
    Location
    Grand Junction, CO
    Posts
    16,839
    Post Thanks / Like
    Mentioned
    72 Post(s)

    Re: JL W0 weak *** speaker

    Quote Originally Posted by dragnix View Post
    Spamming old threads much?
    No shit!




    Western Rep.

    99 Honda CRV: (Always Changing) ___________ 79 F-150: Show Truck ________________
    -Head Unit: Eclipse CD7100________________ -Head Unit: Eclipse CD7100
    -Sub Stage: Sundown SD-2 8's sealed________ -Sub Stage: Looking
    -Mids/Highs: Deciding_____________________ -Mids/Highs: Scan Speak & Blaupunkt
    -Sub Amp: MMATS Hifi 6 channel____________ -Sub Amp: American Warrior Set (Zed Built)
    -Mid Amp: ^^^ 5/6 bridged at 1 ohm_________ -Mid Amp: ^^^

  6. #36
    rsnookie69's Avatar
    rsnookie69 is offline Junior Member



    Join Date
    Dec 2012
    Location
    chicago, IL
    Posts
    20
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL W0 weak *** speaker





  7. #37
    UnderFire's Avatar
    UnderFire is offline CarAudio.com Veteran



    Join Date
    Apr 2011
    Location
    Dayton, OR, 97114
    Posts
    2,043
    Post Thanks / Like
    Mentioned
    39 Post(s)

    Re: JL W0 weak *** speaker

    Quote Originally Posted by rsnookie69 View Post
    Back from the dead yet again...



    97 4runner, 3RZ, 5 Speed

    Headunit: Alpine CDA-9887
    Mids: CDT HD-6CF
    Tweets: CDT DRT-25
    Fronts Amp: Hertz HDP4
    Sub Amp: American Bass VFL150.1
    Substage: 18" SSA ZCON
    Electrical: 160 Amp Alt, Duralast Gold, C&D270FR, 2/0 Throughout

  8. #38
    Timmy13091's Avatar
    Timmy13091 is offline Team DC



    Join Date
    Apr 2012
    Location
    Chicago
    Posts
    2,900
    Post Thanks / Like
    Mentioned
    49 Post(s)

    Re: JL W0 weak *** speaker

    Quote Originally Posted by rsnookie69 View Post
    Really bro? Making the chi look bad




  9. Dislikes rsnookie69 disliked this post
  10. #39
    xShoWTeKx's Avatar
    xShoWTeKx is offline Drop Bass Not Bombs



    Join Date
    Jan 2011
    Location
    Greer S.C.
    Age
    25
    Posts
    1,198
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: JL W0 weak *** speaker

    Poast



    only vid
    http://youtu.be/8NRfhnWAo8o
    mobileaudioforum.com is better than CA.com in every way :o

  11. #40
    nvturbo's Avatar
    nvturbo is offline Member



    Join Date
    Nov 2012
    Location
    North Carolina
    Posts
    94
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL W0 weak *** speaker

    The W0 series is better than the WX's. They are decent subs if installed and wired correctly.



    2012 Volkswagen GTI 4dr
    * Factory RCD-510 H/U
    * MASSIVE AUDIO CK 6X 6.5 components
    * Alpine 3547 2-channel amp
    * Audison SR 1D monoblock amp
    * MASSIVE AUDIO TW10 10" sub in 1.36cu ft ported box (tuned @ 35Hz)
    * Streetwires OFC 4awg power/ground wires
    * Audio Control LC2i line output converter
    * Audio Control ACR-1 remote knob

  12. #41
    DoesDad's Avatar
    DoesDad is offline CarAudio.com Veteran



    Join Date
    Dec 2011
    Location
    Tulsa, OK
    Posts
    2,342
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: JL W0 weak *** speaker

    Let this fucking thread die already!!!




  13. Likes jeffdachef, wickedwitt liked this post
  14. #42
    Join Date
    Oct 2010
    Location
    clearwater, MN
    Posts
    82
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: JL W0 weak *** speaker

    never!!!



    kenwood 995
    Phoenix Gold Ti 2500.1
    Phoenix Gold Elite 12 x2
    33hz

Closed Thread
Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts

1e2 Forum