Closed Thread
Results 1 to 6 of 6

Reload Thread: Running 150rms to focal 165 KP's

  1. #1
    5150's Avatar
    5150 is offline Member



    Join Date
    Aug 2004
    Location
    CA
    Posts
    80
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Running 150rms to focal 165 KP's

    Is running Running 150rms to focal 165 KP's per side too much power? I am using the channels 1&2 on a 450/4....







  2. #2
    Join Date
    Jun 2004
    Location
    Saginaw, Mi
    Age
    28
    Posts
    1,847
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Running 150rms to focal 165 KP's

    The RMS rating on them is 80... that's almost double, so I'd say yes.





    I'm lazy...

  3. #3
    DBfan187's Avatar
    DBfan187 is offline Supa's mom was here!



    Join Date
    Jan 2003
    Location
    Poolside with Supa's mom.
    Posts
    46,452
    Post Thanks / Like
    Images
    12
    Mentioned
    1 Post(s)

    Re: Running 150rms to focal 165 KP's

    use a low gain, should be ight!




  4. #4
    5150's Avatar
    5150 is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    CA
    Posts
    80
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Running 150rms to focal 165 KP's

    Should I go up one step on the speakers or downgrade the amp to a 300/4?




  5. #5
    tplaya07's Avatar
    tplaya07 is offline CarAudio.com Elite



    Join Date
    Feb 2004
    Location
    Orlando, Fl
    Posts
    595
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Running 150rms to focal 165 KP's

    You should be fine with that amp and comps. Just don't go crazy with the gains or EQ settings. IMO, I would rather have the extra headroom, putting less strain on the amp, than having an amp that has to run at it's full RMS power all the time.




  6. #6
    5150's Avatar
    5150 is offline Member

    Threadstarter


    Join Date
    Aug 2004
    Location
    CA
    Posts
    80
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Running 150rms to focal 165 KP's

    Well I have blown the both crossovers, and blown 5 tweet's... Soo I don't know.. I think there was too much eq... The gain was not even up half way...




Closed Thread

Similar Threads

  1. Replace my Eclipse ALUM with a Focal 33K?????
    By Epitaph to War in forum Subwoofers
    Replies: 10
    Last Post: 02-10-2005, 06:22 PM
  2. Focal or Diamond Audio???
    By StreetAvalanche in forum Subwoofers
    Replies: 13
    Last Post: 09-16-2002, 06:41 PM
  3. Alpine vs Focal
    By Unregistered in forum Subwoofers
    Replies: 2
    Last Post: 01-22-2002, 08:38 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum