+ Reply to Thread
Results 1 to 5 of 5

Reload Thread: Cadence crossover question

  1. #1
    Staynlean's Avatar
    Staynlean is online now Senior VIP Member



    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    340
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Cadence crossover question

    The components are the Cadence cwm6 kit. The passive crossover has a setting that allows changing from -3db, 0db, +3db.

    Does changing that setting effect the woofer performance at all, or is just to attenuate the tweeters? I'm not sure, help me out.







  2. #2
    d77543020's Avatar
    d77543020 is offline CarAudio.com Veteran



    Join Date
    Dec 2005
    Location
    stockton ca
    Posts
    2,503
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Cadence crossover question

    It only affects the tweeters think of it is low medium high




  3. #3
    Staynlean's Avatar
    Staynlean is online now Senior VIP Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    340
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Cadence crossover question

    Well I can't, for the life of me figure out why my woofers sound so muddy and completely do not blend. They also sound weak, and have an echo sound to them. It's terrible.

    The tweets are set at -3db and are WAY over powering the entire front stage. I don't know where else to go besides trying to go active off the head unit and using the passive crossovers for only the tweets, ran off of HU power.

    I originally installed the tweets first off the HU using the crossovers and the door speakers were still stock.

    It sounded great! I'm at a loss at how to get better sound out of my woofers. They are Amped off a prime 300/4. So they should be getting abt 50 watts.

    Any and all help is appreciated.




  4. #4
    Staynlean's Avatar
    Staynlean is online now Senior VIP Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    340
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Cadence crossover question

    Anybody else, I understand and knew the -3db and all settings were for the tweets but I can't, for the life of me understand how chitty my woofers sound. It's worse then stock x10.

    Anyway, wtf can I do?

    And, BUMP!




  5. #5
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Cadence crossover question

    make sure the two mids are not out of phase..... check all your connections,crimps,crossovers wiring ect..... (are you sure that there is a problem? or are you expecting too much from the mids)?

    whats wrong with them? are you saying the tweeters are playing louder than the mids or sumthing?

    whats you HPF set to?




+ Reply to Thread

Similar Threads

  1. Crossover question
    By Inferno13 in forum Amplifiers
    Replies: 0
    Last Post: 06-07-2002, 07:37 PM
  2. EQ and crossover questions
    By Cl552k4 in forum General Discussion
    Replies: 1
    Last Post: 05-19-2002, 07:10 PM
  3. Crossover Question?
    By nofriends46 in forum Amplifiers
    Replies: 0
    Last Post: 04-25-2002, 03:23 PM
  4. Crossover question
    By Razorfist in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 03-28-2002, 04:19 PM
  5. Crossover question
    By Unregistered in forum General Discussion
    Replies: 1
    Last Post: 02-07-2002, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum