Closed Thread
Results 1 to 15 of 15

Reload Thread: Problem With My Tweeters

  1. #1
    Boofster's Avatar
    Boofster is offline Junior Member



    Join Date
    Apr 2013
    Location
    Florida
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Problem With My Tweeters

    I bought a pair of Pioneer TS - T110 tweeters a few days ago. I wired them in parallel to the door speakers i already have but whenever i turn up the volume they dont produce much sound at all. At best they can get about as loud as headphones. Any idea on why this would be happening?







  2. #2
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,388
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Problem With My Tweeters

    Tweeters alone do NOT make much sound at all.

    Also do you have a HPF on them or are they playing full range?




  3. #3
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,917
    Post Thanks / Like
    Images
    28
    Mentioned
    158 Post(s)

    Re: Problem With My Tweeters

    besides the question above, where are they? what impedance?



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://mobileaudioforum.com/forum/showthread.php?6722-KHA-2014-Accord-Sport-SQ-Factory-Integration
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  4. #4
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,418
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: Problem With My Tweeters

    Those tweeters have a 7000 Hz crossover - what were you expecting to hear?



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  5. #5
    Boofster's Avatar
    Boofster is offline Junior Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    Florida
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by maylar View Post
    Those tweeters have a 7000 Hz crossover - what were you expecting to hear?
    I was under the impression that they would play the vocals louder, I have two 15" subwoofers in my trunk and the bass is overpowering.




  6. #6
    Kingstroker's Avatar
    Kingstroker is offline Mr Dique



    Join Date
    Oct 2012
    Location
    Guthrie, OK
    Posts
    381
    Post Thanks / Like
    Images
    1
    Mentioned
    1 Post(s)

    Re: Problem With My Tweeters

    you need some mids that will work with the tweets. you have a biiiig gap in frequency



    '05 F250 King Ranch Crew Cab 4X4 Off Road Modded Powerstroke
    Rebuild in process
    Pioneer DEH 80PRS
    Modded Linear Power LP4753IQ
    Front Woofer: Infinity Kappa Perfect 6.5"
    Front Tweeter: SEAS Neos in pods
    Back: Pioneer TS-D6802R
    Knukonceptz Karma 12ga
    Stinger HPM3 RCA's
    Big 8: PhoenixGold Oga

  7. #7
    Join Date
    Apr 2013
    Location
    New Jersey
    Posts
    47
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem With My Tweeters

    2 15's in the trunk? Man talk about over kill, sell those things and get a single 12 inch with a 500 watt amp




  8. Dislikes basshead7890 disliked this post
  9. #8
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,388
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Problem With My Tweeters

    No, just step up your mids/highs. Mids play vocals, not tweeters...




  10. #9
    calebkhill's Avatar
    calebkhill is offline CarAudio.com Elite



    Join Date
    Dec 2012
    Location
    Phenix City, Alabama
    Posts
    1,101
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by Gonzalez1988 View Post
    2 15's in the trunk? Man talk about over kill, sell those things and get a single 12 inch with a 500 watt amp
    ? I have 2 15's and my SQ is killer.



    "When I listen to a stereo loudspeaker playback in my room and an auditory scene has formed in my mind, how would I know that what I hear is an accurate replica of an auditory scene that could be had at the recording venue? Or more generally, that this is an auditory scene that could have existed at all?"


  11. #10
    Boofster's Avatar
    Boofster is offline Junior Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    Florida
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by mlstrass View Post
    No, just step up your mids/highs. Mids play vocals, not tweeters...
    I'm dumb then, what exactly would the tweeters be playing?




  12. #11
    Boofster's Avatar
    Boofster is offline Junior Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    Florida
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by calebkhill View Post
    ? I have 2 15's and my SQ is killer.
    Yeah it doesn't sound bad, I just want to round everything off pretty much.




  13. #12
    calebkhill's Avatar
    calebkhill is offline CarAudio.com Elite



    Join Date
    Dec 2012
    Location
    Phenix City, Alabama
    Posts
    1,101
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Problem With My Tweeters

    Get a component set, you'll be straight. Tweets play upper end vocals and beyond



    "When I listen to a stereo loudspeaker playback in my room and an auditory scene has formed in my mind, how would I know that what I hear is an accurate replica of an auditory scene that could be had at the recording venue? Or more generally, that this is an auditory scene that could have existed at all?"


  14. #13
    Boofster's Avatar
    Boofster is offline Junior Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    Florida
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by calebkhill View Post
    Get a component set, you'll be straight. Tweets play upper end vocals and beyond
    I see, thanks for the answer.




  15. #14
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,388
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by Gonzalez1988 View Post
    2 15's in the trunk? Man talk about over kill, sell those things and get a single 12 inch with a 500 watt amp
    One would assume you have a vag




  16. Likes RickJamesYo, trumpet liked this post
  17. #15
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,917
    Post Thanks / Like
    Images
    28
    Mentioned
    158 Post(s)

    Re: Problem With My Tweeters

    Quote Originally Posted by Boofster View Post
    I'm dumb then, what exactly would the tweeters be playing?
    tweeters with a 7kHz crossover: the "esses" in vocals and cymbals.

    Have you told us what speakers you are running up front and what amp is on them?



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://mobileaudioforum.com/forum/showthread.php?6722-KHA-2014-Accord-Sport-SQ-Factory-Integration
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

Closed Thread

Similar Threads

  1. problem with my amp
    By themtwolefties in forum Amplifiers
    Replies: 4
    Last Post: 03-13-2005, 05:23 AM
  2. Problem with my Directed 1100D
    By 318iSPOLKMoMo in forum Amplifiers
    Replies: 3
    Last Post: 04-14-2003, 02:49 PM
  3. Problem with my and I need help!!!
    By Celicasav in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 04-08-2003, 08:07 AM
  4. another problem with my install
    By sportincamry in forum General Discussion
    Replies: 16
    Last Post: 09-24-2002, 10:43 PM
  5. Havin problems with my sub running, please help!!!
    By DYNO583 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 03-09-2002, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum