Closed Thread
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 46

Reload Thread: Bought set of tweeters, very quiet sound... are they blown/broken?

  1. #1
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member



    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Bought set of tweeters, very quiet sound... are they blown/broken?

    I bought a set of Pioneer tweeters, 30 bucks for a pair, and they have rave reviews everywhere I've looked. I have coaxial speakers in each of my doors and then a sub, but at head level there are several places in the car that the highs are very low and drowned out by road noise and mids/bass.

    I bought these tweeters to put more at head level on the door panels for each door. They are rated to handle 40 watts RMS but I don't have an amp to power them so I was going to run them off the head unit which can put out around 25.

    Since I don't yet have time to install them into the door panels, I decided I just wanted to test em out and see how they sound. I unplugged the front door speakers from my 4x50 watt amp and hooked up the tweeters to it. At first I couldn't tell if they speaker wire wasn't connected to the output terminals properly because I couldn't even hear the tweeters over the rear coaxial speakers (which were still plugged in). I ended up unplugging all of the door speakers and turned up my system nearly all the way to just see if they would get loud. Nope... not at all. With my 500 watt sub and my door speakers, I can't imagine i'll hear these things at ALL. Which doesn't make a lot of sense, because my coaxials are sharing 50 watts between a mid bass driver and a tweeter, whereas these tweeters get the whole channel to themselves.

    I was under the impression from reviews that the tweeters would scream, and really fill in the sound void. This is pretty underwhelming lol

    Here they are: Pioneer TS-T110 (tst110) 7/8" Hard Dome Tweeters

    Anyone know what the deal might be? I know I can return them but I want to know if this is the way it's supposed to be or not.







  2. #2
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Side note... only a pretty small amount of wire is coming out of the jacket on the stock speaker wire for these things... Could that possibly (probably unlikely) be the problem, that I need to expose more of the wire?




  3. #3
    Chriszle's Avatar
    Chriszle is offline CarAudio.com Elite



    Join Date
    Jan 2011
    Location
    SD
    Posts
    1,718
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Not sure why you aren't getting enough sound. One problem might be that your head unit does not put out 25 watts per channel. Probably more like 10 RMS.




  4. #4
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    I didn't hook it up to the head unit to test it, I hooked it up to my amp which can power it easily




  5. #5
    TheUnderFighter's Avatar
    TheUnderFighter is offline Beer Addict



    Join Date
    Mar 2011
    Location
    Murrieta, California, (SoCal)
    Age
    23
    Posts
    3,465
    Post Thanks / Like
    Images
    5
    Mentioned
    28 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    I'm not sure why you aren't getting any output.... But there are a lot of misconceptions and misunderstandings in your post. Too many to really point out for ya. If you wish to continue learning and growing in this hobby, I HIGHLY recommend you read around a lot more before you make another purchase. And read and reference this site, it has a TON of knowledge: Basic Car Audio Electronics

    That being said. I have on theory. You're getting minimal noise when just the tweeter is connected. And you're getting no high-end when the coaxial is connected. It sounds to me like you have a High-Pass filter set on your amp, and it's cutting off the high-frequencies. I'd suggesting turning the crossovers to off, or full, or pass-through, or whatever option it is, and see if that changes the sound for ya.



    2009 Hyundai Elantra - Budget Sound in Progress
    HU- Kenwood eXcelon KDC-X994
    Fronts- Crescendo MP6 mids, Vifa Ring Radiator tweets on Arc KS300.4
    Subs- Single SA-10 on Mmats 2000.1 @ 1ohm
    Misc- 1/0 CCA from AT, Big 3 in Stinger HPM, and AT 60 mil deadener
    Bought from: Inferno333, select127, treesive, Kangaroux, DonH
    Sold to: coolest user, Psychodrama, MidgetClown, mr.tigger, av83

  6. #6
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Quote Originally Posted by TheUnderFighter View Post
    I'm not sure why you aren't getting any output.... But there are a lot of misconceptions and misunderstandings in your post. Too many to really point out for ya. If you wish to continue learning and growing in this hobby, I HIGHLY recommend you read around a lot more before you make another purchase. And read and reference this site, it has a TON of knowledge: Basic Car Audio Electronics

    That being said. I have on theory. You're getting minimal noise when just the tweeter is connected. And you're getting no high-end when the coaxial is connected. It sounds to me like you have a High-Pass filter set on your amp, and it's cutting off the high-frequencies. I'd suggesting turning the crossovers to off, or full, or pass-through, or whatever option it is, and see if that changes the sound for ya.
    If you wouldn't mind, try to point out a couple misconceptions that you think I have. I've been working on my stereo for years and feel like I know a fair amount of what's going on.

    My amp is always set to all pass, I deal with HP and LP filters on my headunit. The tweeters I bought have an in-line crossover so I understood that should take care of the crossover issue, although not as effectively as an external crossover would. My headunit has my speakers hi-passed at 100 hz, but even still with the inline crossover that seems to be mostly irrelevant.




  7. #7
    pickup1's Avatar
    pickup1 is offline Audiosystem,Dynaudio...



    Join Date
    Aug 2005
    Location
    Roanoke,TX
    Age
    49
    Posts
    7,617
    Post Thanks / Like
    Images
    19
    Mentioned
    29 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Were the tweeters new when you bought them? Is the crossover made for the pioneers? Crossover point?




  8. #8
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Yes the tweeters were new, the crossover point is 7k and it's an inline crossover that came with the tweeters.

    Thanks for the website Underfighter.. lot of good info in here. Been reading for about an hour.

    Maybe I was just expecting something different, I don't really know. I don't have much experience with tweeters I was just expecting more sound. Maybe it's a lower freq range that I'm missing...

    Any other thoughts guys?




  9. #9
    av83's Avatar
    av83 is offline CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,864
    Post Thanks / Like
    Mentioned
    50 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Quote Originally Posted by ckunke002 View Post
    Yes the tweeters were new, the crossover point is 7kand it's an inline crossover that came with the tweeters.
    Thanks for the website Underfighter.. lot of good info in here. Been reading for about an hour.

    Maybe I was just expecting something different, I don't really know. I don't have much experience with tweeters I was just expecting more sound. Maybe it's a lower freq range that I'm missing...

    Any other thoughts guys?
    That crossover point does seem quite high. Unless it's a REALLY gentle slope, but that would still be less than ideal. Most people really don't need more than two tweeters in their entire car. I would try either adding more power to the front coax's, and if that doesn't work, switch to a component set.



    80prs
    RF t800.4, CDT es-6mo, DD T2
    2 MB Quart DSC1500.1 strapped on 1 Tantric HDD 12
    Mike Singer 310 amp 6 phase
    2 runs of Monster Cable 1/0

  10. #10
    pickup1's Avatar
    pickup1 is offline Audiosystem,Dynaudio...



    Join Date
    Aug 2005
    Location
    Roanoke,TX
    Age
    49
    Posts
    7,617
    Post Thanks / Like
    Images
    19
    Mentioned
    29 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Yea...but you should be able to hear them pretty good on 50x2....I'm running 2-8 ohm (really 5 dc ohm) Dynaudio tweeters on an Audison 60 x2 and they get loud.




  11. #11
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Quote Originally Posted by av83 View Post
    That crossover point does seem quite high. Unless it's a REALLY gentle slope, but that would still be less than ideal. Most people really don't need more than two tweeters in their entire car. I would try either adding more power to the front coax's, and if that doesn't work, switch to a component set.
    The slope is 6 db/octave. This might sound dumb but, a component speaker set is simply a set of mid-bass speakers and tweeters... how would that solve my treble problem? Just because components are often higher quality than coaxials? Because I already have the tweeters... Just more details would help




  12. #12
    av83's Avatar
    av83 is offline CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,864
    Post Thanks / Like
    Mentioned
    50 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Quote Originally Posted by ckunke002 View Post
    The slope is 6 db/octave. This might sound dumb but, a component speaker set is simply a set of mid-bass speakers and tweeters... how would that solve my treble problem? Just because components are often higher quality than coaxials? Because I already have the tweeters... Just more details would help
    Because more "treble" comes from the mids than you think, that's why I brought it up. Honestly, they should get kinda loud on fifty watts each. Try another source of power. If they still don't have much sound, return/exchange them.



    80prs
    RF t800.4, CDT es-6mo, DD T2
    2 MB Quart DSC1500.1 strapped on 1 Tantric HDD 12
    Mike Singer 310 amp 6 phase
    2 runs of Monster Cable 1/0

  13. #13
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    How much did your audison cost you? And yeah it's hard to say... any other thoughts?




  14. #14
    ckunke002's Avatar
    ckunke002 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    Clackamas, OR
    Posts
    491
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    Quote Originally Posted by av83 View Post
    Because more "treble" comes from the mids than you think, that's why I brought it up. Honestly, they should get kinda loud on fifty watts each. Try another source of power. If they still don't have much sound, return/exchange them.
    Any suggested brands for a good component set? Could it maybe be that my 4 channel full range amp simply doesn't cover >7k very well?




  15. #15
    mlstrass's Avatar
    mlstrass is online now Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,386
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Bought set of tweeters, very quiet sound... are they blown/broken?

    you've never heard just tweeters playing and expected more, happens all the time. People seem to have no idea how little sound comes out of just tweeters.....And I run a ton of supertweeters and by themselves it's still not very loud.

    Play them WITH the coax's and you should notice a diff up top, but if you need more overall volume then get better speakers/more power...




Closed Thread
Page 1 of 4 1 2 3 4 LastLast

Similar Threads

  1. WTB: Nice set of tweeters.
    By NewAgeKing in forum Wanting to Buy (WTB) - Car Audio
    Replies: 13
    Last Post: 07-27-2008, 05:17 AM
  2. WTT: Two Kicker 6" Midbass drivers for a nice set of tweeters (pics in thread)
    By reed dollaz in forum Wanting to Buy (WTB) - Car Audio
    Replies: 8
    Last Post: 03-14-2008, 11:16 AM
  3. Adding set of Tweeter TO Rainbow
    By acura2005 in forum Speakers
    Replies: 4
    Last Post: 11-18-2006, 01:05 PM
  4. WTB"Nice Set Of Tweeters
    By bassdude in forum Wanting to Buy (WTB) - Car Audio
    Replies: 0
    Last Post: 09-20-2005, 09:04 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum