Closed Thread
Results 1 to 3 of 3

Reload Thread: Help! Tweeters fade and shut off

  1. #1
    rjay's Avatar
    rjay is offline Senior VIP Member



    Join Date
    Sep 2010
    Location
    oklahoma city
    Posts
    323
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Help! Tweeters fade and shut off

    So I just changed out my components and amp, but am now having problems. I have a RF Punch P1000X5D amp and it puts out 75 watts to each of my front component sets. Front components which are CDT HD62im with CDT 550i crossovers are supposed to handle up to 150 watts (I believe) but when I crank it up the tweets fade and shut off and then will come back on when I lower the volume. I don't understand my gains should be good and I'm not giving them full power or anything. My Boston Acoustics SC60's never had this problem? Do I just have some bad tweeters or what could be the problem? Thanks



    My simple but pleasing setup

    Kenwood Excelon KDC-X497 HU
    Rockford Fosgate Punch P1000X5D 5 channel amp
    CDT HD62im front components w/ CDT 550i crossovers
    Image Dynamics IDQ10D4v3 sub (sealed enclosure)
    Audio Technix Sound Deadener
    Knu Konceptz Kolossus 4ga amp kit




  2. #2
    myjaja's Avatar
    myjaja is offline Audioque



    Join Date
    Sep 2006
    Location
    San Antonio, Tx Posts: 143,632 _____<^>*_*<^>_____
    Posts
    3,624
    Post Thanks / Like
    Mentioned
    34 Post(s)

    Re: Help! Tweeters fade and shut off

    Thats the tweeter protection kicking in from the crossovers. It does that to keep you from blowing your tweeters.



    Refs: sbcaprice305, mattmcss, systembumping, LeofromtheH, audiobahnuser18, stishdr, wcarson8911, jnoel, mr_kebo, 93 saturn sl2



    HU: Home stereo converted to dc
    Speakers: Stock
    Subs: 6 1/2 home sub
    Amp: off the stereo
    Wiring: extended power cord
    neon lights: Christmas lights duct taped to frame

  3. #3
    rjay's Avatar
    rjay is offline Senior VIP Member

    Threadstarter


    Join Date
    Sep 2010
    Location
    oklahoma city
    Posts
    323
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Help! Tweeters fade and shut off

    Quote Originally Posted by myjaja View Post
    Thats the tweeter protection kicking in from the crossovers. It does that to keep you from blowing your tweeters.
    That's kind of what I was thinking, but I'm confused on why since I'm only giving half the rated power.



    My simple but pleasing setup

    Kenwood Excelon KDC-X497 HU
    Rockford Fosgate Punch P1000X5D 5 channel amp
    CDT HD62im front components w/ CDT 550i crossovers
    Image Dynamics IDQ10D4v3 sub (sealed enclosure)
    Audio Technix Sound Deadener
    Knu Konceptz Kolossus 4ga amp kit

Closed Thread

Similar Threads

  1. Quick Help Please! Alpine Amp shutting off...
    By mikey7182 in forum Wiring, Electrical and Installation Help
    Replies: 0
    Last Post: 01-22-2008, 08:02 PM
  2. Replies: 5
    Last Post: 10-12-2007, 10:40 PM
  3. Power Shuts off to amps and other components HELP!!
    By ephyouckay in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 06-28-2007, 03:20 PM
  4. music goes and shuts off...not cool
    By marleyskater420 in forum Wiring, Electrical and Installation Help
    Replies: 21
    Last Post: 08-10-2003, 11:59 PM
  5. System shuts off.... HELP!!!
    By Audioz in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 09-10-2002, 09:41 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum