Closed Thread
Results 1 to 6 of 6

Reload Thread: Why do my speakers sound like *****?

  1. #1
    foreman's Avatar
    foreman is offline CarAudio.com Elite



    Join Date
    Nov 2003
    Location
    NY
    Age
    41
    Posts
    1,725
    Post Thanks / Like
    Images
    1
    Mentioned
    1 Post(s)

    Why do my speakers sound like *****?

    Ok, i need a hand here. I'm running 6.5's in my doors, 5.25's and tweets in my kicks, and i have a 4 channel Soundstream ref414s amp for power. I have an incredible set of 3 way passives i bought from a friend, but they are not biampable. I want more control over my midbass, but when i run the 5.25 comps of the passives, and the 6.5's off the amp, i lose all my midbass...With the passives, the midbass is great....Oh, i'm using one set of rca's to the amp and running the parallel switch for the rca's(soundstream, remember?)







  2. #2
    kappa546's Avatar
    kappa546 is offline CarAudio.com Elite



    Join Date
    Oct 2003
    Location
    KY
    Age
    29
    Posts
    945
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Why do my speakers sound like *****?

    im not sure if i understand this correctly, but... why not use two channels for the 5 /14 and tweets (with 2 way x-over)high passed at whatever, and use the midbasses off the other two channels. thats just how i understood your problem



    -Andres

  3. #3
    kappa546's Avatar
    kappa546 is offline CarAudio.com Elite



    Join Date
    Oct 2003
    Location
    KY
    Age
    29
    Posts
    945
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Why do my speakers sound like *****?

    wait nvm i still dont understand what the problem is... disregard the post



    -Andres

  4. #4
    Pete's Avatar
    Pete is offline Senior VIP Member



    Join Date
    Feb 2004
    Location
    Minneapolis, MN
    Age
    34
    Posts
    234
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Why do my speakers sound like *****?

    check the phase relationship between the 6.5 and the 5.25 when you try running the 6.5 straight off the amp... you may need to add some time correction.

    Another thing you may want to consider is putting an eq in the chain before the amp and then not worry about biamping at all.



    Kenwood Excelon x811
    CDT Audio HD-62 in custom kicks
    MTX Amp for CDTs
    Kicker ZR360
    ??? need to decide on a new sub

  5. #5
    helotaxi's Avatar
    helotaxi is offline Kilroy was Here



    Join Date
    Dec 2003
    Location
    South Central (New Mexico that is...)
    Age
    39
    Posts
    8,933
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)

    Re: Why do my speakers sound like *****?

    Don't run a passive network without all the drivers it was meant to have connected. You could damage your amp as that portion of the passive will appear to the amp to be a dead short.

    That aside, did you have the amp bridged to the whole shebang before when you were using the whole passive setup? If so that is why you don't have the midbass performance that you had before, you have maybe a 1/3 of the power going to the midbasses.

    If I were you, I would just run the passive network and the extra power of the bridged channels.



    Artificial Intelligence is no match for Natural Stupidity.

    Never underestimate the power of stupid people in large numbers.

    Life's tough...it's even tougher when you're stupid.

  6. #6
    foreman's Avatar
    foreman is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2003
    Location
    NY
    Age
    41
    Posts
    1,725
    Post Thanks / Like
    Images
    1
    Mentioned
    1 Post(s)

    Re: Why do my speakers sound like *****?

    Right, i had it bridged into 2 channels...I'm feeding the 6.5's a solid 75-80 watts by themselves, but i guess that's not enough. Now i'm using a low pass filter from the amp, and the mids can't take the subbass.... Is there an electronic crossover out there that can do what i'd like it to do? Run the midbass bandpass around 40-250hz, then the mids from 250-2500, then the tweet up?




Closed Thread

Similar Threads

  1. unbalanced speakers, advice?
    By Sharp_Shoota in forum General Discussion
    Replies: 4
    Last Post: 02-23-2004, 02:40 AM
  2. Clarion DXZ925 no sound from HU??
    By fuqxyu in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 02-14-2004, 12:40 PM
  3. Sound Storm
    By Spawn20 in forum Amplifiers
    Replies: 11
    Last Post: 01-29-2004, 04:59 AM
  4. New speakers distorting.
    By slothy in forum Speakers
    Replies: 4
    Last Post: 12-05-2003, 03:25 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum