User Tag List

Closed Thread
Results 1 to 7 of 7

Reload Thread: Going active on Phoenix gold rsd65cs

  1. #1
    UMWDawg92's Avatar
    UMWDawg92 is offline CarAudio.com Elite



    Join Date
    Jun 2010
    Location
    Missoula, MT
    Age
    23
    Posts
    1,209
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Going active on Phoenix gold rsd65cs

    Hey everyone this is my first post so I'd like to say thanks in advance for any help or advice. Well I just got myself a set of the pg rsds and a kenwood x4r 4 channel and I'm wondering if it is worth going active on this set? the amp has built in dsp and parametric eq along with alot of crossover settings. So I'm wondering if It would be good to disconnect my rear fill and run two channels to the woofers and the other two to the tweeters? And if so what crossover points would be good? oh if you're not familiar with the amp its rated at 100 rms x4 at 14 volts







  2. #2
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    38
    Posts
    1,172
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Going active on Phoenix gold rsd65cs

    You shouldn't have any problems doing that, just set the gains for the tweets to be ~50 watts. The tweets had been known to have issues blowing even when used w/the passive crossover.

    The mids can handle the 100 watts all day long so you should be fine there too.

    Set the xover between 2.5k - 3k Hz.

    I run mine, for now, in a 3-way actively passive set up. Rsd6 mid, rsd3 mid and memphis pr-15 tweets. I wouldn't say one of my PG tweets blew, but one doesn't work anymore. When I took them out for a while to run a totally different setup it worked, but when I went to put them back in, one was dead.




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

  3. #3
    UMWDawg92's Avatar
    UMWDawg92 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2010
    Location
    Missoula, MT
    Age
    23
    Posts
    1,209
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Going active on Phoenix gold rsd65cs

    Thanks for the help! the other thing I was thinking is how would running the passive crossover work with bridging the amp to run 300 rms x2, or is that way too much power? And another thing this made me think of is if I run active should I invest in a sound processor especially since I am running off of a factory HU from a LOC (I don't have any other choice in my car)




  4. #4
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    38
    Posts
    1,172
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Going active on Phoenix gold rsd65cs

    I wouldn't put more then 150-175 watts through the passive network.

    I personally would get a sound processor. Between the processing power my HU has (Eclipse CD8455) and the Audio Control DQS,m I'm set.




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

  5. #5
    thehardknoxlife's Avatar
    thehardknoxlife is offline CarAudio.com Veteran



    Join Date
    Sep 2005
    Location
    Knoxville, TN
    Posts
    2,789
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Going active on Phoenix gold rsd65cs

    Quote Originally Posted by smgreen20 View Post
    I run mine, for now, in a 3-way actively passive set up. Rsd6 mid, rsd3 mid and memphis pr-15 tweets.
    Is that the whizzer cone 3"? I tried for a while to source a pair of those. Sell them to me now.




  6. #6
    UMWDawg92's Avatar
    UMWDawg92 is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Jun 2010
    Location
    Missoula, MT
    Age
    23
    Posts
    1,209
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Going active on Phoenix gold rsd65cs

    I think I'll try going active on them then. As far as sound processors go, any reccomendations? I was looking at the Hifonics HFEQ or the soundstream XBP10. Any better in that price range? (about 80-120)




  7. #7
    smgreen20's Avatar
    smgreen20 is offline phoenixphorum-com



    Join Date
    Apr 2005
    Location
    Lafayette,IN
    Age
    38
    Posts
    1,172
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Going active on Phoenix gold rsd65cs

    I'd have to look into processors. I haven't looked at to many sense I got my DQS.


    thehardknoxlife,
    Those would be the ones, only problem is, the mounting tabs have been cut off and they each have a tare in the surround where the screws I used managed to pinchingly twist a rip in them. I'd still sell if you'd want them, they sound fine.




    My install
    http://phoenixphorum.com/viewtopic.php?f=10&t=16998

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum