Closed Thread
Results 1 to 3 of 3

Reload Thread: Speaker Problem?

  1. #1
    TheJuggla1's Avatar
    TheJuggla1 is offline Senior VIP Member



    Join Date
    Apr 2009
    Location
    Surrey BC
    Posts
    248
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Speaker Problem?

    I got the 3 way kicker 6x9 running off a 4 channel JL Amp 500W (I forget the model It does like 100 Watts each channel, but can do 125 each if you have like 2 ohm speakers or something like that)

    When I get to a certain point in volume and then turn it up even one more it will seem like the speakers are getting quieter(Seems the Deeper the voice the lower I have to keep the volume but if it is a high voice I can sometimes put it up a few more, although increasing or decreasing the Bass doesn't seem to effect how high I can turn up the volume before the voice 'quieten'), the amp has 4 Gauge and a battery right next to it so I don't see power being a problem? However I have walmart boxes(This is my guess) and I am thinking either the internal speaker wiring in the boxes are bad or the 'entrance' clip thing to get the power inside the box is bad, thoughts?(What gauge of speaker wire do you recommended for these?)

    Other problems I asked the shop where I bought these speaker said it could be something on my HU doing it? It is an alpine(Bought it like a year ago is the higher end model with 6 Buttons to the right of the volume control) I could also think my HU might not getting enough power? I am still using the 'stock' power slot on it that is wired into the Ignition.

    Also what Gauge of wire should I send from my mono(1000W Alpine) to subs (2x L5 15 Kickers)?







  2. #2
    rollinonD's's Avatar
    rollinonD's is offline Member



    Join Date
    Nov 2008
    Location
    Islip, NY
    Posts
    120
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Speaker Problem?

    Odds are that those 6x9's need more power.



    Quote Originally Posted by DrChronic View Post
    Well living in the country with all the blacks, ive seen boxes built out of just about anything. Drywall, plywood, chip board, 5 gallon buckets, desks, etc.
    Not looking for another 18

  3. #3
    TheJuggla1's Avatar
    TheJuggla1 is offline Senior VIP Member

    Threadstarter


    Join Date
    Apr 2009
    Location
    Surrey BC
    Posts
    248
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Speaker Problem?

    I check my amp spec its 80RMS Watts it puts out not 100RMS Watts. However my 6x9 take up to 90RMS Watts, but this happens when they aren't even turned that high. I have maybe the gain at 3/4 On the amp and my HU(Alpine) at 18/35 Volume(It starts doing it after 19/35) before it starts to do this. Lower the Treble might let me put the volume higher by 1 or 2.

    My old amp I am not sure but Loudness wise,I think I can recall I could turn it up a lot louder(But being a shitter amp it would distort a bit) but it wouldn't seem like how it quietens like it does now.




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum