Closed Thread
Results 1 to 2 of 2

Reload Thread: Why wont my speakers work? Thanks

  1. #1
    Londo9's Avatar
    Londo9 is offline Junior Member



    Join Date
    Jan 2010
    Location
    NY
    Posts
    15
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Why wont my speakers work? Thanks

    I hooked up 2, 4ohm MB quart speakers to a 2 ohm amplifier to get some better highs however when I turn it up the speakers cut out. I wired the speakers in parallel because of the ohm difference. In fact I wired each speaker individually from the HU to each speakers to discount any factory interference by the nuisance tweeters in the doors. HELP? Thanks







  2. #2
    Slo_Ride's Avatar
    Slo_Ride is offline Midnight Rider



    Join Date
    Oct 2005
    Location
    Atlanta
    Posts
    7,758
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Why wont my speakers work? Thanks

    Quote Originally Posted by Londo9 View Post
    I hooked up 2, 4ohm MB quart speakers to a 2 ohm amplifier to get some better highs however when I turn it up the speakers cut out. I wired the speakers in parallel because of the ohm difference. In fact I wired each speaker individually from the HU to each speakers to discount any factory interference by the nuisance tweeters in the doors. HELP? Thanks
    This part confused me, sounds like you may have wired them wrong.



    Refs = PapaGeno21, Goindef154, 92c1v1c, Disarmer, chemmins, 97maxima, kroid777, ithertz, basscort2009, hunterw, mar08052, appleyard, millimac247, jonny101abc, sundownz, cranberryyumyum, mig139, daboyfrumdabx, skateguy92, basebalz13.

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum